zone alarm/network query

Discussion in 'Home Networking' started by Me, Nov 13, 2004.

  1. Me

    Me Guest

    Greetings

    I have just set up a network between my desktop PC and a laptop but when
    Zone Alarm (free version) is running on the PC, I can't "see" the laptop. As
    soon as I disable Zone Alarm, there is the laptop and I can move stuff
    to-and-fro. Can anyone advise please on whether I can tell Zone Alarm to
    accept the signal from the laptop - and if so, how? The laptop is just using
    XPs own firewall at present.

    I'm using a Linksys modem/router (WAG54G). This is hardwired to an ethernet
    card on the PC. The laptop has a Linksys wireless adapter card.

    This has been setup to test if the network will work, in readiness for going
    broadband (now ordered).

    I know the router has built in firewall stuff, but I've seen in newsgroups
    that it's advisable to have a software one as well.

    All help appreciated.
     
    Me, Nov 13, 2004
    #1
    1. Advertisements

  2. Me

    mikeFNB Guest

    routers & XP firewall only against protect incoming , i'll spray that
    again.......

    routers & XP Firewall only protect against incoming attacks, they do not
    prevent outgoing 'phone-home' or mailer virus etc.
    so run ZA on every machine with access to the outside world via however!.

    you might possibly need to add the ip range / ip of the laptop / gateway
    into all trusted zones of any ZA you run.

    mike
     
    mikeFNB, Nov 13, 2004
    #2
    1. Advertisements

  3. Me

    Me Guest

    Thanks Mike, I'll try to sort that. Didn't realise routers firewalls had the
    same limitation as XP
     
    Me, Nov 13, 2004
    #3
  4. What you're saying is true but only with the routers default settings. My
    Netgear router can be set to block all outgoing ports and then you allow
    only the ones you require. I don't know about other makes of router.
     
    Graham Watson, Nov 13, 2004
    #4
  5. Me

    IbroxJim Guest

    snip

    You need to identify the laptop as being on the the "trusted network"
    any easy way to do this is to remove Zonealarm and replace it with Kerio
    Personal Firewall. Kerio is very easy to to set up in this type of
    situation -- it tries to idenify the trusted network at installion and
    ask you to verify or customize the address ranges it finds. After that
    it will initially ask you to confirm as each applcation is run if it is
    ok t let contact the outside world and the same for incommimg
    connections untill it builds up a set of rules.
    The version of Kerio I use is 2.1.4 I fnd this version simpler better
    and slimmer than the version 4.x.x Version 2.14 of Kerio can be found
    at computercops.biz
     
    IbroxJim, Nov 13, 2004
    #5
  6. Me

    Rob Morley Guest

    While many routers can be configured to control outgoing connections on
    a per-port basis, software firewalls can do it on a per-application
    basis - this tends to be rather more useful when it comes to stopping
    malware from getting out.
     
    Rob Morley, Nov 13, 2004
    #6
  7. Me

    phoenix Guest

    That's exactly the way Zonealarm works with the exception that it *does*
    identify the Trusted Zone. ;-)

    Regards

    Bill
     
    phoenix, Nov 13, 2004
    #7
  8. Me

    IbroxJim Guest

    Very true, I know with Kerio a specfic application can be restricted to
    a specific port, specific protocol AND a specified internet end point
    address. Kerio also runs an MD5 checksum which flags if the
    applications exe has changed.
    But I like the added protection of a hardware firewall be it on the
    ADSL-Router or better still running on a PC running IPCop or similar.
     
    IbroxJim, Nov 13, 2004
    #8
  9. Me

    Me Guest

    So going back to my original query, why didn't Zone Alarm allow me to
    contact my laptop - is it because ZA was already installed before the
    network was set up?
     
    Me, Nov 14, 2004
    #9
  10. Me

    mikeFNB Guest

    yes, often happens, i then to disc the internet then disable ZA, get network
    working, re-enable ZA, reconnect internet.
    works most times

    mike
     
    mikeFNB, Nov 14, 2004
    #10
  11. Me

    phoenix Guest

    Yes, as Mike has already mentioned, that's probably the reason.

    The easiest method of setting up ZA from scratch (without a re-install) is
    to delete the rules database. You can do that by unchecking the 'Load ZA at
    startup' option and rebooting so that ZA isn't active. Go to the \Internet
    Logs directory (usually under your \Windows dir) and delete *all* the files
    in there (keep any *.txt log files yoy may need) the restart ZA. You will
    have to authorise all your programs again or put ZA in Learn mode for a
    couple of day but it should solve your problem, do that on each PC that ZA
    is installed. Don't forget to check the 'Load ZA....' option s it starts
    automatically after each reboot.

    Regards


    Bill
     
    phoenix, Nov 14, 2004
    #11
  12. Me

    Me Guest

    Thanks to you and all other responders. Now in action and understanding
    increased.
     
    Me, Nov 15, 2004
    #12
  13. Me

    phoenix Guest

    Glad you're sorted. :)

    Regards

    Bill
     
    phoenix, Nov 15, 2004
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.