"Your computer needs a Windows Certificate"????

Discussion in 'NZ Computing' started by ~misfit~, Aug 5, 2012.

  1. ~misfit~

    ~misfit~ Guest

    Ok, bought a Nokia 3710 Fold to replace my damaged 2720 Fold and, on going
    to the Nokia NZ website support page for this model:
    http://www.nokia.com/nz-en/support/product/3710-fold/ I'm told that the
    'Nokia PC Suite' that I've been using to backup my 2720 is being replaced
    with 'Nokia Suite'. (Using my T60 laptop running XP Pro, fully updated.)

    Ok, I figure new phone, new software so, after transferring contacts etc.
    from a 2720 backup file to the 3710 using PC Suite I uninstall Nokia PC
    Suite (and all entries starting with 'Nokia' in 'Add and Remove
    Programmes'). Defrag, reboot and go to install the Nokia Suite (~90MB) that
    I just downloaded.

    Straight away I get an error that tells me what's in the subject of this

    "Your computer needs a windows certificate. The Windows authentication
    certificate (VeriSign Primary Intermediate CA Certificate) is missing from
    your computer. Before you can install Nokia Suite, please install the

    The last bit is an hyperlink that takes me to:
    and I'm baffled. What?

    So I ring Nokia NZ and get an Asian who speaks English with an American
    accent. Twenty-five minutes later I'm told that it's a Microsoft issue and
    am given MS NZ's 0800 number - only to get a recorded message to call back
    during business hours.

    Now, I dont think that this is an MS issue and that, come tomorrow, if I
    call, I'll end up chasing my tail for ages, getting increasingly frustrated.

    Can anyone here help me please? The Nokia software doesn't ask you to select
    an OS, in fact the file is called Nokia_Suite_webinstaller_ALL.exe, so I
    assume that the 'ALL' bit is all OSes (or at least all [relatively] current
    Windows versions.



    "Humans will have advanced a long, long, way when religious belief has a
    cozy little classification in the DSM."
    David Melville (in r.a.s.f1)
    ~misfit~, Aug 5, 2012
    1. Advertisements

  2. ~misfit~

    Enkidu Guest

    Have you tried installing the certificates? It is likely that removing
    the Nokia software also (incorrectly) removed the certificates too.


    Enkidu, Aug 5, 2012
    1. Advertisements

  3. ~misfit~

    Gordon Guest

    hey, just open you wallet/bank account to MS. All will be well.

    Be warned gentle reader, the OS you use is more important than the hardware.
    Gordon, Aug 5, 2012
  4. I think all you need to do is install those certificates:


    Nokia seems to have used a certificate to sign the code for the Nokia
    Suite that is too new to have matching authority certificates in XP
    SP2. Installing the matching certificates fixes that. So it is a
    Nokia problem - they should have used certificates that supported XP.
    But it is easily fixed.

    That Symantec/VeriSign page is also bad - it should have given the
    proper installation instructions, and preferably an explanation also.

    As well, the Nokia installer should have given you an option to
    proceed with the install without checking the signing.
    Stephen Worthington, Aug 5, 2012

  5. Why is this user still using SP2 , SP3 has been out for some time.
    Frank Williams, Aug 5, 2012
  6. ~misfit~

    ~misfit~ Guest

    Thanks Stephen, and all who replied. An IT friend of mine who reads this
    group emailed me the fix last night, I thought that I should post it here so
    that the folks who tried to assist me know how to get around this issue:

    Simply go here:
    <http://www.microsoft.com/en-nz/download/details.aspx?id=29434> and, once
    you've downloaded and run the 1.5MB 'Genuine Advantage' test to make sure
    your install is legit you are free to download and install the root

    After that all went perfectly. I'm still bemused as to why Nokia included a
    hyperlink to Symantec/VeriSign when, with a link to that MS page I would
    have had the software installed with only a couple minutes extra rather than
    the ~45 minutes I spent Googling (without finding the answer), 25 minutes on
    the phone to Nokia and then having to rely on the kindness of others to sort
    it out for me.

    Thanks mate (you know who you are <g>). I hope you don't mind me posting
    this follow-up, I know your knowledge is your bread-and-butter and undersand
    that if you give it away freely and randomly you don't get to eat. However
    this group (or at least the core of legit members whom I've 'known' for over
    a decade) have been good to me and I wanted those who invested their time
    trying to help me to know the answer.


    "Humans will have advanced a long, long, way when religious belief has a
    cozy little classification in the DSM."
    David Melville (in r.a.s.f1)
    ~misfit~, Aug 6, 2012
  7. ~misfit~

    ~misfit~ Guest

    Somewhere on teh intarwebs Stephen Worthington wrote:
    Ah, sorry, I replied as a 'thread tie-up' without following your link. So
    *that's* how to use those blocks of text! I read to save them with a *.cer
    affix elsewhere but not how to import them into XP. I tried putting them in
    the Windows folder, the folder I was trying to install the Nokia software
    from, almost everywhere on my machine (but didn't 'action them)! I must find
    and delete them all now.

    I didn't find anything about how to use them, as is detailed in your link.
    Thanks. I can't say if it works as I did it the other way but it's obvious
    that your Google-fu is stronger than mine!

    (Or maybe I should have just gone to the Nokia forums in the first place,
    although I *did* look in the 'FAQs' for the software with no luck.)


    "Humans will have advanced a long, long, way when religious belief has a
    cozy little classification in the DSM."
    David Melville (in r.a.s.f1)
    ~misfit~, Aug 6, 2012
  8. ~misfit~

    ~misfit~ Guest

    Somewhere on teh intarwebs ~misfit~ wrote:
    Hmmm, updating the root certificates for Windows seems to have had at least
    one other effect (and I've hardly done anything on my machine today!).

    I use OE (with OEQuoteFix) for newsgroups (I know, I know...) and, for some
    reason, on this T60 I've never been able to view messages with a fixed font,
    even though it's been selected in the 'Format' drop-down menu. (I've needed
    it from time-to-time for when folks post tables, as they do in the F1 group,
    and have had to resort to cut'n'pasting text into notepad.) Anyway, now it
    works differently[1]. Odd, in the close to three years I've been using this
    machine it hasn't worked and updating the root certificates has fixed it.
    <ponders> I wonder if there are other changes to my software?

    [1]When I say 'differently' I can select 'Plain Text' or 'Rich Text (HTML)'.
    However, I used to be able to, if plain text was selected, then select from
    a sub-menu, if I wanted fixed spacing or not. As it stands I don't have that
    option, it's fixed spacing (which I'm having a bit of trouble with right
    now) or HTML - and I'd never post HTML to usenet. Hmmm.... First-off I'll
    re-start OE....


    "Humans will have advanced a long, long, way when religious belief has a
    cozy little classification in the DSM."
    David Melville (in r.a.s.f1)
    ~misfit~, Aug 6, 2012
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
There are no similar threads yet.