XP WPA-PSK key length issue

Discussion in 'Wireless Networks' started by hello, Feb 25, 2005.

  1. hello

    hello Guest

    I want to use a long pass phrase at least 40 characters. I
    can do that with my D-Link WAP however Microsoft Windows XP Pro SP2 is
    does not allow me to enter a very long pass phrase.

    Is there something I am missing with Windows OS that will let me enter
    a longer pass phrase. That is the main reason I switched from WEP to
    WPA so I could enter a long pass phrase making the amount of time one
    would have to sniff my wireless traffic to hack me much longer. At
    least that is my understanding of it from the books I have read.


    Sam Cederas
    Raleigh, N.C.
    hello, Feb 25, 2005
    1. Advertisements

  2. hello

    Niklas Guest

    With WPA, the passphrase can be between 8 and 63 characters.
    What does the error say?

    Niklas, Feb 25, 2005
    1. Advertisements

  3. hello

    hello Guest

    I do not get an error echoed back to me because I have just "assumed"
    that it is not working because of the following:

    On my access point (DLink DI-514) I enter the long passphrase that I
    want to use successfully. Every character I type is echoed back to me
    on the screen. No problem there....
    I go to my laptop. The laptop 1 year old and I have Windows XP SP2
    installed. I go to the wireless setup that is part of XP and type in
    a passphrase. I have been using a short passphrase say 15
    characters. With that setup when I type the passphrase in I get a
    series of asterisks echoed back every time I enter a character. One
    asterisk for every character typed. I type it in again to confirm.
    NO PROBLEM there as that setup worked fine.

    Now today I went back into the laptops wireless configuration and
    decided to change my passphrase after doing so successfully on the
    D-Link access point. Here is what I noticed and assume this is a
    problem. I type my new passphrase in the wireless setup on the
    laptop...after I start typing the passphrase... I dunno say 16 or so
    characters.... the asterisks stop echoing back any further....so I am
    assuming that the characters I am typing now are not being allowed to
    be used thus assuming that the passphrase is too long. For every
    character I type on my keyboard I see an asterisk echoed back to
    me....this I do successfully until like I said in the previous
    sentence somewhere around 16 or so characters from then on for every
    character I type I see no more asterisks echoed back. I then assume
    this will not work and here I am.

    I have not tried to just go ahead and keep typing the passphrase and
    see if it will work thus disregarding whether or not I am getting
    anything echoed back to me on the screen or not on the laptop.

    So by the time I get some more feedback from you and others I may just
    very well find out that it will work as I am going to go downstairs
    and just type long passphrase in and see if it works.

    Thanks for the time you have spent replying to my issue.

    -Sam Cederas
    Raleigh , N.C.
    hello, Feb 25, 2005
  4. hello

    hello Guest

    just going ahead and typing despite not seeing any new characters
    echoed back on the screen for the passphrase on xpsp2 wireless setup
    did not work.

    So I do have a problem as I cannot use a long passphrase with WPA-PSK
    using XPSP2's wireless configuration.
    hello, Feb 25, 2005
  5. hello

    Niklas Guest

    It sounds as if it's just an illusion that you don't think there are more
    charcters enterd in the editbox but actually there is.
    You could open notepad, type the correct password, copy the password CTRL-A
    (select all), CTRL-C (copy) and paste in to the edit box (CTRL-V). Maybe
    that would make it easier for you to know that you have entered to correct

    Niklas, Feb 25, 2005
  6. hello

    Kerry Brown Guest

    On my access point (DLink DI-514) I enter the long passphrase that I
    I don't think the DI-514 supports WPA. It uses WEP. If you have it set to
    256 bit encryption this may be the problem. Try setting it to 64 bit and see
    if that works. If it does try 128 bit. Hope this helps.

    Kerry Brown
    KDB Systems
    Kerry Brown, Feb 25, 2005
  7. hello

    hello Guest

    I disabled windows from handling my wireless configuration and
    downloaded a utility for my wireless adapter which is a Atheros

    The utility works great and actually echoes back the text as typing.
    I am thinking I have an issue with my Dlink DI-514 Wireless Router
    because using the Atheros Utility I am able to type a long passphrase
    like I want and see the characters echoed back however I still am not
    able to connect.
    If I shorten the passphrase then I am able to connect with the laptop.
    The passphrase I want to use is 43 characters long.
    hello, Feb 25, 2005
  8. hello

    hello Guest

    I think you are on to something.
    D-Link claims to support WPA-PSK with the current firmware dated July
    2004 version 1.03 or something.
    I however cannot get a passphrase longer that 20 characters to work
    with the D-Link. I make a 20 character long passphrase and I am able
    to connect to the D-Link just fine.
    I create a 21 character passphrase and I cannot connect.
    The http interface for the D-Link has the necessary gui for me to
    click on to address WPA-PSK so one would assume their stuff is working
    It has been 8 months since they have release a firmware upgrade for my
    model (DI-514).

    Well I have hit a wall right now.

    Thanks for your help !

    hello, Feb 25, 2005
  9. hello

    Kerry Brown Guest

    I think you are on to something.
    I wasn't aware of the firmware upgrade. I was reading from an old manual
    :). In my experience D-Link is pretty good at updating firmware for fairly
    current products. Maybe they will come out with another version. In the mean
    time it would probably be best to change your keys on a regular basis.

    Kerry Brown
    KDB Systems
    Kerry Brown, Feb 25, 2005
  10. hello

    SimonMackay Guest

    The way I would "key" a wireless network is to use the Wireless Network Setup
    Wizard, even if your AP doesn't support Windows Connect Now functionality.
    First, work through the Wizard.

    In the first screen, select "Automatically assign a network key" and
    determine your SSID yourself. Here, the PC determines the WEP or WPA key

    In the second screen, select "Set up a network manually".

    In the last screen, select "Print network settings". You will see a Notepad
    screen with the network settings as a "rap sheet". Save the "rap sheet" to a
    UFD and print it out.

    Log in to your AP and set the SSID and WPA key according to what you see in
    the "rap sheet" and confirm these settings

    Restart the Wireless Network Setup Wizard and select "I want to add devices
    to the network" option.

    Select the "Use a USB Flash Drive" in the second screen and follow the
    instructions here on to set up your wireless-capable laptops to the network.

    If you are lucky enough to have a router or AP with Windows Connect Now,
    work straight through the Wizard once, but set the AP first when "dipping"
    the USB flash drive in to the devices.

    Whever you change the network key, use the Wireless Network Setup Wizard for
    this purpose. I always have said this that it works in a similar manner to
    any door lock that works with a key. With these devices, the manufacturer or
    the locksmith who rekeys them doesn't need you to determine what the key
    "cut" will be. You are also sure that your neighbour's front door key will
    not work your front door lock and your front door key will not operate your
    neighbour's front door lock, even though both locks are from the same
    manufacturer and use the same keyway.

    This program uses the maximum key-length possible, which is equivalent to
    using a lock that works on 5 or more pins or levers compared to using one
    that uses 3 or 4 pins or levers like some cheaper padlocks. Here, the more
    pins or levers yields more "changes" (many different keys) and less risk of
    other keys opening your door.

    With regards,

    Simon Mackay
    SimonMackay, Feb 26, 2005
  11. hello

    hello Guest

    I finally figured out how to fix the problem. I took a bit of my own
    medicine and switched to channel 11. Whaalaah !!!! It works now.
    I am able to sustain a connection using a 60 character long passphrase

    Before I was on channel 1. I was only able to connect with WPA-PSK
    using a passphrase no longer than 20 characters. Once I switched over
    to channel 11 I was able to use up to 64 characters!!

    Ticked to death.

    Thanks to all who expressed interest.

    hello, Feb 27, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.