XP WEP problems

Discussion in 'Wireless Networks' started by scott b, Aug 23, 2004.

  1. scott b

    scott b Guest

    I have a laptop with XP and a Linksys WPC11 ver 3 card. I can connect with
    no problem when I have the WEP disabled (using windows to configure the
    wireless network settings versus the linksys configuration utility), however,
    I am having an icompatibility issue with the encryption level. Windows is
    offering me a choice of 40 bits or 104 bits for my WEP setting instead of 64
    bits or 128 bits. Here is the error message:

    The network password needs to be 40bits or 104bits depending on your network
    configuragtion. This can be entered as 5 or 13 ascii characters of 10 or 26
    hexadeciamal characters.

    I am admittedly new to XP, I have not had these issues with Win 2k. How do
    I get XP to offer the 128bits (or 64bits for that matter) that my wireless
    NIC offers?

    Thank you in advance
     
    scott b, Aug 23, 2004
    #1
    1. Advertisements

  2. 40 is the same as 64
    104 is the same as 128

    (add 24 to 40 or 104)

    1 ASCII Character=8 Bits

    1 HEX Character=4 Bits


    40 or 64 bit ASCII WEP code has 5 characters

    40 or 64 bit HEX WEP code has 10 characters


    104 or 128 bit ASCII WEP code has 13 characters

    104 or 128 bit HEX WEP code has 26 characters
     
    Barb Bowman [MVP-Windows], Aug 23, 2004
    #2
    1. Advertisements

  3. scott b

    Mike Ball Guest

    Barb,

    I've seeen this data posted by your good self on various replies. Can you
    explain why whatever one enters in the key field with WinXP SP1 or SP2,
    whether 5, 10,13 or 26 characters, when you go back and check it afterwards
    WIndows just shows 8 'blobs'. So.,.....is it actually taking notice of
    what you're entering, is it corrupting it or.....?

    I ask because I am using a Netgear WG121 USB adapter on my XP SP2 PC,
    talking to a Draytek Vigor 2600G ADSL router. I use WEP 128 bit encryption.
    When I use the Netgear smart Wizard utility, everything works fine. (and
    it's quite obvious what format to enter the key in with the Netgear
    utility). However, when I prevent the Netgear utility from starting up (by
    removing it from my startup group), and I configure the 128 bit WEP key
    using WZC instead, it never connects to the router. In fact, WIndows tells
    me it doesnt even SEE the network. I've tried entering my 26 hex digits
    many times - every time it doesn't connect, and I can only see 8 blobs when
    I look at the properties for the connection. Start up the Netgear utility
    again and all connects fine.

    My conclusion - the WIndows support is not driving the network adapter
    properly and/or not using the key I'm entering.

    Why is the WIndows key support so awkward? Are there any known bugs in the
    WEP key support - even with SP2 applied? I had hoped that with the changes
    to wireless support in SP2 that I'd be able to use WZC instead of the
    Netgear utility, but no....BTW, I;m using the very latest Netgear WG121
    drivers and utility (V2.0 from their web site).

    Rgds,
    Mike
     
    Mike Ball, Aug 28, 2004
    #3
  4. As far as I know, the amount of "blobs" is not indicative of the WEP key
    length and is used to hide the true length.

    I have not used WEP for a while and not under SP2. Under SP1, there was
    this problem with pasting WEP keys using formatted text (e.g. text copied
    out of programs like Word) while unformatted text (e.g. text copied out of
    Notepad) would work fine. Thus, the solution was to either type in the key
    by hand or to copy and paste the key from Notepad. Keep in mind that when
    entering non-hex keys, case does matter. Also, some routers use passphrases
    to generate a WEP key. Unlike WPA-PSK, there is no standard for generating
    a WEP key from a passphrase and this approach does not work with WZC. If
    you use WEP, you need to enter the final key into WZC.

    Finally, WZC usually does not work if you are both using encryption and are
    not broadcasting the access point's SSID.

    -Yves
     
    Yves Konigshofer, Aug 28, 2004
    #4
  5. scott b

    Mike Ball Guest

    Well hiding the true length of the key from the person who has just entered
    it seems pretty pointless to me and just makes problem determination more
    uncertain - which given the variable nature of wireless connections is the
    last thing one wants. None of the APs, routers or adapter utilities I've
    used so far hide the length of the key - only the digits themselves. Then at
    least you're pretty sure it's using what you've just typed in. And I've
    seen nothing in the help, nor found any article on the Windows support site
    so far which states that this is what it does, which just causes
    uncertainty.

    Take all your points about entering the key, and they've been well
    communicated in the past - I only ever type my key in (26 hex digits) or
    copy and paste from Notepad. Windows is not helping diagnose the problem by
    'hiding' things from me.

    The AP is broadcasting the SSID.

    I'm beginning to suspect that maybe the Netgear WG121 driver may not be
    fully compatible with WZC (whatever SP). After all, it's one of many
    drivers for which at installation you get a message saying that it hasn't
    gone through the Windows Logo scheme but continue anyway. Does make you
    wonder how extensively its been tested with the several patches that have
    been produced for XP Wireless over the last year or so.

    Mike
     
    Mike Ball, Aug 29, 2004
    #5
  6. In addition to the other replies, you might want to check out the new
    wireless network wizard in XP SP2 and see the differences in entering
    a WEP key or WPA passphrase. As for Netgear and signed drivers, you
    should speak with Netgear's tech support.
     
    Barb Bowman [MVP-Windows], Aug 29, 2004
    #6
  7. scott b

    Mike Ball Guest

    Barb,

    I did try the new networking wizard already, tried entering the key using
    it - same thing, no connection.

    I'd rather stick pins in my eyes than contact Netgear tech support :)

    Mike
     
    Mike Ball, Aug 29, 2004
    #7
  8. Have you unchecked 802.1x authentication?

     
    Barb Bowman [MVP-Windows], Aug 29, 2004
    #8
  9. scott b

    Mike Ball Guest

    Mike Ball, Aug 30, 2004
    #9
  10. If you have the latest Netgear drivers and are having this problem,
    I'm afraid I have to send you to Netgear support. If it isn't WHQL'd,
    as you say, ask them for WHQL's drivers.
     
    Barb Bowman [MVP-Windows], Aug 31, 2004
    #10
  11. scott b

    Mike Ball Guest

    Thanks Barb.

    Next plan is to check it with a different manufacturer's USB adapter instead
    of the Netgear.

    I have my doubts about Netgear in general (bad experience with a DG834G
    router, now replaced by a Draytek)

    Mike
     
    Mike Ball, Sep 1, 2004
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.