XP startup error -- missing entry point in DLL

Discussion in 'Computer Support' started by Klein, Dec 22, 2003.

  1. Klein

    Klein Guest

    [[ The procedure entry point SetupDiEnumDeviceInterfaces
    [[ could not be located in the dynamic link link library
    [[ SETUPAPI.dll

    I get this message when WinXP SP1 starts up. The PC operates normally -- no
    problems noted (so far). The resource in question is described at this URL.

    http://msdn.microsoft.com/library/default.asp?url=/library/en-
    us/devio/base/setupdienumdeviceinterfaces.asp

    But beyond reading the description, I think the next step is to track down
    the application calling it. Is this right?

    Can someone point me to a tool or technique I can use to ID the application
    that is requesting this?
     
    Klein, Dec 22, 2003
    #1
    1. Advertisements

  2. Klein

    °Mike° Guest

    Your 'setupapi.dll' may be the wrong version or corrupt. Run the
    System File Checker. Start -- Run -- sfc /scannow


     
    °Mike°, Dec 22, 2003
    #2
    1. Advertisements

  3. Klein

    Harrison Guest

    Try restoring the file.
    Start > Run > sfc /scannow or
    Start > Run > msconfig (click the Expand File button and specify your
    dll.)
     
    Harrison, Dec 22, 2003
    #3
  4. Klein

    Klein Guest

    Your 'setupapi.dll' may be the wrong version or corrupt. Run the
    Thanks. Completed that -- no errors. Still looking.
     
    Klein, Dec 23, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.