XP not detecting Linksys Wireless USB Adaptor Properly

Discussion in 'Wireless Networking' started by ryanradford, Feb 16, 2006.

  1. ryanradford

    ryanradford Guest

    Lead-Up to Problem: Several months ago, I purchased a "Linksys
    Wireless G PCI Card with SpeedBooster" (model WMP54GS) for my Windows
    XP machine running an AMD Athlon XP 2400 and 1 GB RAM. The card
    installed nicely, however based on the location of the antenna (up
    against a corner with tons of wires running around it), I couldn't
    get anything better than a "LOW" connection in the basement suite where
    I live. So I went out and bought the "Linksys Wireless G USB
    Network Adapter with SpeedBooster" (Model WUSB54GS) in hopes that I
    could get a better connection. So I uninstalled all the software
    associated with the PCI card, and took it out of the computer. Then I
    did a fresh reboot and installed the USB Adapter. The problem was that
    every time I plugged it in it would recognize it as an unknown device
    TWICE. After some fiddling around, I still couldn't get it to detect
    properly although occasionally I could get an internet connection (when
    the adapter was detected properly). After uninstalling it and
    reinstalling it several times, this is where I'm at now:

    When I reboot the computer, everything loads up fine except, I get a
    message in my taskbar stating "No Available Wireless Networks in
    Range." The problem is not actually that there's no signal in
    range, it's that the computer won't detect the USB Wireless
    Adaptor. The ONLY way I have managed to work around this is to:
    1) Wait for Windows XP to fully load up
    2) Unplug the USN Wireless Adaptor (from the adaptor itself) - I then
    get the little chime indicating a USB device has been disconnected
    3) Wait for several seconds
    4) Re plug-in the USB Detector.

    After doing this, the computer "finds" the USB Wireless Adaptor and
    then detects and connects to the available wireless network.

    This is the ONLY way I can ever get any kind of internet access.
    Another thing which I'm sure is related is that once I'm up and
    running, if I go to my Device Manager, under USB Controllers I have:
    - USB Composite Device on USB 2.0 Bus (Device Type: Universal Serial
    Bus controllers, Manufacturer: OWC, Location: Linksys Wireless-G USB
    Network Adapter with SpeedBooster, and Status: This Device is Working
    Properly ). This is obviously the adaptor that I have to unplus and
    re-plug in each time.

    But under "Other Devices" I have:
    - Device on USB 2.0 Hub (the Device Type, Manufacturer, and Location
    are all IDENTICAL to the above device, however the status says: This
    device is not configured correctly. (Code 1) . To reinstall the drivers
    for this device, click Reinstall Driver.

    So it appears that the computer is detecting the same adaptor TWICE.
    If I uninstall the "Other Device: Device on USB 2.0 Hub" it just
    redeteccts itself each time.

    So what do I need to do so that I can just turn on the computer and
    have the wireless adaptor and network detected automatically (which it
    SHOULD be doing anyway).

    Any help would be greatly appreciated. I've contacted Linksys and
    didn't really get anywhere.

    Thanks,

    Ryan
    ryanradford @ gmail.com
     
    ryanradford, Feb 16, 2006
    #1
    1. Advertisements

  2. ryanradford

    theodore Guest

    we had the same problem this morning with a netgear card in a toshiba
    laptop.;
    to fix it, we turned off the netgear wifi thing next to the clock by right
    clicking it and then
    hitting exit. It went away.

    then we found the windows thing by right clicking on the windows wifi icon
    down
    by the clock

    one of the things in there was to use windows to run wifi, we clicked on the
    box that autherizes that, and then the ok button, and then it whizzed and
    clicked and then it stopped, and it worked.
     
    theodore, Feb 16, 2006
    #2
    1. Advertisements

  3. ryanradford

    David T Guest

    http://www.linksysfix.com/check/HomePage/index.htm

    go to this link when you have the system up and "running" and run the
    Netcheck program..first...to check your system..
    The second program "Netset" is a setup program to install drivers on your
    system..seems that sometimes the installtion disk does not work correctly..
    I too had problems setting up the same adapter on my system and called tech
    support...ran the netset and all worked fine..
    Food for thought...
     
    David T, Mar 5, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.