XP and WPA-PSK TKIP won't connect

Discussion in 'Wireless Networking' started by Guest, Jan 31, 2006.

  1. Guest

    Guest Guest

    I have just bought a 3com OfficeConnect wireless 11g firewall modem router
    with a USB adapter
    http://www.dabs.com/productview.aspx?quicklinx=395K

    Using my laptop with Windows XP SP2 (newly rebuilt and fully patched by
    windows update) I can connect using WEP 128bit but whenever I try the WPA-PSK
    TKIP it never connects it gets stuck with 'aquiring network address'.
    I have tried using my works Windows 2000 SP4 laptop and that connected
    straight away using WPA, so I'm sure I'm missing something on the XP machine
    but don;t know what.

    Any ideas?
    Thanks Gavin
     
    Guest, Jan 31, 2006
    #1
    1. Advertisements

  2. Guest

    Malke Guest

    Perhaps your wireless adapter on the laptop doesn't support WPA. Check
    with the laptop mfr. There may be a firmware update.

    Malke
     
    Malke, Jan 31, 2006
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    the wireless adapter is a USB stick which came with the router, and it does
    suport WPA and does work on the Windows 2000 machine just not the XP machine.

    Gavin
     
    Guest, Jan 31, 2006
    #3
  4. Guest

    Malke Guest

    Then I'm sorry but I don't know. I'm sure someone who knows about
    wireless usb devices will come along, or you could check with the
    device mftr.'s tech support.

    Malke
     
    Malke, Jan 31, 2006
    #4
  5. Guest

    Liam Guest

    Gavin,

    Send back the 3Com kit and get something else that actually works. The
    problem is the router, not the USB adapter. You are experiencing the well
    known and documented problems for which 3Com consumer grade wireless routers
    are notorious. They can sometimes support a single wireless client but never
    reliably, and rarely more than one.

    My recommendation is Draytek, which I bought when I gave up on the 3Com.
    Expensive but actually does what it is supposed to do.


    Good luck,

    Liam
     
    Liam, Jan 31, 2006
    #5
  6. Guest

    Guest Guest


    I got a Netgear router with USB adapter and I get the same error. Windows XP
    Pro refuses to let the WPA-PSK work. Looking a other forums it appears to be
    a common problem with Windows XP, but I can't find a solution.
     
    Guest, Feb 6, 2006
    #6
  7. Guest

    Liam Guest

     
    Liam, Feb 7, 2006
    #7
  8. Guest

    Liam Guest

    Are you using SP2? There were some pre-SP2 WPA issues although I never had
    any problems. Also, use Wireless Zero Configuration and not the utility that
    came with the USB device.
     
    Liam, Feb 7, 2006
    #8
  9. Guest

    Guest Guest

    I am using Windows XP professional Service Pack 2 with all patches from
    windows.update.
    I have recently reloaded the machine
    Windows XP Pro SP1
    Apply Service Pack 2
    Apply all patches from windows.update

    I am using the WZC and not the 3com util.
    also updated the firmware on the router to the latest and downloaded thr
    latest drivers from thr USB adapter (the ones on the CD appeared to be about
    2 years old even though its new????)
     
    Guest, Feb 7, 2006
    #9
  10. Guest

    Liam Guest

    Are you broadcasting the SSID? If it is hidden it won't help. Apart from
    that I am not sure what the problem could be, but double check everything
    such as MAC filtering and password accuracy. Also completely uninstall the
    manufacturers utility in case that causes an issue when you are using WZC. I
    have never had any WPA specific problems with any of the devices I have used
    (the 3Com was just sh!te whatever I tried) and it seems strange you have the
    same issue with the different manufacturers' equipment.
     
    Liam, Feb 14, 2006
    #10
  11. Guest

    Guest Guest

    I've been doing some more testing.
    (at the moment I'm using MAC filter and WEP 128bit as these work)
    using another PC (Win2000) set thr router to using WPA.
    on the XP machine found the network and set the key.
    It wouldn't conect just got stuck on the 'aquiring network address'
    rebooted the XP machine and watched the router connections on the win2000
    machine.
    as the XP machine booted the router gave it a IP but the XP machine doesn'y
    show it and sits there trying to get one. ????

    Also I am using the WZC and have only loaded the drivers for the USB adapter
    NOT the manufacturers utility, and the SSID is not hidden.

    There has got to be something somewhere doing something but I have no idea
    what to try next. :(

    Gavin
     
    Guest, Mar 8, 2006
    #11
  12. Guest

    Mel Would Guest

    I recently tried switching from WEP over to WPA-PSK TKIP. Got nothing
    but constant disconnects. Real flakey. Gone back to WEP and its rock solid.
     
    Mel Would, Mar 9, 2006
    #12
  13. Guest

    johnmeola Guest

    Good Luck Man. Had this problem on many different notebooks and pda's
    as well. Found many threads from people having the same problem. After
    days of diag I just gave up and went back to WEP.
     
    johnmeola, Mar 9, 2006
    #13
  14. Guest

    Latro_

    Joined:
    Jan 3, 2008
    Messages:
    1
    Likes Received:
    0
    Possible Solution

    I know this is an old thread, i was searching for a solution as i was getting the same waiting for address for ages.

    I found a sort of work around myself. If you just assgn your xp machine it's own IP and set the default gateway to that of the router it should bypass this step.

    So right click your wireless connection in network places, goto status, then properties.

    Scroll down to TCP/IP, goto properties on that.

    Next screen check 'User the following IP address' Pick one that your router allows or has been setup for on DHCP. In my case this was 192.168.0.3, subnet mask should take care of its self.

    Set the Default gateway to your router's ip, In my case 192.168.0.1.

    For DNS set the preferred DNS server as the router's ip, e.g. again in my case 192.168.0.1.

    Now try connecting to the router with WPA/PSK running, enter your pass key in carefully and it should work.

    This is by no means a nice or clean fix but it got my wireless up and running. I only rally wanted to test the router's wireless for my Asus eee coming tommorow, thats linux so I should be fine lol :)
     
    Latro_, Jan 3, 2008
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.