XP ad-hoc wireless network - accessing shared files and printers

Discussion in 'Wireless Networks' started by CliveDarling, Aug 18, 2009.

  1. CliveDarling

    CliveDarling Guest

    I've 2 pcs running XP Pro and each has a wireless card. I've successfully set
    up the ad-hoc network on the host and have connected using the client. Each
    PC is in a common workgroup.
    Now, this may be a stupid question; call it the vagaries of an ageing
    pensioner's mind. How do i actually physically "see" and attach the shared
    resources that are on the host, at the client. Do I need to set up a "network
    place"? If so, how should this be formatted in a mapped drive? Or is there a
    simple method that I am just not seeing? My ad-hoc network is simply called
    I ultimately want to use the internet connection on the host, from the
    client but am having IP issues at the client. I will post a query on this
    All help welcome!!
    CliveDarling, Aug 18, 2009
    1. Advertisements

  2. CliveDarling

    Lem Guest

    Standard networking advice from MVP Malke below. Take the parts that
    apply to you and ignore the rest.

    For Internet Connection Sharing, see

    File/printer sharing

    Excellent, thorough, yet easy to understand article about File/Printer
    Sharing in Vista. Includes details about sharing printers as well as
    files and folders:


    For XP, start by running the Network Setup Wizard on all machines (see
    caveat in Item A below).

    Problems sharing files between computers on a network are generally
    caused by 1) a misconfigured firewall or overlooked firewall (including
    a stateful firewall in a VPN); or 2) inadvertently running two firewalls
    such as the built-in Windows Firewall and a third-party firewall; and/or
    3) not having identical user accounts and passwords on all Workgroup
    machines; 4) trying to create shares where the operating system does not
    permit it.

    A. Configure firewalls on all machines to allow the Local Area Network
    (LAN) traffic as trusted. With Windows Firewall, this means allowing
    File/Printer Sharing on the Exceptions tab. Normally running the Network
    Setup Wizard on XP will take care of this for those machines.The only
    "gotcha" is that this will turn on the XPSP2 Windows Firewall. If you
    aren't running a third-party firewall or have an antivirus with
    "Internet Worm Protection" (like Norton 2006/07) which acts as a
    firewall, then you're fine. With third-party firewalls, I usually
    configure the LAN allowance with an IP range. Ex. would be Obviously you would substitute your correct
    subnet. Do not run more than one firewall. DO NOT TURN OFF FIREWALLS;

    B. For ease of organization, put all computers in the same Workgroup.
    This is done from the System applet in Control Panel, Computer Name tab.

    C. Create matching user accounts and passwords on all machines. You do
    not need to be logged into the same account on all machines and the
    passwords assigned to each user account can be different; the
    accounts/passwords just need to exist and match on all machines. DO NOT
    machine to boot directly to the Desktop (into one particular user's
    account) for convenience, you can do this. The instructions at this link
    work for both XP and Vista:

    Configure Windows to Automatically Login (MVP Ramesh) -

    D. If one or more of the computers is XP Pro or Media Center, turn off
    Simple File Sharing (Folder Options>View tab).

    E. Create shares as desired. XP Home does not permit sharing of users'
    home directories or Program Files, but you can share folders inside
    those directories. A better choice is to simply use the Shared Documents
    folder. See the first link above for details about Vista sharing.

    F. After you have file sharing working (and have tested this by
    exchanging a file between all machines), if you want to share a printer
    connected locally to one of your computers, share it out from that
    machine. Then go to the printer mftr.'s website and download the latest
    drivers for the correct operating system(s). Install them on the target
    machine(s). The printer should be seen during the installation routine.
    If it is not, install the drivers and then use the Add Printer Wizard.
    In some instances, certain printers need to be installed as Local
    printers but that is outside of this response.
    Lem, Aug 19, 2009
    1. Advertisements

  3. CliveDarling

    CliveDarling Guest

    I'm sorry but this is too confusing for my 65 year old mind. Your Point F
    "after you have etc"; this is my problem. How do I actually access the shared
    files at the client? I have file sharing set on and the printer I need is
    also set as shared. But how do I actually get at them? I have the same
    workgroup etc and have been suceessful in setting up the wireless network and
    attached to it from the client. I just need to know how to be able to "see"
    the shared files and open them from the client.
    CliveDarling, Aug 19, 2009
  4. CliveDarling

    Lem Guest

    Hey, I'm over 64.

    If you've actually indicated that a *folder* (not file) is to be shared,
    then on the computer where the folder actually resides, you should see
    (in Windows Explorer) that its icon has a hand under it. See, e.g.

    The way you made (make) that happen was by right clicking on the folder
    (again, in Windows Explorer), clicking on the Sharing tab, and giving
    the folder a "share name" (try to keep it under 12 letters/numbers long,
    no spaces, no special chars). This is what step E means by "Create
    shares as desired."

    Then, on the *other* computer, you should be able to access the shared
    folder in a variety of ways. The folder *may* ("should") show up in My
    Network Places. Although MNP works most of the time, it can have
    problems, and it may take 10 or 15 minutes after both computers are
    actually connected to the network for the icons to show up. You can
    sometimes speed things up by the following: In My Network Places, click
    on "View workgroup computers" in the left pane. Then double click on the
    icon for the "remote" computer and its shared folders ought to show up.

    A simpler, more reliable method is to access the remote folder directly.
    First you need to know the computer name of the remote computer. If you
    don't recall it, right click "My Computer" and select properties. Then
    click the "Computer Name" tab. What you're looking for is the "Full
    computer name." Let's suppose that the remote computer is named "Clive2"
    and you want to open a folder that you've shared under the name "CDocs".

    Go to Start > Run and type
    \\Clive2\CDocs [click OK]

    and the folder should open in a Windows Explorer window.

    There are other methods. (In Windows, there are probably at least 3
    different ways to do anything).

    Sharing printers is similar, but there can be some idiosyncrasies, so
    why don't we stop here and see how you do. If you get any error
    messages, please quote them verbatim.
    Lem, Aug 19, 2009
  5. CliveDarling

    Jack-MVP Guest

    In addition when a folder is shared correctly you can "Map" a Share as an
    additional Drive on another computer and then it would appear in Windows
    Explorer as an additional Drive.
    Here is a little more on the issue, http://www.ezlan.net/sharing.html#map
    Jack (MS, MVP-Networking).
    Jack-MVP, Aug 20, 2009
  6. CliveDarling

    CliveDarling Guest


    Fair play to you! I'm glad there are still some ageing hippies around.

    The mote has been cleared from my eyes; I have made contact beautifully with
    the host shared folders, from the client and am ecstatic! Thank you.

    On the issue of using the Internet Connection on the host, are there some
    special settings I need to make on the client Internet Explorer? On simply
    trying to access a web page from the client with the standard settings, I get
    the usual "web page not found". So I presume I'm just not getting to the
    connection. Are there possible issues with IP address settings?
    Many thanks for your very clear help

    CliveDarling, Aug 20, 2009
  7. CliveDarling

    CliveDarling Guest

    Thanks Jack,

    All is now well with the file access; I've done as you suggest and mapped
    the folders that I need. I'm ecstatic!
    CliveDarling, Aug 20, 2009
  8. CliveDarling

    Lem Guest

    The problem *may* lie in the manner in which you initially set up the
    ad-hoc connection (use a router is *so* much easier and safer). The
    first thing to check is the IP address assigned to the *client* computer.

    On the client computer, open a Command Prompt window:
    (Start>Run cmd [enter])

    In the Command Prompt window that opens, type
    ipconfig [enter]

    Your IP address should be 192.168.0.x. If it instead has the form
    169.254.x.y, you have not configured Internet Connection Sharing. See
    the links in my earlier post, repeated here:

    For Internet Connection Sharing, see

    These articles also have some troubleshooting help.
    Lem, Aug 20, 2009
  9. CliveDarling

    Jack-MVP Guest

    Glad you solve it. Mapping Drives is one of the great solutions for working
    over LAN .
    Jack (MS, MVP-Networking)
    Jack-MVP, Aug 21, 2009
  10. CliveDarling

    CliveDarling Guest


    'fraid I hit a brick wall here.

    MS Article 306126 tellms me I should se this message when I add ICS to my
    internet gateway.
    "When Internet Connection Sharing is enabled, your LAN adapter will be set
    to use IP
    address Your computer may lose connectivity with other
    computers on
    your network. If these other computers have static IP addresses, it is a
    good idea to set them
    to obtain their IP addresses automatically. Are you sure you want to enable
    Connection Sharing?"

    I don't see this; and of course my IP is not set as suggested; it is 169.254

    I am using a 3G Card, a USB modem that I have always on. Should this make a
    I have tried forcing the IP addresses to be in the 168 range but lose
    connectivity to the host when I do that; so I've returned to auto selection.
    I have been unable to ping the host at all using 168's.

    I now have both computers set to auto IP; I can connect to the wireless
    network no problem and have access to all the shared folders and drives.

    I just can't seem to get the ICS working.

    CliveDarling, Aug 21, 2009
  11. CliveDarling

    Lem Guest

    Forcing the IP address (on either computer) will not work. ICS does
    several things on the "main" or "host" computer in addition to setting
    the IP address.

    See if the suggestions here help: http://support.microsoft.com/kb/308006/

    Or, read a few of the pages starting with

    and use the Network Setup Wizard.
    (Don't get confused by the screen shots that apply to earlier versions
    of Windows; after starting the Wizard, skip down the page until "The
    Wizard's Welcome screen then appears. Click Next to continue.")

    Lem, Aug 21, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.