X-Lite 3.0 behind Fritz!box dsl-router

Discussion in 'UK VOIP' started by Hans Greiner, Jan 28, 2007.

  1. Hans Greiner

    Hans Greiner Guest

    Hej!

    I have a strange problem:

    I live in Germany and use freenet DSL.
    I have a Fritz!Box SL WLAN as router, behind this I use a W2k machine and a
    XP SP2 machine. Both run Sygate as personal firewall.

    On the W2k-Rechner I had no problem to install freenets iPhoneCommunicator.
    But inbound calls are not signaled by a ring singal. On the XP SP2 machine
    I had to install X-Lite 3.0. The configuration was impossible on this
    machine.

    Apart from the ring signal everything nice and peachy with the
    iPhoneCommunicator on W2k.

    X-Lite 3.0 on XP is great for outbound calls. Inbound calls show a one-way
    audio problem. The caller can't hear me! But voice quality is great for all
    set up audio channels.

    I set up port forwarding on my router to the XP machine:

    5060, 5004, 3478, 3479, 16384-16400, 8000 UDP
    8001 TCP

    -> no change in behaviour!

    The only effect is (as expected), that the W2k machine does not get any
    inbound call...

    Than I installed X-Lite 2.0 on my XP machine.
    Inbound calls and outbound calls work great now. But the voice quality is
    horrible: Noise and echo!

    Anyone an idea why X-Lite 3.0 does not work on the same machine, with the
    same firewall settings? Does X-Lite 2.0 have a feature, X-Lite 3.0 does not
    have? Any suggestion for helpful settings for my X-Lite 3.0?

    Any help is much appreciated!

    regards from Berlin

    /Hans
     
    Hans Greiner, Jan 28, 2007
    #1
    1. Advertisements

  2. Hans Greiner

    aap Guest

    If the fritzbox is using VOIP, it's responding to port 5062
    So you have to config xlite for 5062.
    Enable TCP 5062 on the fritzbox for incoming traffic to your pc.
    Also enable UDP and TCP ports 8000-8005 for incoming traffic to your pc.
    Allow xlite for incoming traffic on your pc's built-in firewall.

    If the fritzbox is not using voip, read 5060 for 5062.

    Cu
     
    aap, Jan 28, 2007
    #2
    1. Advertisements

  3. Hans Greiner

    Hans Greiner Guest

    Hej aap!

    Thanx for your response!

    Am Sun, 28 Jan 2007 11:14:45 +0100 schrieb aap:
    The Fritz!Box does not use VOIP, so I configured
    5060 UDP, TCP
    8000-8005 UDP, TCP to be forwarded to my machine.

    I changed nothing in my X-Lite 3.0 settings, because (as far as I can see)
    there is no way to influence port usage in X-Lite 3.0...
    Is there a way?

    Unfortunately: no change!

    Any additional ide
     
    Hans Greiner, Jan 28, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.