WZC doesn't know our driver is WPA capable...How to tell WZC?

Discussion in 'Wireless Networking' started by PingPong, Aug 18, 2004.

  1. PingPong

    PingPong Guest

    Hi,

    I am trying to make our driver to work with WZC with WPA functionality. I
    already made all WPA related OIDs
    work and able to use meetinghouse Aegis client to do WPA and WPA PSK and
    surf.
    Right now, when I plug in our card and load the driver, the Windows Zero
    Configuration doesn't know our card can do
    WPA OIDs and TKIP and AES encryptions.
    How do I tell WZC it's a WPA capable driver ? Through the OIDs or INF file
    or Registery ?

    Please advise !


    Corin
     
    PingPong, Aug 18, 2004
    #1
    1. Advertisements

  2. PingPong

    Gramps Guest

    Gramps, Aug 18, 2004
    #2
    1. Advertisements

  3. PingPong

    PingPong Guest

    Hi,
    Thank you for the infomation.
    I went through the tests that guidelines described and right now our driver
    had the same OID responses as guideline
    says.
    But one weird thing is WZC didn't sent me the Query
    OID_802_11_ASSOCIATION_INFOMATION,
    It basically skipped this query OID.
    I used DLink card as the reference. WZC sent the same OID sequence to DLink
    as it sent to our driver, except WZC sent OID_802_11_ASSOCIATION_INFOMATION
    to DLink and skipped it to our driver.
    SO, DLink card is "WPA capable", and our's not.

    Please Help, I know I am very close to pass tests as "WPA capable".
    Why WZC doesn't sent OID_802_11_ASSOCIATION_INFOMATION to our driver ?
    (I did implement this OID: ASSOCIATION_INFOMATION .)
    Any ideas ?
     
    PingPong, Aug 19, 2004
    #3
  4. PingPong

    Gramps Guest

    Are you exporting OID_802_11_ASSOCIATION_INFORMATION in your list of
    supported OIDs when queried by OID_GEN_SUPPORTED_LIST?
     
    Gramps, Aug 19, 2004
    #4
  5. PingPong

    PingPong Guest

    Thanks agian,
    Yes, I do exporting OID_802_11_ASSOCIATION_INFORMATION when queried by
    OID_GEN_SUPPORTED_LIST.

    Anything I possibly missed ?
     
    PingPong, Aug 19, 2004
    #5
  6. PingPong

    Gramps Guest

    Are you getting a set of OID_802_11_ADD_KEY? If so, are you failing
    the set if the key index parameter is 0xc0000001 and returning
    NDIS_STATUS_INVALID_DATA?

    For that matter, can you list the OIDs that you are getting (based on the
    adapter guidelines) and what your driver returns for data?
     
    Gramps, Aug 19, 2004
    #6
  7. PingPong

    PingPong Guest

    Hi, Here the list of the OIDs the got after enable theWZC in Control
    Panel\Administrative Tools\Services

    WmiQueryComplete, Oid: OID_802_3_CURRENT_ADDRESS 0x04040490 0x00000404

    WmiQueryComplete, Oid: OID_GEN_MAC_OPTIONS, Data: 0x0000008D (141)

    WmiQueryComplete, Oid: OID_GEN_MAXIMUM_FRAME_SIZE, Data: 0x000005DC (1500)

    WmiQueryComplete, Oid: OID_GEN_MEDIA_CONNECT_STATUS, Data: 0x00000001 (1)

    WmiQueryComplete, Oid: OID_802_3_CURRENT_ADDRESS, Data: 0x04040490
    0x00000404 0x00000000 0x00000000 0x00000000 0x00000000

    WmiQueryComplete, Oid: OID_802_3_CURRENT_ADDRESS 0x04040490 0x00000404

    WmiQueryComplete, Oid: OID_802_11_AUTHENTICATION_MODE, Data: 0x00000000 (0)

    WmiQueryComplete, Oid: OID_802_11_INFRASTRUCTURE_MODE, Data: 0x00000002 (2)

    WmiQueryComplete, Oid: OID_802_11_WEP_STATUS, Data: 0x00000000 (0)

    WmiQueryComplete, Oid: OID_802_11_SSID, Data: 0x00000007 0x61666564
    0x00746C75 0x00000000 0x00000000 0x00000000

    WmiQueryComplete, Oid: OID_802_11_BSSID_LIST, Data: 0x0000000B 0x0000009C
    0x19660F00 0x00004623 0x00000001 0x00000061

    WmiQueryComplete, Oid: OID_802_11_SSID, Data: 0x00000007 0x61666564
    0x00746C75 0x00000000 0x00000000 0x00000000

    WmiSetComplete, Oid: OID_802_11_INFRASTRUCTURE_MODE, Data: 0x00000001 (1)

    WmiSetComplete, Oid: OID_802_11_SSID, Data: 0x00000020 0x131C0314
    0x1B1A0305 0x1B011B10 0x05030205 0x050A1D1D

    WmiSetComplete, Oid: OID_802_11_AUTHENTICATION_MODE, Data: 0x00000003 (3)

    WmiQueryComplete, Oid: OID_802_11_AUTHENTICATION_MODE, Data: 0x00000003 (3)

    WmiSetComplete, Oid: OID_802_11_WEP_STATUS, Data: 0x00000006 (6)

    WmiQueryComplete, Oid: OID_802_11_WEP_STATUS, Data: 0x00000007 (7)

    WmiSetComplete, Oid: OID_802_11_ADD_KEY, Data: 0x00000040 0xC0000001
    0x00000020 0xFFFFFFFF 0x1B1AFFFF 0x1B011B10

    return NDIS_STATUS_INVALID_DATA

    WmiSetComplete, Oid: OID_802_11_BSSID_LIST_SCAN, Data: 0x00000000 (0)


    This list is almost identical to what WZC send to DLink card, except some
    return values like OID_802_11_BSSID_LIST are different.
    However DLink card got extra query OID association_information which we
    didn't after set OID add_key .
    WmiQueryComplete, Oid: OID_802_11_ASSOCIATION_INFORMATION, Data: 0x00000028
    0x00000000 0x00000000 0x00000000 0x00000000 0x00000000


    Anything wrong in the list ? DLink has the same list and return values and
    passes tests. The only missing OID for us is query association_information,
    if WZC send us this OID, then I can debug the next. If they don't, something
    must be wrong.

    Thanks in advance.
     
    PingPong, Aug 19, 2004
    #7
  8. PingPong

    Gramps Guest

    Some comments inline below...

    The bad news is that I don't see anything that looks incorrect and I'm not
    sure if the comments I've given you will have any impact.

    You may want to plumb OID_802_11_ASSOCIATION_INFORMATION to your driver
    through OidScope to see how it's handling it.


    [Please confirm that you are not responding to this query with 0x8D. 0x80 is
    a reserved NDIS setting and should not be used by the miniport.]
    (2)

    [You're initializing to Ndis802_11AutoUnknown which is not supposed to be
    used. You may want to default to Ndis802_11Infrastructure instead.]
    [You're initializing to Ndis802_11Encryption1Enabled. You may want to
    default to Ndis802_11EncryptionDisabled instead.]
     
    Gramps, Aug 19, 2004
    #8
  9. PingPong

    PingPong Guest

    Hi,
    I tried those OIDs setting you commented. I still got the same list without
    the OID_802_11_ASSOCIATION_INFORMATION.

    I am sure I returned OID_GEN_MAC_OPTIONS with value 0xD, I don't know where
    0x80 came from, but DLink card has the same value 0x8D as well.

    Anything else? looks like it's a tough one to find out, I am running out of
    ideas.





     
    PingPong, Aug 19, 2004
    #9
  10. PingPong

    Gramps Guest

    I tried those OIDs setting you commented. I still got the same list
    without
    NDIS will insert the 0x80 after the miniport is queried with
    OID_GEN_MAC_OPTIONS.
    The only thing I still suspect is whether OID_802_11_ASSOCIATION_INFORMATION
    is really being advertised in the OID_GEN_SUPPORTED_LIST query. Have you
    tried querying your driver with OID_802_11_ASSOCIATION_INFORMATION through
    OidScope?

    Also, let's see if we can solve this together outside of the news group.
    Send me email at .
     
    Gramps, Aug 19, 2004
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.