WPF Media Player causing problem on 64-bit Windows 2008

Discussion in 'Windows 64bit' started by Faisal Shafiq, Aug 9, 2008.

  1. I have created a windows service in C# using Visual Studio 2008. This
    windows
    service is meant to synchronize the Video Content information that has been
    uploaded into an SLS (Silverlight Streaming Service) account. In order to
    get
    a video's meta information (such as duration etc.) and generate it's
    thumbnail without downloading it to our server, I am using WPF's MediaPlayer
    class.

    The service works fine in Windows Server 2003 32 bit and 64 bit edition.
    However, it doesn't work in our deployment environment which is Windows
    Server 2008 64 bit edition. The player simply fails to retrieve any video's
    meta data and thumbnail generation doesn't work either. I don't have any
    idea
    what is going wrong here. Event Viewer seems to have no clue about the
    problem. Can somebody please guide me towards the problem resolution as i
    have already slipped my deadline.

    Thanks
     
    Faisal Shafiq, Aug 9, 2008
    #1
    1. Advertisements

  2. You'll want to post this on one of the MSDN forums appropriate to what
    you're doing. This is primarily a consumer and IT pro newsgroup, and not a
    developer group. The first test, it seems to me, is to try it in Server 2k8
    32-bit, and see if the problem exists there. I suspect it will, since my
    hunch is that you're using or expecting something that isn't available in
    Server 2008, or isn't installed by default. Roles in Server 2k8 are far more
    narrowly defined, and only the minimum services are enabled and exposed for
    the roles installed.
     
    Charlie Russel - MVP, Aug 9, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.