wpa/wep needs AEGIS protocol?

Discussion in 'Wireless Networking' started by boardtc, Nov 30, 2005.

  1. boardtc

    boardtc Guest

    I am trying to set wep 128 bit protection on my home network. Using a
    paraphrase and key index 1, I enter the wep key 1 for laptop 1. It
    works fine. It does not for laptop 2.

    Laptop 1 was bought with xp pro sp2. Laptop 2 has xp home and sp 2 was
    just installed on it.

    Looking at the protocols for each wireless card the difference is that
    laptop 2 has Microsoft TCP/IP verson 6 and does not have AEGIS
    Protocal. Doing a bit of googling suggests that the AEGIS is necessary
    for wap. Where can I download this to see if this will fix the problem?

    Any other thoughts appreciated.

    Thanks, Tom.
     
    boardtc, Nov 30, 2005
    #1
    1. Advertisements

  2. There is no interoperable method to use a passphrase to create a WEP key.
    The methods that exist only work when the Access Point and the client are
    using the same algorithm which usually only happens when they are built
    using the same WLAN chipset.

    WPA-PSK does work with a passphrase and is interoperable, but you need all
    the WLAN devices to be WPA capable... for older WLAN devices you will mean
    an upgrade to its firmware and device driver. XP SP2 has the necessary
    higher level modules to allow WPA authentication to work and set the
    encryption keys correctly.

    The AEGIS protocol driver is a part of a 802.1x toolkit from a company named
    MeetingHouse. Many WLAN vendors use their toolkit to add 802.1x support to
    their WLAN client utilities. It is not a necessary part of WPA, but could
    provide a portion of the necessary for some WLAN vendor client utilities.

    Phil Doragh
     
    Philip Doragh, Dec 1, 2005
    #2
    1. Advertisements

  3. boardtc

    Ryan Younger Guest

    On laptop 2 do the following if you are not using IPv6:

    Click Start | Run type: cmd

    At the command prompt type: ipv6 uninstall

    You should see the following message:

    Uninstalling...
    A reboot is required to complete this action.

    Are you entring the 128-Bit (104 bit technically, as there is a 24-bit IV or
    'Intialization Vector') WEP key in ASCII or Hex format? Have you tried both
    on the problematic laptop?



    --
    All the best,

    Ryan Younger.
    http://spaces.msn.com/members/wirelessnetworking/ - Ryan's Wireless
    Networking Weblog

     
    Ryan Younger, Dec 1, 2005
    #3
  4. boardtc

    boardtc Guest

    Thanks. I uninstalled IPV6. When I set the 128 bit wep on my router it
    creates a 26 digit hex string, there does not appear to be options to
    do otherwise.

    Laptop 2 uses a pc wireless card (origo, made in taiwan, pretty
    generic), which I bought 18 months ago, checking the documentation, it
    says :

    802.11b+ Wireless LAN PC CardBased on the 2.4GHz Direct Sequence Spread
    Spectrum (DSSS) technology, the product comply to the IEEE 802.11b
    standard and Wired Equivalent Privacy (WEP) with 64-bit encryption.

    I thought I was on a winner, but changing to the 10 digit hex (64 bit)
    did not work either. I even reinstalled the driver from the cd and did
    plug and play again, following the doced installation. The driver is
    dated 18/9/2003 (4.15.5.1). The only problem was they have the wan
    monitor utility where they advice to set wep parameters, etc, but when
    I run this the proces runs but the expected gui does not open (even
    after reboot)

    I'm loath to just go and buy another card. Any thoughts on getting this
    one working for wep?
     
    boardtc, Dec 1, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.