WPA-PSK(TKIP) cant acquire ip address

Discussion in 'Wireless Networking' started by Guest, May 6, 2006.

  1. Guest

    Guest Guest

    So heres the problem...
    My roomate got T1 set up in the house through his job.
    He has a router set up in the house that was given to him through work
    (netspeed or something like that)
    He can connect with the passphrase he set up but i cant.
    I use a netgear wireless card that works everywhere else when a password is
    required.
    So my driver is updated. My card was unistalled and reinstalled etc. My
    software picks up the signal, picks up thats its WPA, works for my roomate,
    but just wont work for me. Long story short..."limited or no connectivity
    because cant renew IP address" is what i get.

    Any suggestions?? I think someone at his company would have to fix me so i
    can get in.

    Thanks!!! :)
     
    Guest, May 6, 2006
    #1
    1. Advertisements

  2. Aloha venus3,

    Are you sure the device gives out IP addresses? Maybe your roommate's machine
    has a static IP address assigned by his company? Or maybe the device only
    gives out a single address?

    -Ben-
    Ben M. Schorr, MVP
    Roland Schorr & Tower
    http://www.rolandschorr.com
    Microsoft OneNote FAQ: http://www.factplace.com/onenote.html
     
    Ben M. Schorr - MVP, May 6, 2006
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    I seem to be having the identical problem. I just got a new Fujitsu notebook
    with an Intel 3945ABG card in it and I have a DLink DI-624 router. My old HP
    with an Atheros card in it connects to the router under WPA and WPA2 with no
    difficulty, but the new notebook with the same passkey won't connect if WPA
    is activated. It connects just fine with no security, but like the initial
    poster of this thread says, as soon as you activate WPA you get "Limited or
    no connectivity".

    The Intel card supports WPA2, the XP patch is installed, the DLink driver is
    up to date. I'm at a loss as to why it won't work with the Fujitsu notebook,
    but works like a charm for the older HP.

    It sounds like any help for Venus3 will help me too. Thanks.
     
    Guest, May 6, 2006
    #3
  4. Ben M. Schorr - MVP, May 6, 2006
    #4
  5. Guest

    Guest Guest

    Aloha Ben,

    Yup. I didn't try WPA on the router, but WPA2 on the notebook, or vise
    versa. I'm not mixing standards.

    I've tried manually entering the passkey and cutting and pasting to remove
    miskeys, but there was no change. It's quite odd, the router and notebook are
    communicating, because I have mu Norton FW set to tell me when unused ports
    are accessed and I get the same "A remote system is attempting to contact
    your PC" message on both my notebook (wireless) and desktop (ethernet connect
    to router) when the router is re-booted between WPA and no-WPA attempts (I
    also turned the FW off, but no change).

    Thanks for the response and any ideas Ben.
     
    Guest, May 6, 2006
    #5
  6. Guest

    Guest Guest

    Hi Venus3 and Ben,

    I've resolved the issue at my end. I applied a static IP to my notebook and
    it worked like a charm. I have a DLink DI-624 and used 192.168.0.77.

    I thought the IP had to be assigned by the router, but apparently you can
    assign it at the notebook.

    Go to: Network Connections > Wireless Net. Conn. > Properties > Internet
    protocol (TCP/IP) >

    Click "Use following IP address" and enter an IP in the range of your router
    (for the DI-624 192.168.0.77 worked fine). Subnet 255.255.255.0, default
    gateway 192.168.0.1.

    Click "Use the following DNS server" and key in 192.168.0.1 for preferred
    and 4.2.2.2 for Alternate.

    Click OK and then set up your WPA

    These steps (except for the specific IP ranges) should translate for other
    brands routers as well.

    Thanks goes to James at DLink Canada.
     
    Guest, May 7, 2006
    #6
  7. Most companies giving out stuff like that do so with setup routines to stop
    others using it. Now assuming they didn't refry the innards to their own
    specs so that they cannot be changed (which is what Optus Australia do for
    Dlink 302Gs and possibly other modems they give to customers) without you
    getting an exe to overwrite the changes from the maker of the router, a good
    chance is that they have access control turned on in it. Go to the web
    interface for the modem through the working computer and see if that is the
    case. If it is, add your MAC to it. Also check out if DHCP is turned off. If
    it is, apply an IP number in the required range to your own wi-fi NIC or
    turn DHCP back on in the router. Personally, I would turn DHCP off along
    with the broadcasting of the SSID. It isn't really security, it's just
    something to help towards REAL security.
     
    Diamontina Cocktail, May 7, 2006
    #7
  8. Guest

    James Gockel Guest

    I'll bet that the device only accepts one user connection at a time.
    -James G.
     
    James Gockel, May 7, 2006
    #8
  9. Guest

    Bert Guest

    Thank you IvanK

    I too, have been looking for an answer to this .........Tried your fix and
    it worked perfectly :)

    Bert
     
    Bert, May 8, 2006
    #9
  10. Guest

    Kerry Brown Guest

    Norton Firewall is blocking DHCP. Without knowing what version of Norton you
    are using it's hard to say exactly how to fix it. With most versions if you
    add your subnet as a trusted network DHCP will work.
     
    Kerry Brown, May 8, 2006
    #10
  11. Guest

    Guest Guest

    My pleasure Bert!

    Glad my "instructions" made sense! :)

    Ivan
     
    Guest, May 8, 2006
    #11
  12. Guest

    Bert Guest

    More help would be welcome
    I am using Norton Antivirus 2006 Version 12.2.0.13 with Windows XP Home
    WEP was working fine but I could not get WPA to work
    Bert
     
    Bert, May 8, 2006
    #12
  13. Guest

    Guest Guest

    Hi Bert,

    If you can get WEP to work, then I doubt your firewall is the issue. I
    assume you've upgraded to SP2 so windows can do WPA? Checked that your router
    will do WPA? Tried cutting and pasting your key to make sure there are no
    keystroke errors?
     
    Guest, May 8, 2006
    #13
  14. Guest

    Bert Guest

    Hi again IvanK

    WEP has alway's worked for me, I just couldn't set up WPA until I tried your
    fix (thanks again ) but I still think something is blocking DHCP
    That is why I quizzed Kerry for more info.......... maybe there is something
    in Norton Antivirus that is blocking it ??
    anyway just to add, I am not using any firewall except for the Window's one
    which I had turned off while I was troubleshooting WAP
    I have SP2 and have the update for WPA2
    The Notebook was new in Jan 2006 and I have updated the intel wireless
    driver
    Does anyone know if there are any issue's using a static IP?? otherwise all
    seems to be fine now

    Bert
     
    Bert, May 9, 2006
    #14
  15. Guest

    Kerry Brown Guest

    I agree. If WEP is working then a firewall is unlikely to be the problem.
     
    Kerry Brown, May 9, 2006
    #15
  16. Guest

    Eugene Guest

    I've seem this problem occur mostly when the key is incorrect in one of the
    devices.

    Try to open notepad(Start, Run and type in Notepad), type in the key you are
    going to use, copy and paste into both devices.

    -Eugene
     
    Eugene, May 9, 2006
    #16
  17. Guest

    Guest Guest

    Hello all,

    Ive connacted Netgear and no its not my card. Ive contacted the router
    (linkys) and so thats not the problem. Ive assigned a range pf adresses and
    that connects me but i still cant view any web pages. I was told it may be a
    problem with the network or modem that my roomate is using. I cant conntact
    anyone there because the guy who set us up in the house has quit. So now i
    dont know who to go to. I may just end up paying for yahoo DSL. :(

    Thanks
     
    Guest, May 9, 2006
    #17
  18. Guest

    Guest Guest

    Hello Eugene,
    I do not have a key. I was only given a password that my roomate uses to
    connect. He can get on but i cant. He's the one who set up the router.
    Should i copy and paste the password into my Netgear software where required?
    Ive been trying to assign a static ip but i dont even know what IP to use
    etc.

    Thanks for your help.
     
    Guest, May 15, 2006
    #18
  19. Guest

    nizack05 Guest

    I'm having similar issues with my laptop, just got an HP dv5051 or 5150
    (can't remember the number order).

    Anyway, It came with xp home and I can only connect to my wireless if
    there is not security on it, or if I manually set the tcp/ip properties
    to give it this IP, use this subnet, gateway, and dns server. Then my
    wireless will start up right away, so it's not the key I'm using. I
    have a DLink DI-524. My laptop is intel so it's built into my laptop. I
    run norton firewall, the whole security suite.

    I also have a PC that runs xp pro, that I installed a wireless G card
    in and it runs fine, I have McAfee firewall on that, their whole
    security suite.

    If I take my WPA-PSK off I can connect to it. I have no troubles when I
    plug my laptop in either. I get an ip from my router, but my wireless
    with WPA on it will not give me an IP address.

    I've tried messing around with everything and the only time it works is
    when I set up the properties on my laptop to know what the DHCP on the
    router should be telling me.
     
    nizack05, Jun 9, 2006
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.