WPA-PSK is driving me nuts - HELP?

Discussion in 'Wireless Networking' started by Sven Pran, Jan 1, 2008.

  1. Sven Pran

    Sven Pran Guest

    I have a local wireless network with a Jensen AL-2954
    router and two clients: a 3COM PCMCIA card
    3CRWE154G72 in a PC with Windows 98SE and a
    D-Link DWL-G810 connected to Windows 98.

    First I had great problems getting the D-Link to work
    with WPA-PSK, that problem was finally solved when I
    discovered that D-Link apparently does not support
    "Group Key Update" (varying the encryption master
    key at regular intervals).

    My 3COM card has worked fine all the time , both
    with WEP and with WPA-PSK, but suddenly it no
    longer works with WPA-PSK?

    I did some maintenance and it could seem as if I have
    deleted something I shouldn't have deleted, but I am
    completely unable to identify what that can have been.
    I have even cleaned up the network configuration in the
    PC and installed the 3COM card from scratch again.

    From the router log my best guess is that the 3COM
    card cannot authenticate itself to the router when in
    WPA-PSK mode. At the very moment I switch from
    WPA-PSK to WEP, replacing only the encryption mode
    and the key(s), everything works fine.

    The D-Link now works fine both in WEP mode and in
    WPA-PSK mode, and yes - I have double-checked
    that they use identical keys for WPA-PSK.

    D-Link "knows" both TKIP and AES while 3COM only
    knows TKIP. I used to have encryption mode set to
    "Automatic" in nthe router which worked fine, now I
    have set it to TKIP with no help.

    Suggestions will be appreciated!

    regards Sven
    Sven Pran, Jan 1, 2008
    1. Advertisements

  2. Hi
    The security starts with the Wireless Router/Access Point.
    The Wireless Router has to be set to a certain level and all the clients
    have to follow.
    If even one of the clients can not follow, the setting of the Wireless
    Router's security has to be reduced.
    From the weakest to the strongest, Wireless security capacity is.
    No Security
    MAC______(Band Aid if nothing else is available).
    WEP64____(Easy, to "Brake" by knowledgeable people).
    WEP128___(A little Harder, but "Hackable" too).
    WPA-PSK__(Very Hard to Brake ).
    WPA-AES__(Not functionally Breakable)
    WPA2____ (Not functionally Breakable).
    Note 1: WPA-AES the the current entry level rendition of WPA2.
    Note 2: If you use WinXP and did not updated it you would have to download
    the WPA2 patch from Microsoft. <http://support.microsoft.com/kb/893357>
    The documentation of your Wireless devices (Wireless Router, and Wireless
    Computer's Card) should state the type of security that is available with
    your Wireless hardware.
    All devices MUST be set to the same security level using the same pass
    Therefore the security must be set according what ever is the best possible
    of one of the Wireless devices.
    I.e. even if most of your system might be capable to be configured to the
    max. with WPA2, but one device is only capable to be configured to max . of
    WEP, to whole system must be configured to WEP.
    If you need more good security and one device (like a Wireless card that can
    do WEP only) is holding better security for the whole Network, replace the
    device with a better one.
    Setting Wireless Security - <http://www.ezlan.net/Wireless_Security.html>
    The Core differences between WEP, WPA, and WPA2 -
    Jack (MVP-Networking).
    Jack \(MVP-Networking\)., Jan 1, 2008
    1. Advertisements

  3. Sven Pran

    Sven Pran Guest

    Thanks, but I'm afraid this doesn't help me much.

    OK, here is my complete network:

    Jensen router with four clients:

    Windows Vista cable connected
    Windows XP SP2 Home edition cable connected
    Windows 98 Cable connected to D-Link G810, wireless to the router
    Windows 98SE DELL Inspiron 5100 with 3COM wireless to the router.

    MAC filter active, Broadcast active

    Entire network is operational with WEP

    The highest security level I have been able to use is WPA-PSK. This
    became possible when I found out that I had to zero (disable)
    "Group Key Update" in the router. With this parameter active the DLink
    client dropped contact first time a key update was scheduled. (3COM
    handled this perfectly.)

    I cannot run WPA2 and I cannot run AES. My router suports both but
    my DLink does not support WPA2 and 3COM does not support AES.

    My router can be set to "Automatic" and initially this worked perfectly.
    Specifying TKIP instead of Automatic now makes no difference.

    My problem is that the 3COM client no longer makes contact with the
    router when the network is changed from using WEP to using WPA-PSK.

    The router indicates that it has seen the client and sent some packets
    but not received any at all?

    I fear that I may have deleted some configuration parameters that
    shouldn't have been deleted when I did some cleanup after removing
    a 3COM Ethernet card 3CCFE575CT, but even completely
    reinstalling the 3COM wireless card hasn't helped.

    After all: The 3COM wireless card worked perfectly with either
    WPA-PSK or WEP, now it only works with WEP and I can't find out

    That is what is driving me nuts.

    regards Sven
    Sven Pran, Jan 1, 2008
  4. Sven Pran

    Lem Guest

    The D-Link DWL-G810 is an obsolescent piece of equipment. As originally
    released, it was only capable of using WEP encryption. If you have
    upgraded the firmware (minimum version 2.13 (but that was a beta
    version)) it should be capable of WPA-PSK. The ability to renew the
    master key periodically (Group Key Renewal Interval) is an additional
    security mechanism, and the DWL-G810 *should* be able to handle it. If
    it doesn't, try upgrading to the most recent firmware, which AFAIK is
    version 2.20. The DWL-G810 will never be able to do WPA2, and probably
    cannot handle AES either.

    Your 3Com card is also pretty old. It may also have only supported WEP
    when it was first released. Perhaps when you "cleaned up" the 3Com
    Ethernet card you deleted the newer driver and/or connection management
    software. If you reinstalled these from a CD you had from when you
    bought the card, try downloading the most recent version:

    Lem -- MS-MVP - Networking

    To the moon and back with 2K words of RAM and 36K words of ROM.
    Lem, Jan 2, 2008
  5. Hi
    I understand your pain, but your combination of Wireless is rather unusual.
    Win98 as well as win2000 do not support WPA2 (WPA-AES is basically the same
    Win98 was conceived before the Wireless era, at the time the WIFI alliance
    mandated that Wireless provider would issue hardware that can do WPA on
    Win98. However not all Wireless is WIFI certified, and many manufacturers
    supported Win98 in a very simplistic way; as a result WPA support for
    Wireless Hardware working with Win98 is spotty.
    The one thing that I learned is Not to obsess about is worked before. It
    does not work Now. so one has to find a cost effective way to make it work.
    I would first try to enable the "Group Key Update" in the router a see if
    the 3-com starts to work again on WPA level.
    If it does you have to make a decision either to get rid of the 3com, so
    that the D-Link would work, or get rid of the D-Link.
    I do not know where you reside but when I am at I would get this.
    It an excellent PCI card and when needed l am all set. $30, and trouble
    I do have a Win98 installation for support purposes, unfortunately it is on
    a VirtualPC, and thus useless for debugging Wireless and thus I can not go
    into the OS to see what the Wireless might be missing.
    Good Luck, and happy new year.
    Jack (MVP-Networking).
    Jack \(MVP-Networking\)., Jan 2, 2008
  6. Sven Pran

    Sven Pran Guest

    I have version 3.15 and it works with WPA-PSK except that it cannot handle
    "Group Key Renewal".
    Yes, I am going to try that as well


    regards Sven
    Sven Pran, Jan 2, 2008
  7. Sven Pran

    Sven Pran Guest

    Except that what is causing me headache is the 3Com PCMCIA card in the
    Win98SE machine. According to documentation (and management software)
    it shall support WPA-PSK. It did, but does no longer? DLink operates
    satisfactory now.

    regards Sven
    Sven Pran, Jan 2, 2008
  8. Sven Pran

    Sven Pran Guest

    More on this problem:

    PCMCIA card: 3CRWE154G72 has (as mentioned before)
    worked perfectly in my DELL Inspiron 5100 both with WEP
    and with WPA-PSK, but suddenly it no longer works with

    I did some maintenance and it could seem as if I have
    deleted something I shouldn't have deleted, but I am
    completely unable to identify what that can have been.

    I have even cleaned up the network configuration in the
    PC and installed the 3COM card from scratch again.

    When I tried the 3COM card in another laptop I have
    (running XP) it worked perfectly also with WPA-PSK.

    Now I am looking for something in Windows 98SE that
    can be necessary for WPA-PSK to function but which
    is not needed for WEP, and that I can accidentally have
    lost during my maintenance?

    Still grateful for comments and suggestions.

    Regards Sven
    Sven Pran, Jan 7, 2008
  9. Sven Pran

    Sven Pran Guest

    I begin to suspect that what I have lost is some kind of a
    "Wireless Manager" which for Windows systems previous
    to Windows XP SP2 must be installed separatly(?).

    My search continues, but I shall still be grateful for any

    regards Sven
    Sven Pran, Jan 7, 2008
  10. Sven Pran

    James Egan Guest

    Windows xp was the first version with inbuilt support for wireless
    networking. To use wireless with win98 you must install and use the
    manufacturer's own control software. Often the supplied driver cd is
    out of date and a trip to the manufacturer's website for an update is

    James Egan, Jan 7, 2008
  11. Sven Pran

    Sven Pran Guest

    Below is my OP, here is the solution:

    As I suspected I had lost "something", namely the
    IEEE 802.1X Protocol. I narrowed in to an application
    Aegisl2 which I found in the installation library for the
    3COM card.

    So I tried this application and was told that the
    protocol was installed, did i want to uninstall it?

    I did, and then (after a requested reboot) run that same
    application again. This time it told me that the protocol
    was not installed, did I want to install it? Guess what,
    I pressed "Install", and after another reboot my 3COM
    card was back in its old good mood.

    Thanks to all who came up with hints. Although none
    of them solved my problem directly they gave me the
    ideas for searching in the right places and for the right

    (The reason reinstallation of the 3COM card did not help
    was apparently that the IEEE802.1X protocol was only
    partly removed and therefore did not install again with
    the 3COM card.)

    regards Sven
    Sven Pran, Jan 12, 2008
  12. Sven Pran

    Donna Luciw Guest

    Hi Sven,

    I understand your frustration. We have 4 98se machines that we want to run WPA2 on and the only thing I could find to do this was the Odyssey Client. I have an Asus VL138g v2 pci card. Only using the drivers for the card and then using the Odyssey Client software for security. I am connecting perfectly. Hope this helps.

    Donna Luciw, May 30, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.