WPA-PSK and laptop access problem?

Discussion in 'Wireless Networking' started by Lisa, Sep 25, 2005.

  1. Lisa

    Lisa Guest


    I have a D-link di-624 and I've been using it for a while using the WPA-PSK
    with a desktop using a D-link DWL-G520 wireless network card! I just got a
    laptop that has a built in Broadcom 802.11g wireless card. The laptop won't
    connect to the router if using the WPA-PSK encryption, it takes almost 2
    minutes to get the IP address and then shows, "limited or no connectivity"!
    Switching the encryption to WEP, the laptop connects with no problems! I
    called D-link but they said that they don't support WPA and if I want to use
    it I should figure it out myself!!

    The laptop has SP2 installed and all the latest updates from Microsoft and
    the Broadcom card has the latest driver as well! I hope that someone can
    help me out! I really want to use the WPA if I can! Thank you very much.
    Lisa, Sep 25, 2005
    1. Advertisements

  2. Lisa

    Guest Guest


    i have a d-link 624 router using wpa-psk , i have a acer aspire 3002lci with
    a broadcom 802.11g that has the same problem your having. i used a d-link
    dwl-650 pcmcia card from my other laptop that didn't experience this problem
    to set up a second wireless connection on the acer laptop after i installed
    the drivers it connected up , so i tried the broadcom wireless connection and
    it started to work
    dont know if this will be a permanent fix , but its working now.hope this
    helps you
    Guest, Sep 27, 2005
    1. Advertisements

  3. Lisa

    mac Guest

    It does work fine with the D-link card in the PC as I mentioned, so you are
    right it is compatible with other d-link products! Unfrotuantly, I don't
    have a d-link pcmcia card to fix whatever is wrong or missing in the laptop
    like you did! I am not going to go out and buy one to get the laptop to work
    with wpa-psk, it is just not worth it!

    It should be a little thing in there that needs tweaking and I am sure
    D-link know all about it but for some reason they refuse to support wpa at
    the moment! I hope someone here figured it out and would share it with me.
    Thanks again!
    mac, Sep 28, 2005
  4. Lisa

    Matt Guest

    Same problem here. We have two laptops, one with a NetGear PC Card and
    one with an internal Intel. After attempting WPA, I switched back to
    an open system. Now my wireless network icon in my system tray shows
    that I am disconnected. Yet I am posting this message at the same
    time. Have any of you noticed this?

    Matt, Oct 28, 2005
  5. Lisa

    __spc__ Guest

    If WEP works, and WPA is an option, then WPA will work also. You need XP
    SP2 for WPA - and the latest hardware drivers and firmware. Make sure that
    you're inputting the key correctly. My laptop has broadcom hardware in it,
    and I'm on WPA-PSK (TKIP)
    __spc__, Oct 29, 2005
  6. Lisa

    Lisa Guest

    Not entirely correct and that is according to D-link! I have the latest
    driver for my Broadcom hardware and the latest firmware for the D-link
    router and still my laptop will not connect with WPA-PSK, WEP is not an
    issue!! D-link said that they will only guarantee that WPA-PSK will work
    within the D-link product family. As I said in my original post, I've been
    struggling with this for few months and I can not get it to work, D-link
    will not offer any support to help troubleshoot the problem. I think you
    just got lucky that your adapter and router are somehow WPA-PSK compatible!
    Lisa, Oct 30, 2005
  7. You may well stay unsuccessful with your mixing of D-Link and non D-Link
    However as a long-shot possibility I offer this observation:

    Certain key-sequences or even some characters seem not to go so well with
    some manufacturer's hardware.
    I've had instances, where this 60 character sequence for example
    was pasted repeatedly into different (!) WLAN routers and always ended up
    shortened by more than half of the characters. Of course the same key pasted
    into a receiving NIC was ok and the handshake thereafter unsuccessful. There
    were other discrepancies too, but here's how I got to get mine working:

    Try persisting with a 63 character (504bits) key.
    Start off with making the key really simple, like 1111111111..........and so
    Double-check the count, AFTER you pasted it into the field and again AFTER
    you rebooted the router !
    (use the arrow keys to scroll through all pasted characters!!!)

    If successful, try making more involved keys.

    A long shot, I know, but if you run out of other ideas, it may be worth a

    Herbert Nagler, Oct 30, 2005
  8. Lisa

    Guest Guest

    i solved my wpa-psk problem by using wpa2 . i downloaded new firmware
    updates to my D-LINK di-624 router updated the drivers in the acer laptop
    with the broadcom wireless nic then went to microsoft to update win xp with
    wpa2 update kb893357 and the darn thing works perfectly. hope this works for
    you also

    Guest, Jan 11, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.