WPA not working on Japanese windows XP SP2

Discussion in 'Wireless Networking' started by Dan, Nov 10, 2008.

  1. Dan

    Dan Guest

    I changed my D Link from WEP to WPA PSK and my Dell Windows XP SP2 Home
    connects no problem; however, I have a Toshiba Laptop with Japanese Windows
    XP SP2 OS and it won't finish "acquiring" the SSID once changed. Seems like
    I"m stuck with WEP. Can anyone help?
     
    Dan, Nov 10, 2008
    #1
    1. Advertisements

  2. Dan

    John Guest

    What is the WiFi card make/model? My wild guess is the WiFi card does not
    support WPA but I could be wrong. Have you tried updating WiFi driver?
     
    John, Nov 10, 2008
    #2
    1. Advertisements

  3. Hi
    Windows XP SP2 is by default WPA/WPA2 capable.
    However it takes the info from the Wireless card Drivers. If the card, and
    or, its drivers does not support WPA Windows would not either.
    Log to the support site of the Laptop and check for the latest drives of the
    Wireless Card.
    Jack (MS, MVP-Networking)
     
    Jack \(MVP-Networking\)., Nov 10, 2008
    #3
  4. Dan

    John Guest

    WinXP SP3 is by default WPA/WPA2 capable. WinXP SP2 is WPA capable but needs
    an additional patch to make it WPA2 capable.

    I agree that the hardware + driver must also support them.
     
    John, Nov 10, 2008
    #4
  5. Dan

    Dan Guest

    Thanks, card is

    Intel(R) PRO/Wireless 2200BG Network Connection
    9.0.4.17

    Going online now
     
    Dan, Nov 10, 2008
    #5
  6. Dan

    Pavel A. Guest

    This isn't WPA2 capable. Too old :(

    Regards,
    --PA
     
    Pavel A., Nov 10, 2008
    #6
  7. Dan

    John Guest

    Yes it is. I've been using 2200BG since mid 2005 with WPA2 security.
     
    John, Nov 10, 2008
    #7
  8. Dan

    John Guest

    Oh btw the OP asks about WPA security, not WPA2.
     
    John, Nov 10, 2008
    #8
  9. Dan

    Dan Guest

    Still unable to connect. Updated OS to Windows XP Home SP3 and upgraded
    Intel(R) PRO/Wireless 2200BG card driver to 9.0.4.39 but still cannot connect.

    The Dell connects no problem, the Japanese OS laptop gets stuck in a
    viscious cycle where it tries to connect then fails every 3 seconds. Cannot
    get an IP address. Very frustrating.

    Appreciate any further insight.
     
    Dan, Nov 11, 2008
    #9
  10. Dan

    Frank Guest

    Did you get the driver from Intel site or your notebook manufacturer?
    Is MAC filtering enabled? What if you give that notebook a static IP? Have
    you restarted the router by unplugging/plugging it back? Start over from
    scratch?
     
    Frank, Nov 11, 2008
    #10
  11. Dan

    Marc Guest

    That 3 second loop means it connects to your SSID, but it cannot
    authenticate the connection, because your PSK is wrong.
     
    Marc, Nov 11, 2008
    #11
  12. Dan

    Dan Guest

    Got the driver from the Intel site. MAC filters is disabled. Restarted the
    router & modem with unplug/plug. Should I enable MAC filter or request a
    static IP from my ISP?
     
    Dan, Nov 11, 2008
    #12
  13. Dan

    Dan Guest

    We've triple checked the PSK. Also, as soon as we change the router back to
    WEP we can connect. Seems the problem is related to WPA-PSK security.
     
    Dan, Nov 11, 2008
    #13
  14. Dan

    James Egan Guest

    Have you tried upgrading the firmware of the router? You didn't
    mention which type of router it is or how old it is.

    Quite a few older routers will not be able to handle AES encryption
    with WPA-PSK and you might need to use TKIP. Of course, if you select
    TKIP on the router (it might be implied if TKIP or AES isn't a
    selectable option) you will have to select that on the pc's too along
    with using the correct passphrase.



    Jim.
     
    James Egan, Nov 11, 2008
    #14
  15. Dan

    Dan Guest

    Router is DLink DI-524 with Firmware version 1.21 . Will upgrade to 1.23
    shortly.

    Hopefully this works as upgrading the Intel 2200BG made it worse and we've
    rolled back but are now unable to connect for more than 5 minutes without
    dropping. We've also maxed out power setting for the Intel and that didn't
    seem to work

    Thanks
     
    Dan, Nov 11, 2008
    #15
  16. Dan

    Marc Guest

    You're using a JAP OS and remapped keyboard layout. The 3 second loop
    means the connection is fine but fails WPA authentication, because your
    PSK is wrong. The facts are what they are, what you "see" is not the
    problem, what you cannot see is the problem.

    Change the PSK to 12345678. If you still get the 3 second loop, it is
    because your JAP OS does not translate characters properly. If it works
    with WEP it should work with ASCII characters 0123456789ABCDEF.



     
    Marc, Nov 12, 2008
    #16
  17. Dan

    Frank Guest

    Try using WiFi driver from your notebook manufacturer.
     
    Frank, Nov 12, 2008
    #17
  18. Dan

    Frank Guest

    Good point. Also, when entering the shared key, if every character is
    replaced by *, type it into Notepad so you can see it. Copy/paste them
    later.
     
    Frank, Nov 12, 2008
    #18
  19. Dan

    John Guest

    No. I believe Frank was talking about a static internal IP. That has nothing
    to do with dynamic IP from your ISP. The problem may be related to your
    DLink DHCP server or incorrect password as others mentioned. To find out
    which is causing it, try assigning a static IP address (eg:
    192.168.0.whatever) to the notebook with Japanese OS.

    Take a look at:
    http://reviews.cnet.com/routers/d-link-di-524/4864-3319_7-30839580-3.html
    [snip]
    The router will not accept any of the other options if WEP has been selected
    first. You have to reset the router back to factory defaults and re-do all
    of your settings

    This one also: http://www.wifi-forum.com/wf/showthread.php?t=822
    someone says the following:
    On my DI-624 you have to disable DHCP and go with static IP for wpa-psk to
    work. And download the wi-fi wpa patch from microsoft.

    (note: remember that the discussion in wifi-forum.com occured in 2004 so you
    can ignore the wi-fi wpa patch part.)
     
    John, Nov 12, 2008
    #19
  20. Dan

    Phil K Guest

    All;

    I have seen this problem many times lately and researched many posts and have not yet found and answer...

    This particular situation sounds similar, the differential diagnostic is;

    * Using an inbuilt (older) WiiFi card (Brand seems to be immaterial) however other users report no problems with this card.
    * Any version of windows XP with the appropriate WiFi patch (Sp1-3) or fully updated using windows update.
    * Latest Drivers have been downloaded for the Wifi card and latest firmware for the AP. The brand of AP is immaterial and other users have reported no problems with that particular AP.
    * Passkeys/phrases are correct and have been checked by directly cutting and pasting from the same text file into each application.
    * The PC can connect using DHCP with an attached LAN card and Cat5/6 connection.
    * The PC can connect using WIFI & WEP with DHCP and static IP.
    * The PC can connect using WIFI & WAP and Static IP address.
    * The PC cannot connect using WIFI & WAP and DHCP.
    * Both Winsock and TCP/IP have been reset with Netsh command.

    If this problems exhibits the same characteristics then its NOT, problem related to the windows version, a passkey problem, a DHCP problem, or a TCP/IP stack problem but some funky little problem to do specifically with WPA/DHCP and an, as yet, undiagnosed third condition...
     
    Phil K, Nov 18, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.