Workaround : ISP modem dialup fails @home but not via PABX

Discussion in 'Computer Support' started by Post Master, Mar 2, 2006.

  1. Post Master

    Post Master Guest

    Prev Thread = "ISP modem dialup fails, but only @home not via PABX"

    Well I had my first successful connection last night (after a hiatus in
    testing due to various reasons, Torino 2006 being one of them).

    I don't regard this as a full solution, and I certainly don't know what
    has made the difference, but maybe my feedback will help others who
    find themselves in the same predicament.

    I tried a number of changes, not sure which of these helped, maybe it
    was something else not listed.

    First, I scoured the Smart Link user manual, and collected a set of AT
    commands to try to investigate the problem.

    #UD = show diagnostics
    Does not work at all, don't use it

    This is what I did use (see ref thread above for how to enter these)
    AT L3 M2 &A7 \A0 +MS=34,0,4800,24000
    L3 = high volume
    M2 = speaker always on
    &A7 = show transmit rate
    \A0 = 64 char block size
    +MS=34,0,4800,24000 = V.34 speed between 4800 and 24000 baud

    After the negotation the modem still sends output to the speaker. I was
    surprised at how white the hiss was, I really expected to hear more
    along the lines of tones. Every 2 minutes a burst of control
    information uses the DTMF tones and this is quite useful as a call
    duration indicator.

    I include an excerpt from the log, some things were interesting

    1) There was no echo as I had experienced before (but this occurred
    even when a connection was made, via PABX and another residential
    line).

    2) The usual garbage was displayed after username &password
    verification (usual only when no connection was established), I tried
    to capture this again - maybe this forced the connection to be
    completed
    2.1) Waited about a minute with nonsense ISDN commands on the screen
    shpx
    username:
    password:eek:hyyfuvg
    ~~ÿ}#À!}!}.} %}"}&} }*} } }#}$À#}%}&}%"ÿ
    }'}"}(}"}1}$}%ô}3})}!isdnx2ÝÃ~~ÿ}#À!}!}/} %}"}&} }*} }
    2.2) Tried to capture the text with ^C
    2.3) Finally clicked on DONE, and then in the terminal monitor I saw a
    connected response


    3) The command to select V.34 was partially accepted (V.34 was
    selected) but the speed restriction was rejected and full speed of
    57600 baud was used. Previously V.92 was accepted (see prev thread).


    The connection details just before disconnection were
    Duration 10:54
    Speed 57.6 kBps
    Sent 86'418 Received 557'736
    Compression 0% Compression 0%
    Errors 0 Errors 0

    These confirm the connection speed

    Other points to note:

    Smart Link customer care did not respond to my enquiry.

    I disconnected the home phone. I thought I had tried this in the past,
    but not 100% positive.

    There was quite an electric storm at the time, maybe this lightened the
    residential phone line load.

    The authentication procedure required me to manually enter username and
    password, on the prev successful login (via a different residential
    line) this was not so. This could simply be that I have not quite
    matched the dialup properties, but I do know that I did enter the
    requisite info in the properties box for the dialup used.


    Some interesting lines in the modem log that may be useful :

    These are the modem's own default settings
    03-01-2006 20:08:12.796 - Send: AT &F E0 V1 &A3 &D2 &C1 S0=0<cr>
    :08:12.796 - Recv: <cr><lf>OK<cr><lf>
    :08:12.796 - Interpreted response: OK
    :08:12.812 - Send: ATS7=60S19=0L3M1\N3%C3&H1N1X4<cr>
    :08:12.812 - Recv: <cr><lf>OK<cr><lf>
    :08:12.812 - Interpreted response: OK
    :08:12.812 - Sending user initialization commands.

    This is my custom command
    :08:12.828 - Send: AT L3 M2 &A7 \A0 +MS=34,0,4800,24000<cr>
    :08:12.828 - Recv: <cr><lf>OK<cr><lf>
    :08:12.828 - Interpreted response: OK
    :08:12.828 - Waiting for a call.
    :08:12.828 - TSP(0000): Making Call

    These were all sent a second time, log continued after the second setup
    :

    :08:12.921 - Dialing.
    :08:12.921 - TSP Completing Async Operation(0x000102f2) Status
    0x00000000
    :08:12.921 - TSP(0000): LINEEVENT: LINECALLSTATE_DIALING
    :08:12.921 - TSP(0000): LINEEVENT: LINECALLSTATE_PROCEEDING
    :08:12.937 - Send: ATDT##########,,,,,,,,,####<cr>
    :09:02.218 - Recv: <cr><lf>MODULATION: V.34
    :09:02.218 - Interpreted response: Informative
    :09:02.218 - Recv: <cr><lf>PROTOCOL: LAPM
    :09:02.218 - Interpreted response: Informative
    :09:02.218 - Recv: <cr><lf>COMPRESSION: V.44
    :09:02.218 - Interpreted response: Informative
    :09:02.218 - Recv: <cr><lf>TXRATE 26400<cr><lf>CONNECT 24000<cr><lf>
    :09:02.218 - An unknown response was received while attempting to
    connect, but CD was high so completing successfully
    :09:02.218 - Connection established at 57600bps.

    Here are the events during the connected state
    :09:02.218 - Error-control on.
    :09:02.218 - Data compression on.
    :09:02.218 - TSP(0000): LINEEVENT: LINECALLSTATE_CONNECTED
    :09:32.218 - Read: Total: 613, Per/Sec: 16, Written: Total: 163,
    Per/Sec: 1
    :11:32.218 - Read: Total: 62257, Per/Sec: 513, Written: Total: 9851,
    Per/Sec: 80
    :13:32.218 - Read: Total: 194234, Per/Sec: 1099, Written: Total: 45775,
    Per/Sec: 299
    :15:32.218 - Read: Total: 194562, Per/Sec: 2, Written: Total: 47323,
    Per/Sec: 12
    :17:32.218 - Read: Total: 227267, Per/Sec: 272, Written: Total: 59618,
    Per/Sec: 102
    :19:32.218 - Read: Total: 452246, Per/Sec: 1874, Written: Total: 79898,
    Per/Sec: 169
    :20:50.000 - CD dropped--Remote modem hung up. ModemStatus=00000030
    :20:50.000 - TSP(0000): LINEEVENT: LINECALLSTATE_DISCONNECTED(0x1)
    :20:50.000 - TSP(0000): Dropping Call
    :20:50.000 - Hanging up the modem.
     
    Post Master, Mar 2, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.