wlanapi.dll error after SP3 (D-Link)

Discussion in 'Wireless Networks' started by France, May 10, 2008.

  1. France

    France Guest

    Hi! I had a problem solved thanx to some forums on web, so I post this.
    In D-Link Wireless Network, after installing SP3 at the boot of PC, there is
    an error message about wlanapi.dll. To resolve:
    The D-Link AirPlus Utility does not work with Windows XP Service Pack 3.
    Upon loading, it displays: "AirGCFG.exe - Entry Point Not Found. The
    procedure enry point apsGetInterfaceCount could not be located in the
    dynamic link library wlanapi.dll.".
    A workaround is to use the pre-SP3 version of wlanapi.dll and place it in
    the appropriate directories. Upon loading, this version of the file will be
    used instead of the version in the System32 directory.

    xcopy %Windir%\$NtServicePackUninstall$\wlanapi.dll
    "%ProgramFiles%\D-Link\AirPlus G"
    xcopy %Windir%\$NtServicePackUninstall$\wlanapi.dll
    "%ProgramFiles%\ANI\ANIWZCS2" --


    it worked fine on my PC desktop with Windows XP Pro SP3.....
    France, May 10, 2008
    1. Advertisements

  2. France

    France Guest

    Sorry....i've seen in this forum there's the solution....
    France, May 10, 2008
    1. Advertisements

  3. France

    StaRipper Guest


    Download and install the new driver.

    StaRipper, May 15, 2008
  4. Good on you for posting your resolution!

    Bon chance!
    Jamie Richards, Jun 29, 2008
  5. France

    My Guest

    Hi! I have the same problem, but I don't get what to doo about it.
    How do i download the pre-SP3 version of wlanapi.dll????
    Bye My
    My, Sep 19, 2008
  6. France

    Pavel A. Guest

    Contact D-Link for update. They caused DLL name conflict
    (aka "DLL hell") with MS, they ought to provide update
    for their software that resolves this.

    Pavel A., Sep 19, 2008
  7. I am using a D-link Air Premier DWL AG660 Wireless card. After installing Windows service pack 3 I started getting the following messages every time I was booting up.

    AirGCFG.exe - Entry Point Not Found
    The procedure entry point apsGetInterfaceCount could not be located in the dynamic link library wlanapi.dll
    WZCSLDR2.exe - Entry Point Not Found
    The procedure entry point apsInitialize could not be located in the dynamic link library wlanapi.dll

    All I would do is dismiss them and allow the computer to complete the boot. I was able to connect the internet so was not to fussed although it started to get a bit annoying. This is how I solved it.

    1.Follow the link to download new drivers. This will take you to D-link support website.


    2. Select the model of the d-link hardware
    3. Read the Q/A by scrolling down the page and select the one about problem with SP3
    4. Select to download new drivers for correct model number. (When you download SAVE to a folder you remember were it is)
    5. Once finished downloading, open file and click setup.

    Just a quick note, I had to shut down and restart the laptop about 3 times throughout this. When you first press setup, it uninstalls the previous software & drivers. This is when to shut down and reboot. Windows will detect new hardware as it is booting. Just ignore this and go back to were you saved the new drivers and click on setup again. Once complete reboot again and then select the wireless network you wish to connect with.

    Problem sorted
    leeroy santana, Nov 16, 2008
  8. Jack \(MVP-Networking\)., Nov 17, 2008
  9. France

    Pavel A. Guest

    This is a known issue, and a known solution.
    Thanks for confirming with detailed instructions.

    Pavel A., Nov 17, 2008
  10. France

    erniek Guest


    I tried this and I'm stilling getting the missing .dll file error.
    I even found and downloaded the wlanapi.dll and placed it in the respective
    directory "%ProgramFiles%\D-Link\AirPlus G" and
    "%ProgramFiles%\ANI\ANIWZCS2" - what am I doing wrong?
    erniek, Jan 27, 2009
  11. France

    Pavel A. Guest

    You're not using the "official" (or how they name it) driver
    install/update software from the WLAN device vendor.
    If the s/w package and instructions for SP3 problem are
    not available on their site, call their support.

    Pavel A., Jan 27, 2009
  12. France

    erniek Guest

    Hi. thanks for the quick response. Unfortunately for me I unistalled sp3 when
    I first starting experiencing this problem. I then came across solutions
    posted across the web similar to yours but when I tried it it didn't work i
    believe becuase the wlanapi.dll was no longer located in
    %Windir%\$NtServicePackUninstall$\ - but I am still getting the same error
    messages even when I try to reinstall my dlink software. I have tried to find
    the latest dlink software from their site [for my dwl g630 rev a] but it has
    made no difference. Does anyone know where I can locate the pre-sp3
    wlanapi.dll file [228kb] or an alternative solution?

    Ive tested a different wireless card from a friend and it works fine on my
    laptop. otherwise it looks like i will have to rebuild my machine or buy a
    new card!
    erniek, Feb 14, 2009
  13. France

    Storhannus Guest

    Hi. Youll find the wlanapi.dll tha Youve had before installing SP3 from the
    location below described. If You run those tools on Your cmd, You can get the
    file to somewhere safe. With D-link DWL-G122 this worked.

    Hope this helps. This is staightforwardly copied from another page here in
    microsoft site.

    xcopy %Windir%\$NtServicePackUninstall$\wlanapi.dll
    "%ProgramFiles%\D-Link\AirPlus G"
    xcopy %Windir%\$NtServicePackUninstall$\wlanapi.dll

    Storhannus, Oct 25, 2009
  14. France

    Pavel A. Guest

    A *way* better idea is to get the latest SP3 compatible version
    of the vendor WLAN drivers.

    A long time passed since SP3, all vendors have their stuff updated.
    The poor guy guilty for that DLL name conflict with the MS Wireless update
    probably will get back to work from jail soon ;)


    Pavel A., Oct 29, 2009
  15. Okay i did this but i still get one error message (instead of two)
    brown.eyed.girl21, Jan 24, 2010
  16. Hi
    It seems that the D-Link Wireless Utility and WZC native utility are both
    loading into memory.
    Only one Wireless Utility can be active at the same time.
    Disable one of them and try again.
    Jack (MS, MVP-Networking).
    Jack [MVP-Networking], Jan 25, 2010
  17. France

    OldBeaver Guest

    What is expected from Microsoft Vista is a solution, not more problems.
    To follow your solution is a pain, bigger than the original problem.

    You just make a good operating system, OR, as you constatly spy our
    computers and ask for sending error messages, just make an easy automatic
    solution to users who paid for an OPERATING system, not an NON-OPERATING
    system or QUASI-OPERATING system.

    Tks, A LOT !
    OldBeaver, Jun 3, 2010
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.