WLAN card gets signal but no IP Address

Discussion in 'Wireless Networking' started by Roshan Qureshi, Jun 8, 2005.

  1. I have an OEM Orinoco Mini-PCI WLAN card in a Windows 2000 notebook. It
    finds the wireless router just fine (SSID is detected; signal is strong (5/5
    bars); MAC address of router is detected; there is no security on the
    router) but it does not acquire an IP address (yes, it is setup for DHCP).
    Here's what I have tried and found:

    .. swap cards with a known-good one: same problem.
    .. Uninstall card driver & client mgmt. software. Download and install
    latest driver/SW from vendor's web site: same problem.
    .. Install latest driver/SW from Agere's (chipset maker) website: same
    problem.
    .. Install another (brand and model) WLAN card in PC Card slot: success!
    .. Uninstall/reinstall TCP/IP (Microsoft KB Article 837333): same problem
    .. For another, unrelated issue, swapped out the computer shell (everything
    except HDD, WLAN card, optical drive, & battery) for a known-good one.
    .. Give card a static address: same problem.

    Does anyone have any suggestions short of doing a clean reinstall of Windows
    (which I'm pretty sure will fix the problem since the hardware seems OK, but
    will take a solid day to do)?

    Thanks in advance,
    roshan
     
    Roshan Qureshi, Jun 8, 2005
    #1
    1. Advertisements

  2. Roshan Qureshi

    Clark Guest

    You never give the name or model of the router. Have you checked their
    website for updates and possibly compatibility problems with that type of
    card?

    Can you use a different brand router to test? Sometimes words or phrases
    used in setting up the cards and/or routers are a little different and don't
    always mean the exact same thing.

    Clark
     
    Clark, Jun 8, 2005
    #2
    1. Advertisements

  3. Roshan Qureshi

    Jack \(MVP\) Guest

    Hi

    Seems that you did every thing right, might be the card is functional any more.

    Since new PCMCIA cards can be found these days for $10 there is no need to “Break you

    Heart” because of a piece of plastic. ;) ;)

    Jack (MVP-Networking).
     
    Jack \(MVP\), Jun 8, 2005
    #3
  4. The router is a Linksys WRT54G. The card, as I mentioned, is an OEM ORiNOCO
    Mini-PCI (chipset by Agere). This machine/card has failed acquire an IP
    Address (DHCP or static) on multiple routers of different brands & models,
    though it always picks up the SSID, channel, &c. This same card, when
    installed in another PC of the same model, works fine with this router.

    As for words/phrases being different in various client managers, that is a
    pet peeve of mine. Since this card detects the router's channel, SSID, and
    MAC correctly, I believe that all the wireless-specific settings are
    correct.

    I suspect that the issue at hand is not specific to wireless networking, but
    some other Ethernet/TCP/I-don't-know-what setting for this connectoid on
    this machine. Does anyone know how to delete a connectoid and all its
    settings (files, registry entries, &c.)? Any other ideas?

    thanks,
    roshan
     
    Roshan Qureshi, Jun 8, 2005
    #4
  5. Thanks, Jack. The card is good; I put it in another machine of the same
    model/OS and it works. It's something with this card in this machine . . .

    rq
     
    Roshan Qureshi, Jun 8, 2005
    #5
  6. Roshan Qureshi

    Clark Guest

    Clark, Jun 8, 2005
    #6
  7. Roshan Qureshi

    Clark Guest

    Clark, Jun 9, 2005
    #7
  8. I have. I experienced this problem when I was running SP3, but I found a
    patch (presumably addressing this issue) on the computer vendor's web site
    that fixed it. Later, I upgraded to SP4 and the card still worked. [I
    don't know if I mentioned this before, but it should now be clear that the
    card has worked in the past.]

    thanks,
    roshan
     
    Roshan Qureshi, Jun 9, 2005
    #8
  9. Interesting! I'll try that when the user returns from his current trip &
    let you know. Thanks again for all the help and research!

    roshan
     
    Roshan Qureshi, Jun 9, 2005
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.