Wireless Zero Configuration service not starting.

Discussion in 'Wireless Networking' started by Guest, Nov 5, 2004.

  1. Guest

    Guest Guest

    When I try to manually start this service on my XP SP2 machine, I get this
    error message:

    "Could not start the Wireless Zero Configuration service on Local Computer.
    Error 1058: The service cannot be started, either because it is disabled or
    because it has no enabled devices associated with it."

    I have my drivers for the wireless card installed properly, so what can I do
    to fix this problem so that I can start this service?

    Guest, Nov 5, 2004
    1. Advertisements

  2. Guest

    Pavel A. Guest

    This can be result of activity of 3rd party software installed with your wireless card.
    Unfortunately some these "utilities" can't do any better than disabling the service.
    Pavel A., Nov 5, 2004
    1. Advertisements

  3. Guest

    Guest Guest

    When I removed the software that came with the card, I was still unable to
    restart the service.
    Guest, Nov 5, 2004
  4. Did you check the Event Viewer? If not, check the Event Viewer and see if
    there is any relevant error messages. Click Start, Control Panel,
    Performance and Maintenance, Administrative Tools, and then click Event
    Viewer. For more details, see the following MS KB Article. Details here.

    How To View and Manage Event Logs in Event Viewer in Windows XP

    Check the Services, click Start, Run, and type "services.msc" - without
    quotes and scroll down to Remote Procedure Call (RPC) and check the status
    for it.

    Eric Cross
    Microsoft MVP (Windows Networking)
    Eric Cross [MVP], Nov 6, 2004
  5. Guest

    Guest Guest

    Hi Eric,

    There are no error messages associated with the Wireless Zero Configuration

    I checked the Remote Procedure Call (RPC) and it was allready running since

    Guest, Nov 6, 2004
  6. Eric Cross [MVP], Nov 6, 2004
  7. Guest

    Tanya Guest

    Go to regedit HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WZCSVC

    add a DWORD entry named "Start" and
    value "2"
    "2" is automatic.
    In the jhelp files in Computer Management all the Services are listed for
    the default settings look there if you have been messing with Services.
    Reboot if you change anything.
    Tanya, Nov 6, 2004
  8. Guest

    Pavel A. Guest

    Ok then what happens if you type in "dos" window:
    SC start wzcsvc
    SC queryex wzcsvc

    Pavel A., Nov 6, 2004
  9. Guest

    Tanya Guest

    The path is either (systemroot) orC:\windows\inf\netwzc.inf. Click Open.
    Then click OK. Choose Wireless Zero Configuration. Click OK. Restart the
    system. Then it will show up in Services.msc. It is already started. If it
    won't stay started Regedit will do that or you have something conflicting
    like running the wireless Network Manager Software at the same time. You
    have to use one or the other not both.
    Tanya, Nov 6, 2004
  10. Guest

    Guest Guest

    Network Card:
    Asus 802.11b WiFi motherboard addin card

    When happened when I tried to start it in dos using SC start wzcsvc ?
    I got the same error message:
    Error 1058: The service cannot be started, either because it is disabled or
    because it has no enabled devices associated with it

    What happened then when I tried to check its status using SC queryex wzcsvc
    Along with a bunch of other info, the STATE :1 STOPPED

    I couldn't find the netwzc.inf file.

    It is allready setup to automatically start at bootup, but it still doesn't.
    Strange this is this WAS working a few days ago, then when I rebooted I was
    no longer able to start the service. I was always able to start the service
    manually with the Asus software running at the same time, but now I can't.
    Wireless connection is a big NO if the Asus software is on or off with or
    without WZC. It doesn't work with WZC running alone.

    I don't think it is a conflict because no other wireless software is running
    or started durinig bootup. Which I don't think it would matter anyways
    because it ran fine with the Asus software before I booted up.

    The error message "The service cannot be started, either because it is
    disabled or because it has no enabled devices associated with it" seems
    straight forward. When disabled, starting it up does no good, so it must
    have no enbled devices associated with it, right? So how hard is it to
    associate something to it?

    Guest, Nov 7, 2004
  11. Guest

    Tanya Guest

    There you go you are using the Asus Network software so it us turning off
    WZC. If you want to use WZC then open the wireless network card properties
    put a check next to Use windows to configure my wireless network settings.
    Don't use the Asus Network Manager. You can't use both to run the network.
    Just disable WZC. Then there is no conflict.
    In order to see the inf folder you have to unhide files in Folder
    Tanya, Nov 7, 2004
  12. PMBI, but I am having similar problems with an on-board Intel PRO/Wireless
    LAN 2100 3B. However I can't find the "Use Windows to configure my wireless
    setting" button. Could you give a bit more detail as my old grey cells
    aren't up to this?
    Bob Peel, MVP, Nov 7, 2004
  13. Guest

    Tanya Guest

    Go into the Network Connections Folder. Go to properties of the wireless
    card. I am using WZC there are three tabs at the top of the card properties
    and one says wireless network. That is the one. You won't see it if you are
    going through the Proset Software. You might see let this tool manage my
    wireless network. That means Proset is managing the network.
    Tanya, Nov 7, 2004
  14. OK - been there done that and I still have to start WZC manually. If I
    connect to my Netgear wireless router it will stay connected. But if I
    disconnect then next time I want a wireless connection I have to manually
    start WZC.

    I have checked that the registry setting is
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WZCSVC with Start = 2.

    Any other suggestions please?.
    Bob Peel, MVP, Nov 7, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.