Wireless XP SP2 networking issues.

Discussion in 'Wireless Networking' started by Guest, Jan 5, 2005.

  1. Guest

    Guest Guest

    I have an existing combination network, hard-wired and wireless using a
    Linksys WRV54G Router which supports both the B & G protocols. Have 2 desktop
    PC's (XP SP1) both hardwired and 2 laptops both wireless (1- Win2k & 1 XP
    SP1). The network uses static IP addressing. I just purchased a new laptop
    which is preinstalled with XP SP2 and which has the ability to use either B
    or G wireless. I have assigned the new laptop a static IP address, and
    entered the DNS and Gateway information. It connects to the wireless network
    but I cannot see any of the other computers on the network or the shares, nor
    can I ping anything (not the machines on the network, or the router or
    anything on the internet). I'm baffled and am open to any suggestions.

    Thanks for your help.
    Tina
     
    Guest, Jan 5, 2005
    #1
    1. Advertisements

  2. Guest

    Tony Guest

    Have you tried with the XP firewall turned off?
     
    Tony, Jan 5, 2005
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    Yes I have disabled the firewall and tried that also.

    Another fact and I'm sure this is the cause but don't know why it's
    happening - even though I've hardcoded the IP, DNS and Gateway Address into
    the properties on the wireless.. when I run and IPCONFIGA
     
    Guest, Jan 6, 2005
    #3
  4. Guest

    Guest Guest

    Sorry my previous message went without beign finished.

    What I was saying is when I run and IPCONFIG, the gateway comes in blank. I
    checked the TCP/IP properties again, and went into the advanced settings and
    the gateway IP is there. I don't know why ipconfig isn't showing it.

    Tina
     
    Guest, Jan 6, 2005
    #4
  5. Guest

    Tony Guest

    Do you have DHCP enabled in the router? If so will the new PC connect if
    you change TCP/IP to be allocated IP address automatically?

    Is the Local Area Network Connection showing as No. 2 or 3?
     
    Tony, Jan 6, 2005
    #5
  6. Tina,

    I believe that there is some problem here regarding the configuration of
    this interface. You entered the IP address/Subnet Mask/Gateway address in
    the blanks located on the "General" tab of the TCP/IP configuration page,
    correct?

    Could you provide the exact numbers you are using to configure this network
    to me? Maybe there is some problem with the network addresses you have
    choosen.

    Now, if the config info was corrupted, this problem might also happen. You
    could choose to uninstall and reinstall this adapter. You can do this
    through Device Management ( run "devmgmt.msc")
     
    Brian Wehrle [MSFT], Jan 6, 2005
    #6
  7. Guest

    Guest Guest

    Yes I entered the information on the General tab of the wireless adapter.

    The IP address is 10.0.0.194
    The subnet is 255.255.255.0
    The Router/Gateway address is 10.0.0.251 (I know that normally it would be
    10.0.0.1 but it's set this way intentionally by my boss).

    I will try the adapter reinstall, even though it's a brand new laptop and I
    just wanted to attache it to do the updates.

    Thanks!
     
    Guest, Jan 6, 2005
    #7
  8. Guest

    Guest Guest

    I have now removed the wireless adapter through the device manager, and
    reinstalled it. Now on reboot Ipconfig does have the default gateway, as well
    as the network IP address and DNS entries. However I still cannot see or
    connect to the other computers in the same workgroup, nor do I get Internet
    access.
     
    Guest, Jan 6, 2005
    #8
  9. Tina,

    Well, one step at a time. Since you now have the correc information, it
    will be worthwhile to pursue the next logical
    step. Please try doing a ping from the workstation to the router (from the
    cmd.exe window):
    ping 10.0.0.251
    You should be able to do thing ping. If there is an error message, please
    post what the output of the ping command is.

    Once you can do a ping to that machine, you should be able to ping the DNS
    servers. These also should be entered in that same page to allow
    for correct network access. If they are not entered, you will need to get
    these numbers from another machine and enter them where you put the rest of
    the
    TCP/IP information.

    --
    Brian Wehrle

    Software Test Engineer/Wireless Networking
    Microsoft Corp.
     
    Brian Wehrle [MSFT], Jan 7, 2005
    #9
  10. Guest

    Guest Guest

    Thanks for the thoughts but I had already tried pinging the router, other
    systems on my home network and the DNS servers. What I finally found in the
    newsgroups all the way back a number of pages was someone who posted the only
    way they were able to get theirs to work was to not use WEP or WPA. I
    disabled the WEP (had been at 64 bit) and immediately everything started
    working. I've read even further back amoung the threads and this apparently
    is a common issue. It doesn't seem as though there has been any fix for it.

    If you have other suggestions I'm certainly willing to try. Thanks!
     
    Guest, Jan 8, 2005
    #10
  11. If by disabling security things "suddenly work," you may have mismatched
    security settings. For WEP encryption to function properly, the keys must
    match between the access point and the client machine. Double check that
    you have matching keys on both devices.
     
    Jerry Peterson[MSFT], Jan 11, 2005
    #11
  12. Guest

    Guest Guest

    Thanks - have already done that - Linksys router, you enter a password and it
    gives you 4 keys. Even put in MAC addresses as a test saying only the listed
    MAC addresses can access the network. Still no good. And the wireless is
    working fine on the 2 non-XP SP2 computers. We even tried a new password and
    new keys - same result. SP2 system loses the network and all the rest are
    okay.

    Tina
     
    Guest, Jan 11, 2005
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.