wireless network problem (after service pack 2)

Discussion in 'Wireless Networking' started by Guest, Sep 16, 2004.

  1. Guest

    Guest Guest

    after i installed service pack 2 on my second computer which uses the
    wireless adapter it fails to work. when i delete it from the perfered
    networks list, it automatically fines the correct network (SSID) then attemps
    to connect ... no matter the conectivity (usually good or verry good) the
    status becomes aquiring network address (didnt it already find this when it
    searched for networks in range?) then it times out of that operation and says
    "Status: limited or no connectivity" ... this makes no sense to me since it
    finds the correct network and everything ... why is this happening? NOTE:
    before SP2 i had it working perfectly fine with WEP encryption i have tried
    no encryption and WEP also ... i am using a linksys wireless B router, but
    really im quite sure that SP2 has something to do with this, since this is
    exactly when my wireless stopped working. please does anyone know what is
    wrong?
     
    Guest, Sep 16, 2004
    #1
    1. Advertisements

  2. Guest

    Lance Guest

    The "limited connectivity" warning notice is because your wireless NIC
    can't find a DHCP server. DHCP is what hands out IP addresses to network
    cards. Since the card can't get an address by DHCP, it gives itself one
    in the 169.254.x.x range.

    I assume your other computer gets an address just fine, your DHCP server
    works. So the problem is in the wireless computer.

    If your network has worked before and you have a history of
    spyware/adware/virus infections, then there could be a problem with
    winsock or the TCP/IP stack on the wireless computer.

    Install, update and run full scans using Spybot Search & Destroy,
    Ad-Aware and your favorite antivirus software to remove any current
    infection.

    Then try resetting your winsock with this article:

    [Either of these could break third party network software like Novell
    Client, Cisco VPN, etc. These need to be uninstalled and reinstalled.]

    Microsoft Knowledge Base Article - 811259
    How to determine and recover from Winsock2 corruption
    <http://support.microsoft.com/default.aspx?scid=kb;en-us;811259&Product=winxp>

    If this is not successful, try this one:

    Microsoft Knowledge Base Article - 299357
    How to reset Internet Protocol (TCP/IP) in Windows XP
    <http://support.microsoft.com/default.aspx?scid=kb;en-us;299357&Product=winxp>

    Lance
    *****

    qwerty thought carefully and wrote on 9/15/2004 6:11 PM:
     
    Lance, Sep 16, 2004
    #2
    1. Advertisements

  3. I just experienced the same problem on my upgrade. M$ would see the network
    but couldn't connect. I switched to the hardware connection utility from
    the hardware vendor and it now works.

    I do/did not have any viruses, spyware problems etc.

    SP2 is a lot slower to boot up now too.

    M$oft 250MB servicepacks suck AND blow at the same time.

     
    Display Name Here, Sep 16, 2004
    #3
  4. Guest

    Guest Guest

    Since installing SP2, I have a problem with my wireless connection. I use a
    Netgear MA101 which worked perfectly prior to SP2. The problem I have is
    that the WEP key settings (length) seem to be overwritten when starting up.
    I can change the settings using the Adapter Utility and the the wireless
    functions normally. It looks like SP2 is overridding settings. Any ideas.
     
    Guest, Sep 17, 2004
    #4
  5. Guest

    Lance Guest

    You're using the utility that came with the adapter? Turn off Wireless
    Zero Configuration service. Both the utility and WZC are trying to
    configure the adapter.

    Start/Run/type in services.msc, hit return. Find Wireless Zero
    Configuration service in the list and disable it.

    Lance
    *****

    Alan Davies thought carefully and wrote on 9/17/2004 11:19 AM:
     
    Lance, Sep 18, 2004
    #5
  6. Guest

    Guest Guest

    I have had similar problem after installing SP2 today. Did anybody find a
    working solution?

    After installing SP2 I have been able to connect to 802.11b wireless network
    but I am unable to receive IP address from DHCP. There were no problems prior
    to installing SP2. My wireless network is not encrypted nor secured any other
    way. The same network connection with my ethernet adapter works just fine
    with no problems.

    I have uninstalled the network driver, fetched the newest one from the
    manufacturers home page and installed it. The problem remains.

    I am using Intel Centrino chipset with Intel Pro/wireless 2200BG chip for
    WiFi connections.

    Tomi
     
    Guest, Sep 18, 2004
    #6
  7. Guest

    Guest Guest

    I even tried to reinstall TCP/IP as described in Microsoft Knowledge Base
    Article - 811259. No help. According to intel the driver I'm using should be
    SP2 compatible.

    Tomi
     
    Guest, Sep 18, 2004
    #7
  8. Guest

    Guest Guest

    I'm convinced there is a bug in SP2.

    I have two wireless laptops and a wired desktop on one router. The desktop
    and one of the wireless laptops work fine, but the second, a centrino laptop
    will not resolve the IP address. It worked fine prior to SP2 and still does
    occasionally.

    The centrino machine is a Tosh M2 with built in ethernet and wireless. If I
    plug in a ethernet cable, it connects no problem, and this fixes the wirelss
    issue at the same time. I can then disconnect the ethernet cable and use
    wireless as normal.

    The other laptop is an older machine - a Tosh tecra 8000 - so doesn't have a
    built in ethernet or wireless link.

    I suspect the bug it is to do with having two TCP/IP ports enabled.

    I have not seen a fix yet for this yet. MICROSOFT ARE YOU LISTENING?

    Simon.
     
    Guest, Sep 21, 2004
    #8
  9. Guest

    Guest Guest

    I have a possible lead for you to look at. I had the same problem after
    putting SP2 on my daughters latptop. I uninstalled it and it still had
    problems. I re-installed it and the connections appeared. It was working
    fine until I took the updates for MS Net Framework 1.0 SP3, MS Nete Framework
    1.1 SP1, and MS GDI + Detection tool. I did not install these and it is
    working fine still. It is one of these updates causing the problem. Try
    removing them if possible or you might have to uninstall XP SP2 and reload
    it, but don't take those updates. I haven't had time to load them one at a
    time to see which one it is but I believe it's one or all of them. Hope this
    guides you to a solution.
     
    Guest, Oct 6, 2004
    #9
  10. Guest

    ohso! Guest

    Right on, rick! I uninstalled sp2 from my sony vaio that uses intel pro
    wireless 2200bg and voila, no problem connecting. The only issue I have
    now is when I try to reinstall parts of sp2 I can't tell what not to
    install...meaning all i get is a list like:

    Security Update for Windows XP (KB83376)
    Critical Update for Windows XP (KB88791)
    Security Update for Windows XP (KB93987)
    Security Update for Windows XP (KB84386)

    Argh!
     
    ohso!, Jan 13, 2005
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.