Wireless Network in Home

Discussion in 'Computer Security' started by John Seeliger, Sep 27, 2003.

  1. Not sure where to ask this question, but will try here.

    I just set up a network for my mom and step-father. There are two PCs: a
    CTX SAK-266 (Windows 98) and an eMachines T1090 (Windows XP Home). Two
    Siemens Speedstram 1022 USB Network Adapters running in Ad-Hoc mode connect
    them. The eMachines is the internet gateway machine.

    1. I was told that files in the "Shared Documents" folder on the CTX
    computer would be invisible from the internet, but that the eMachines files
    could be seen by a hacker. Is this correct?

    2. Do I need a different firewall that ICF?

    3. Should I put WEP on? 64-bit? 128-bit? I assume that this would only
    matter if someone was within 802.11b range and eavesdropping, and would not
    matter for protecting the network from an internet attack. Besides, the
    128-bit would be too intensive for the CTX.

    Thanks.
    -John
     
    John Seeliger, Sep 27, 2003
    #1
    1. Advertisements

  2. John Seeliger

    Jim Watt Guest

    yes, but that range might be greater than you think
    No.
     
    Jim Watt, Sep 27, 2003
    #2
    1. Advertisements

  3. John,

    You will want to secure your internet connection by disabling file and print
    sharing on that connection. On your XP computer, right click on Network
    Places from your desktop and select properties. You should then see 2
    connections - one to the internet, and a wireless connection to the other
    computer. Right click the internet connection and select properties. Under
    "connection uses the following protocols", uncheck EVERYTHING except TCP/IP.
    This will patch up a couple of security holes in your internet connection.
    File sharing to the other home computer should remain unaffected because
    it's running through the other network connection.

    For casual home use, the ICF included in XP is fine.

    You will DEFINITELY want WEP turned on. If it's not on, anyone within range
    of your connection can hook up to your network. You should have it set to a
    128-bit key. 128-bit over 64-bit won't really affect your resources. WEP is
    not the end-all be-all of wireless security, but it really helps to deter
    people from snooping around.

    Hope this helps,
    --Donald
     
    Donald Jacobsen, Sep 27, 2003
    #3
  4. John Seeliger

    JT Guest

    If you run a firewall on the eMachine, it will help but it is more
    vulnerable because it is directly connected. At the minimum make sure the
    XP firewall is turned on.
    Probably want to get a different firewall. Either something like ZoneAlarm
    or Sygate, or even better an external router with firewall built in
    You are open to any kid within about 1000 feet and a cantenna. 128bit
    encryption is not too much of a load for your older machine. Some of it is
    taken care of by the wireless adapters.
     
    JT, Sep 28, 2003
    #4
  5. John Seeliger

    Mimic Guest

    ^^ Just thought I'd add that when Ive used ICF Ive experienced a "connection
    lag", in particualr when connecting to an IRC server it could take up to
    5mins to get through as apposed to the usually few seconds, so if you use
    irc and icf and this happens you know what it is.

    --
    Mimic

    "Without Knowledge you have fear, With fear you create your own nightmares."
    "There are 10 types of people in this world. Those that understand Binary,
    and those that dont."
    "C makes it easy to shoot yourself in the foot. C++ makes it harder, but
    when you do, it blows away your whole leg"
     
    Mimic, Sep 28, 2003
    #5
  6. What's happening is that your computer is not responding to the IRC server's
    identd request, because the identd port is blocked by ICF. Try going into
    your internet connection's properties, go to the Advanced tab (where the
    check box for ICF is), and hit Settings. You should be in the Advanced
    Settings window, under the Services tab. Hit "Add", put "identd" as
    description of service, "127.0.0.1" as ip address of computer hosting the
    service, and for internal and external ports, put port 113 (TCP). Hit OK,
    close everything out, and tada... no more IRC connection lag. :)

    --Donald
     
    Donald Jacobsen, Sep 29, 2003
    #6
  7. Got that one on.
    CompUSA has a Belkin router $69.99 - $40.00 = $29.99
    (http://www.compusa.com/products/product_info.asp?product_code=301825&pfp=BR
    OWSE). Is the firewall on this one pretty good?
    I think I might have confused the 128-bit with something I had read. I
    believe I read that it takes a powerful machine to crack 128-bit and I had
    confused that with that it takes a powerful machine to encrypt it, which
    doesn't make sense, now that I think about it.

    Also, I took Donald Jacobsen's advice and removed all protocol's but TCP/IP
    from the dial-up connection. Only QoS or something like that was there.
    Had to uninstall it as it wouldn't uncheck.

    Thanks to all who helped.
     
    John Seeliger, Sep 29, 2003
    #7
  8. John Seeliger

    Mimic Guest

    cool thx :D

    --
    Mimic

    "Without Knowledge you have fear, With fear you create your own nightmares."
    "There are 10 types of people in this world. Those that understand Binary,
    and those that dont."
    "C makes it easy to shoot yourself in the foot. C++ makes it harder, but
    when you do, it blows away your whole leg"
     
    Mimic, Sep 29, 2003
    #8
  9. John Seeliger

    Britten Guest

    Britten, Sep 29, 2003
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.