wireless home workgroup network; 1 shared HP printer not working

Discussion in 'Wireless Networking' started by Guest, Jun 14, 2005.

  1. Guest

    Guest Guest

    Specifically, the HP printer is NOT working on the other workgroup printers
    that are on the home network. The other 2 computers are XP - successfully
    ran the network wizard, all computers show up as well as the shared printer
    (YES, file and printer sharing is enabled) Additionally, the printer is
    attached to a Windows 2000 system which is wired directly to the Linksys
    DI-624 4-port wireless router/switch and the 2 XP systems connect over the

    I was printing a couple of months ago and not sure what has changed on my
    network. I CAN PRINT from the computer directly attached to the printer (USB
    The exact error message is: "Test page failed to print" and then it asks if
    I want to use the troubleshooter, which did not help much. So as you can
    see, I was able to "Add" the network printer to each wireless system, but
    cannot print to the printer from the wireless systems.
    Would really appreciate any assistance, as this one is hurting my
    Guest, Jun 14, 2005
    1. Advertisements

  2. Guest

    DanR Guest

    Have you made any changes to any software firewall programs? If so check into
    You say you were able to "Add" the network printer etc. Did things work fine
    AFTER you did this for some time before the problem started? You may want to
    troubleshoot with one computer at a time. Remove the network printer and start
    over. When you add a network printer the computer is supposed to GET the driver
    for the printer over the network. Let that happen again.
    DanR, Jun 15, 2005
    1. Advertisements

  3. Guest

    Guest Guest

    No changes to firewalls; in fact, I disabled the Windows Firewall on the XP
    systems to see if I could get the printer thing working. ALL of my file
    sharing is working for some odd reason - it's just the printer sharing. I
    understand about the drivers supposed to d/l from the network, but it's not
    happening, I just get a message saying I successfully completed adding the
    network printer, but when I try to print from it, I get the error
    (IMMEDIATELY). I can even dbl click on the printer and set print properties,
    but can't print. I can even access the printer properties via web browser
    through IIS, but no can print. I even tried dragNdrop ops to get SOMETHING
    to print, but no dice.

    Interestingly enough, when this first occurred, I checked the printer and it
    would NOT work from the attached printer; I uninstalled the printer,
    rebooted, and reinstalled the printer.

    I also tried renaming the home network workgroup, but I would NOT recommend
    that for anyone with little experience............. it only took me a couple
    of hours to "flush" the old settings in all three computers.......doh and
    the router.

    I also tried to "reset" the printer by unplugging, but it is working fine
    within the computer it is attached to, just not working on the workgroup
    network (Wireless), and like I said, ALL the file sharing is working, just
    not the printer sharing, even though it appears to add the network printer.
    I've tried several different ways of adding the network printer, but all end
    up the same way not printing and giving error msg.
    Guest, Jun 15, 2005
  4. Guest

    DanR Guest

    Have you tried loading the printer software onto the XP computers? (from printer
    install CD) It's my understanding you don't need to do this but I think it will
    insure the correct driver is available on the XP machine. Could be a problem
    because of Win2K and WinXP. Maybe the driver that the XP machine needed was not
    on the 2K machine.
    DanR, Jun 15, 2005
  5. Guest

    Guest Guest

    Previously, yes; I did have the XP driver on the wireless systems. Funny
    thing is that the XP driver also says 2000 on it, and the first time I shared
    the printer with 1 other system, I did not use the XP/2000 driver and the
    printer sharing worked (Non wireless) between printer attached to 2000 system
    and another XP system.

    Now that I'm thinking about it - I don't think I've been able to print from
    the printer since I've gone wireless.......... I think I'll try getting the
    XP/2000 driver and install this from "add/remove" hardware. Thanks for your
    help, hope this works............ if not, I suppose it could be the
    Guest, Jun 15, 2005
  6. Guest

    Guest Guest

    OK - IT WORKED! But this is NOT how it is advertised to work, although I
    guess I shouldn't complain. Computers and networks can be strange

    This is how I got it to work:
    Kept the 2000 system intact w/its drivers

    Deleted EVERYTHING hp/hewlett packard on the XP wireless systems, rebooted
    and downloaded the XP driver for the printer, then extracted the files, but
    did NOT run the setup. Includes uninstalling printer software

    Then, I used Add/Remove Hardware to point to the network printer location
    and name when it asked which port(s) on a drop down menu, followed the
    prompts for the location of the driver, which was in the extracted files.
    Oddly enough, this by itself did not show the new printer on my

    THEN, since the new printer was not added, I immediately tried to add a new
    network printer, did the search and selected it, and it actually asked a few
    more questions this time, like did I want to share it, and even give it a
    share name, then it asked if I wanted to print a test page (Previously, it
    did not, and I had to access the printer properties to try and print the test

    Well, it worked, so I'm off to do this with the laptop....... Thanks for
    the help!!
    Guest, Jun 15, 2005
  7. Guest

    DanR Guest

    Glad to hear you're up and running. Sometimes it's just persistence that fixes
    the problem. I had similar problems about 2 years ago with XP and ME machines.
    DanR, Jun 15, 2005
  8. Guest

    Guest Guest

    Well................. the laptop is proving to be more of a pain than I
    thought.......... it is NOT giving me the option under Add/Remove hardware
    to select the network location for the printer; however, I did try the
    standard TCP/IP port and named the port where the printer was attached
    (USB001) and it "SEEMED" to be working, but had similar results.....no

    I think it might have something to do with the ability of the laptop to
    connect to resources on the workgroup wireless network; I did not have this
    problem with the desktop XP on the wireless.......

    Sometimes I can connect through using "View Workgroup Computers", but when
    you search your windows network and you have the option to select from the 3
    different places (Choosing the MS Windows Networks) I am unable to connect.
    It's really weird, my signal strength is "excellent" and I've even tried to
    "repair" the connection without success. I am trying a shutdown so we'll see
    how that works.
    Guest, Jun 15, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.