Wireless connectivity issues post SP2

Discussion in 'Wireless Networking' started by Al Blake, Oct 16, 2004.

  1. Al Blake

    Al Blake Guest

    We have just migrated 600+ machines to SP2. Needless to say before we
    started on this we carried out *extensive* testing of our systems...and
    everything passed. A week later we are finding that we are having huge
    problems connecting a specific machine/WLAN card combination to our WLAN.
    These machines were used on the WLAN for over a year in SP1 without problems
    and given the number of other posts it seems SP2 is the issue:

    Symptoms: Machines associate but never get and IP lease. The access point is
    quite happy and reports no errors. The machines sit there saying 'Acquiring
    network address' until eventually they time out.
    Configuration: Toshiba Satellite 1800 + Toshiba mini PIC Wireless LAN card.
    AP: Cisco 1200/350
    Setup: Static Open WEP OR PEAP-TLS

    We get the same results for both access points and both types of
    authentication unless we turn off encryption - then everything is fine. But
    of course no encryption on the WLAN is a non starter.

    Other machine combinations:
    IBM T40 + IBM 802.11b
    IBM T40 + IBM 802.11a/b/g
    Tosh Sat 1800 + Atheros 802.11a/b/g
    all work fine.

    So it seems to be a specific combination of SP2 + THIS card + encryption.
    Needless to say we have all the latest drivers on everything. We have spent
    2 days on this and got nowhere. Most frustrating is that when we tested this
    combination of hardware prior to the SP2 rollout it worked fine. In fact we
    have 2 of the 62 machines in the combinations that *CAN* connect to the WLAN
    after Sp2....which is even more frustrating......and if we re-image a
    machine that cant connect down to SP1...it immediately connects to the WLAN.

    So it seems that SP2 plus specific WLAN hardware combinations is
    unpredicatable. Can anyone give any times as to where we can even start to
    trouble shoot this issue.
    Al Blake, Canberra, Australia
    Al Blake, Oct 16, 2004
    1. Advertisements

  2. Al Blake

    Jim C Guest

    No solution here - but you are not alone. This seems to be a common
    occurrence - works in SP1, but can't get the DHCP-assigned address in SP2.
    I know on my computer that it is not the settings.
    Jim C, Oct 17, 2004
    1. Advertisements

  3. Al Blake

    Guest Guest


    Your excitement is understandable, but could you calm down and
    give us some essential details.

    The Toshiba support site lists several "Satellite 1800" models,
    which exactly is yours? Which exactly is it's wi-fi card model?
    (Toshiba does not make the cards, so this might be OEM version
    of somebody else's product).
    Knowing this can help to find the real manufacturer of the card
    and it's driver, and get the issue resolved faster.

    Another question is, do you use the Windows Wireless configuration service
    to configure the card, or some "utility" that came with the driver.
    If the latter, have you tried to remove it and use the Wireless configuration
    service of SP2 instead?

    Guest, Oct 17, 2004
  4. Al Blake

    Ron Lehner Guest

    I have to agree that post SP2 the wireless connectivity of XP has
    become useless unless you want an unsecure network. I had some
    wireless clients working correctly for about a week then the following
    occurred. Only thing added to OS was the updates. I have not went as
    far to see if any of the updates have caused the problems. But to work
    for a week then quit, leads me to suspect that is the problem. Here
    are my problems below.

    1 - IAS access was granted and IP address was issued with XP SP2 still
    indicating it was acquiring network address. WAN and LAN was
    accessible, but connection dropped out after a couple minutes.

    2 - IAS access was granted and DHCP server broadcast ip address with
    XP SP2 never ack-ing...timed out with 169.xxx.xxx.xxx address.
    ipconfig release and renew with same results.

    3 - Setting alternate config in network settings never worked

    4 - IAS access granted, DHCP address accepted, XP SP2 reconnects every
    4 seconds.

    5 - with encryption off XP SP2 is happy and works fine.

    6 - Modify registry not to auto config - set alternate config doesn't
    work. Result - constantly acquiring network address.

    7 - Any encryption, user password auth, certificates, in other words
    anything to try and protect your network, XP SP2 fails.

    With this pattern I can not get a grasp on what is causing the
    problem. Again, I'll look at the updates from the initial install of

    Using linksys, buffalo, netgear, and orinco cards all have the same

    I have not found any solution other than to go back to SP1. I am
    fortunate I never had put this into a production environment.

    By the amount of posts on this subject, it looks like there are plenty
    of people with this problem. I would be interested if anyone finds a
    solution. I have been trying to correct this problem for over a

    End of venting,

    Ron Lehner, Oct 18, 2004
  5. Al Blake

    Al Blake Guest

    Possible breakthough today:
    Turned *on* SSID broadcast on the access points and suddenly all the
    machines that were giving problems can connect - with full authentication
    and encryption. Strangely enough this works even when the 'broadcast' SSID
    is *not* the SSID we end up connecting to...its early days yet but thetre
    looks to be som wierd combination of card + SP2 + encryption here that
    causes everything to fall in a hole when broadcast is not on.
    Anyway - we use better security that just hiding the SSID ;) so Im gonna
    leave it on for a week or two and see if its stable.
    Al Blake, Oct 18, 2004
  6. Hi Al,

    Here is a repost of a message Carl DaVault sent out to
    microsoft.public.windows.networking.wireless concerning using hidden SSIDs.

    Chris Gual [MSFT]
    This posting is provided "AS IS" with no warranties, and confers no rights.

    ---------- forwarded message ----------
    First, make sure your AP and your wireless NIC's have the latest firmware
    and drivers.
    Next, unhide the SSID and make sure everything connects properly. Does
    re-hiding the SSID make the problem re-appear?
    If so, it might still be a driver issue.

    A couple of things to note about "hidden" SSID's.

    - If you are using them, then they are likely not hidden if a hacker wants
    to see them.
    - Windows tries hidden SSID's "last", so connecting to them may be slower
    than to visible SSID's
    - Some drivers have had problems connecting to hidden SSID's, so the
    experience varies by NIC/driver
    (what NIC/driver are you using?)

    The way Windows handles hidden SSID's is this:

    * It walks through your list of configured networks and tries to connect
    to any ones that it can see.
    * Then, if it didn't get connected or can't see any visible networks, it
    tries each configured network anyway (in case it is hidden).
    * It tries to connect by telling the NIC to use specific settings (SSID,
    WEP, etc.) for the network.
    (at this point, it is up to the NIC to do the actual
    association, which is why I think it's a driver issue)
    * Windows repeats this process until you are connected - you'll see
    balloons letting you know when new networks are visible.

    So if everything works with a visible, but not a hidden SSID, it might not
    be a Windows problem. On the other hand, if you have a lot of networks
    configured, windows is trying them one by one so it may just take a while to
    connect - you can try moving the hidden network to the top of your list of
    SSID's so it is tried first.

    Hiding an SSID doesn't buy any security from hackers and you can use MAC
    filtering to block regular people from connecting to your network even if it
    is visible. I would recommend making your network visible since it will
    improve your connection experience and doesn't hurt security. Even hidden
    AP's and their clients are still blasting packets everywhere - it's just
    that the beacon packets from the AP don't have an SSID in them. The AP will
    still answer to the probe request for the SSID - the probes and responses
    will also be visible to hackers.

    - Carl
    Standard Disclaimers -
    This posting is provided "AS IS" with no warranties,
    and confers no rights. Please do not send e-mail directly
    to this alias. This alias is for newsgroup purposes only.
    Chris Gual [MSFT], Oct 19, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.