Windows XP 64 bit SCSI Issues with adaptec 29160

Discussion in 'Windows 64bit' started by Guest, Jul 21, 2007.

  1. Guest

    Guest Guest

    I'm having a strange problem.
    XP 64 Bit is not seeing the drives attached to my adaptec 29160N card
    In disk manage ment it reports the disks as disk 0 and disk 1, and "flashes"
    the information in the disk - its very quick but I can see the disk
    information (looks sort of correct) for the brief portion of a second it is
    show.

    Windows XP 32 bit is fine with these disks.
    When I use an adaptec 2940U2W, these disks are seen correctly.
    I've also had this problem with an adaptec 19160.

    I've only seen one error message in the event log. Source: VDS Basic
    Provider. Description: Unexpected failure. Error code: [email protected]

    I tried a clean install of XP 64 bit and it got stuck very early on in setup
    with the message: "Examining 1Mb Disk 0 at Id 1 on Bus 0 on adpu16-m..."

    I've checked and flashed the bios on the 29160 to the latest (3.10).

    My motherboard is an Asus 8NSLI with an AMD 4200 X2 with 4 Gb of ram.

    Any suggestions or help would be appreciated
     
    Guest, Jul 21, 2007
    #1
    1. Advertisements

  2. Guest

    Jane C Guest

    Jane C, Jul 21, 2007
    #2
    1. Advertisements

  3. Guest

    Theo Guest

    It's strange your Adaptec cards don't work in Win x64. I've
    been using a 29160N since the pre-release versions. The
    u160 driver is listed in the "drvindex.inf" and there is a
    "adpu160m.sys" drivers included in the OS CD.

    Have you tried a different PCI slot?
     
    Theo, Jul 21, 2007
    #3
  4. Guest

    Guest Guest

    There is a workaround.

    My system has 4 gb of ram installed - which is precisely why I am using 64
    bit XP.

    I removed 2 Gb of ram and lo and behold the drives are working correctly.

    There is a bit of memory map jiggery pokery going on, that I am guessing the
    hardware or driver does not like.
    this blog has some information on this:
    http://www.codinghorror.com/blog/archives/000811.html

    How do I log a bug?
    Note : the 29160 is natively supported by XP Pro 64 bit.
     
    Guest, Jul 21, 2007
    #4
  5. That's a pretty old card, and I suspect the driver doesn't know how to
    handle exactly 4 GB. Also, if you have your BIOS set to re-map memory
    addresses for PCI cards (to gain access to the full 4GB you have installed,
    rather than ~3GB), that could also be affecting it.

    The bug is against either the mobo BIOS (who are doing the remapping), or
    Adaptec for the driver not handling it correctly. I'd start by updating to
    the latest BIOS and then, assuming that doesn't get it, try querying
    Adaptec.

    The real problem is that a lot of hardware made assumptions about memory
    address spaces, and in x64 those assumptions are no longer valid.
     
    Charlie Russel - MVP, Jul 21, 2007
    #5
  6. Guest

    Guest Guest

    Thanks Charlie - Im looking for an updated bios - there are a number , and I
    will try that.

    However the drivers are the native ones, actually supplied as part of
    windows XP 64bit.
    Its really strange that the older card - the adaptec 2940U2W works fine.

    There are no newer drivers on the adaptec site - the adaptec site basically
    says that the drivers supplied in XP 64 bit are all that is available.

    I've disabled the bios settings for remapping and now the system sees 3Gb of
    ram and now XP sees the disks properly.

    So its looks like the drivers in windows XP 64 bit are buggy and need a fix,
    as the 2940U2W ones work perfectly.
     
    Guest, Jul 21, 2007
    #6
  7. How much memory does your system report as available in Windows?
    If it is not the full 4GB you have, you should try enabling and disabling
    hardware and software memory hole remapping in your BIOS.

    I have seen reports that only software remapping works correctly for the A8N
    SLI, but these were 18 months or so ago and later or different BIOSes may
    change that.
     
    Dominic Payer, Jul 21, 2007
    #7
  8. Guest

    Guest Guest

    It was reporting 4gb - I had software and hardware remapping switched on.

    I switched off software and left on hardware and the OS still had 4gb and
    the scsi drives were still not working correctly

    Switching off the hardware remapping, and the OS reported 3gb and the drives
    now work.

    I'll try the SW remapping only , then try an updated bios.

    However, to reiterate - 2940 U2W card was fine, this implies a driver issue.


    (btw - I've been using SATA for the OS drive but I was going to migrate to
    SCSI )
     
    Guest, Jul 21, 2007
    #8
  9. Guest

    Guest Guest

    Tried with software remapping on : 4gb reported by operating system, drives
    not behaving.

    So , later I will try a new bios.
     
    Guest, Jul 21, 2007
    #9
  10. The drivers are supplied by Adaptec - Microsoft doesn't write drivers for
    3rd party hardware. And no, I'd disagree - I'd say the issue is the BIOS
    remapping. Which leads me to suspect that there's an issue with how the BIOS
    is handling that.

    You might also want to double-check the Adaptec site to see if you have the
    latest firmware for that card. Adaptec does periodically update their
    firmware. Older cards, that meant swapping out an EPROM, but any reasonably
    modern card you should be able to flash the new firmware onto it.
     
    Charlie Russel - MVP, Jul 21, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.