Windows x64 Edition won't start after Avast Update

Discussion in 'Windows 64bit' started by Guest, Oct 29, 2007.

  1. Guest

    Guest Guest

    Hi,
    I have a computer that I built that won't boot after the latest Avast
    update. I updated Avast late Thurs (10/25/07) night and when it said that I
    needed to restart the computer, I pushed OK for it to restart and went to
    bed. I got up Friday morning and it was on a solid blue (not BSOD) screen.
    Now, it won't boot at all. I get thru the POST, and when it gets to launching
    the Windows x64 logo, it freezes on a black screen. No text.

    I also:
    - cannot get into any of the safe mode options, with one exception - when I
    launch into "Safe Mode" - I can see the lines "multidisk, rdisk, etc etc"
    coming across the screen and it stops on a line that ends in
    \windows\inf\biosinfo.inf - so it appears that this is where it freezes.
    - cannot boot to my original XP CDrom.
    - cannot get into the recovery console.

    Everything freezes to a black screen before I can get to any options that
    may allow me to work on this drive.

    I have slaved the drive to another x64 computer. I have full access to all
    of the data and files. Nothing is lost.

    So I'm thinking that when Avast did it's update on Thursday night, it
    corrupted one of the Windows boot files.
    Does anyone have any ideas?
    Do you need more information?
    Thanks in advance for any help you can offer.
    --Bill
     
    Guest, Oct 29, 2007
    #1
    1. Advertisements

  2. Hi Bill,

    I have been running Avast myself for more than two years now, I think. My
    machines are updating automatically, sometimes several times a day, never
    had a problem. Something can easily have been corrupted in that update, but
    I am positive it is not Avast that did it. Anything you download may be
    corrupted along the 'line' at any time and these updates are not trivial, in
    a running system.

    On the other hand, it doesn't sound to me as something that HAS to be
    software related - how old is the system you've built? How long since Avast
    was installed? Are you 'Dual-Booting'? How many HD's? IDE, SCSI, RAID or
    SATA?

    If nobody else here objects, I would probably first try and remove the CMOS
    battery for a few minutes (maybe ten?) - this will reset the BIOS and
    [should] be harmless.


    Tony. . .
     
    Tony Sperling, Oct 29, 2007
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    Hi Tony,
    Thanks for taking the time to reply.
    To answer your questions:
    1- The system was built in June 2006.
    2- It is not a dual boot box. Only boots to x64 Windows.
    3- Avast was installed from the beginning.
    4- One HD. Seagate, 320GB, SATAII - no RAID
    5- I have flashed the BIOS to the latest one. No difference. Flashing resets
    the BIOS just like removing the battery (I think). At any rate, it didn't
    help.

    Motherboard is ASUS A8N32-SLI Deluxe, BIOS 1303
    Processor is AMD Athlon 64 x2 at 4200+ Dual Core (socket 939)
    RAM is 2GB Corsair XMS RAM
    HD is Seagate ST3320620AS
    Video card is Matrox Quad card, QID-E128-LPAF
    Power supply is Antec 550w TruePower 2.0

    This system has been rock solid from the time it was built until the Avast
    update Thursday night.
    Thanks again for your responise.
    --Bill


     
    Guest, Oct 29, 2007
    #3
  4. Re 5: Flashing does not reset the CMOS data holding the BIOS settings unless
    you set the flashing program parameters to do so. This is never done by
    default.

    Sometimes the updated BIOS uses a different structure for the CMOS data and
    in such cases the release notes warn to clear the CMOS and set optimal
    defaults before any customisation you may prefer. Failure to do this when
    needed can result in the BIOS doing strange things.




     
    Dominic Payer, Oct 29, 2007
    #4
  5. Well, this is close to what I am having. In addition to the BIOS thing, I
    want to draw attention to the SATA cables as one possible weak point. They
    are rather stiff and routing them around the case could result in them
    having tension that wants to pull them out of their sockets. They aren't
    snapping on very tightly in their sockets anyway and I had to apply a
    half-turn sideway twist before looping them around between the HD and the
    MB. This is hard to explain in graphical language, but I think you'll
    probably see what I'm driving at.

    While you are inside, you might as well reseat everything else too, just
    unfasten and give everything a gentle 'wiggle' and fasten it again. Then
    let's see how it behaves. You should at least be able to boot from a CD/DVD.
    Hopefully!

    Oh - and flashing the BIOS, was that after the Avast upgrade?


    Tony. . .



     
    Tony Sperling, Oct 29, 2007
    #5
  6. Guest

    Guest Guest

    Tony,
    Yes, flashing the BIOS was after the Avast upgrade and part of my attempt to
    repair. Also, I have another identical machine (I've actually built 3 of
    these the exact same way) and I have removed the hard drive out of the
    problem machine and put it in the other one, which boots fine with its own
    normal hard drive. When I install the problem HD into it, it acts the exact
    same way - no boot. So I am pretty sure that something has happened to the
    hard drive itself. It's not a problem on the motherboard or with SATA cables
    or CMOS batteries or resets. If it was, then when I moved the HD to the other
    machine, the behaviour would be different. It isn't. It's identical. No boot,
    and when I do actually get into Safe Mode, it stops at the same place
    (biosinfo.inf).

    And speaking on that, I thought that the file biosinfo.inf might be a
    problem. So I copied it from the twin machine back to the damaged one. Still
    no difference. Exact same result - no boot, etc.

    I really think something is wrong in the boot files that was corrupted when
    the Avast update was done. I do not believe it is any sort of hardware issue,
    since when I move the HD to the twin machine (which runs fine) I get the same
    results.
    Thanks,
    --Bill

     
    Guest, Oct 29, 2007
    #6
  7. This sounds like a disk hardware failure that coincided with the Avast
    update.

    Download and run the disk manufacturer's test utility. That will tell you
    what is wrong with the disk.




     
    Dominic Payer, Oct 29, 2007
    #7
  8. Guest

    John Barnes Guest

    The last listed item is the last one that successfully loaded, not the
    problem one. You could try installing a good system into your problem
    machine. That you say you cannot get to recovery console or boot the XP
    install cd has nothing to do with anything past the BIOS. The install cd
    goes past the license agreement (and recovery console) with no HD, as when
    you haven't installed necessary SATA drivers. You should therefore try to do
    your repairs from one of the other machines where you can access the boot
    files, fixmbr and fixboot.


     
    John Barnes, Oct 29, 2007
    #8
  9. Guest

    Guest Guest

    Hi Dominic,
    OK - I hear you. But....I can run the "damaged" disk on the good computer
    and I can see all of the data on the disk. It just won't boot the operating
    system on its own. But I will download and run the Seagate diagnostics when I
    get home tonight around 10pm (it's 8:37am EST here now).
    Thanks,
    Bill

     
    Guest, Oct 29, 2007
    #9
  10. Guest

    Guest Guest

    Hi John,
    Thanks for replying.
    I do have complete access to the drive when it is running on my other
    computer, which is also a x64 box. My limitation is that I'm trying to figure
    out (or be told) what utilitiies I can use within the x64 environment, since
    that is 100% what I am dealing with. I didn't think that all of the normal XP
    (32bit) tools would work in the x64 realm.

    I'm going to run the HD diagnostics from Seagate, but do you have any
    specific diagnostics that come to mind with respect to the x64 O/S? I ran
    chkdsk /f last night and it said it fixed some things - but still no boot
    when I tried the drive by itself.

    I realize I can just format the drive, and reload x64 and go from there, but
    that's not really the point. I'm trying to understand what went wrong and
    repair it.
    Thanks for everyone's help and ideas!
    -Bill

     
    Guest, Oct 29, 2007
    #10
  11. Yes, Hardware failure looks like one of the more natural possibilities. I
    would, however, try and make a few more exclusions. In the 'other' machine -
    configure the failing HD as non-bootable and make a normal re-boot. Then go
    have a look to see if you can make a backup of the essentials in it's new
    environment. Go on, and from a command shell do a FIXMBR and a FIXBOOT [ON
    THAT DISK] (not your system drive!) and check if that solved anything. If
    not try and re-partition the thing.


    Tony. . .


     
    Tony Sperling, Oct 29, 2007
    #11
  12. Guest

    John Barnes Guest

    By having complete access, what do you mean? I thought you said you
    couldn't boot it when you tried it. Are you saying you can install it in
    the other computer, access it from the system originally installed on that
    computer, but just can't boot to it? How did you try. As I said before, if
    you can't even boot to the XP cd on the other MOBO, you have a problem with
    the MOBO or bios, that may have caused problems with your hd.
    When the drive is installed on the other computer, have you tried
    disconnecting the other drives and doing a fixmbr and fixboot from the XP
    cd?
    Then seeing if it will boot.

     
    John Barnes, Oct 29, 2007
    #12
  13. Guest

    Guest Guest

    Tony:
    The Avast update mentioned by the OP was a Program (i.e.: kernel) update of
    the Antivirus, rather than the regular daily definition update.
    Those program updates are not automatic and you can force them by
    right-clicking on the Avast icon (systray), then Update, then Program Upate.
    That will force you a reboot.
    Current kernel version is 4.7.1074 (right-click, About Avast, etc.)
    Carlos

     
    Guest, Oct 29, 2007
    #13
  14. Well, yes. I do know that the regular updates are database stuff and
    definitions, but the program itself updates this way too once in a while -
    and requires re-booting. I have tried doing the forced update, but I don't
    see anything that isn't in the auto-update facility. I simply think the
    menu-item is a service for users on dial-up?

    Anyway - the problem is the same and I still think we should adapt to the
    notion that downloads can be harmfull when they decide to be.


    Tony. . .



     
    Tony Sperling, Oct 29, 2007
    #14
  15. Guest

    Guest Guest

    Hi Dominic,
    Your suggestion is a good idea, but I can't find an edition of Seagate's
    SeaTools that runs on x64. Do you know of one?
    Thanks,
    Bill

     
    Guest, Oct 30, 2007
    #15
  16. SeaTools for DOS is the one you want.
    http://www.seagate.com/www/en-us/support/downloads/seatools/



     
    Dominic Payer, Oct 31, 2007
    #16
  17. Guest

    Guest Guest

    AN UPDATE - as of 31Oct07 at 9:30pm EST:
    I have now run these tests / procedures on the problem drive. Nothing has
    helped. Data is still there, but cannot get the drive to boot x64:

    chkdsk /f and /r
    fixboot
    fixmbr
    SeaTools (both short and long tests passed)
    BIOS on the computer is updated

    Does anyone have any more suggestions?
    Thanks much,
    Bill




     
    Guest, Nov 1, 2007
    #17
  18. Test the memory on the system with e.g. memtest http://www.memtest.org/

    As the disk tests as good and, from your original post, it seems you cannot
    boot to the x64 CD to do a repair install this is the last hope.



     
    Dominic Payer, Nov 1, 2007
    #18
  19. Bill,

    are you still on the second machine, and this is where you've been running
    all tests and procedures?

    Can you put a new HD on the original failure machine and install a new OS
    there - just for the time being? (You'll most liky need it anyway!)

    You must home in on something that will work, in order to (at best) isolate
    the real problem. Since the problem HD can be accessed from outside your
    data is not the prime concern - it is important that you don't restore it
    all to something that still carries the error. . .whatever that might be.

    I've tried googling for a solution but everything is just stabs in darkness,
    as far as I can tell.

    Did you ever try and remove that battery?


    Tony. . .


     
    Tony Sperling, Nov 1, 2007
    #19
  20. Guest

    John Barnes Guest

    One last try would be to swap a different and known good cd player into the
    problem machine. Unplug all your hd's. If you still don't get the install
    cd to boot, you have a problem with the motherboard. You did say you had
    flashed the BIOS, so the only remaining variable is the MOBO itself

     
    John Barnes, Nov 1, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.