Windows Update won't work, nor System Restore in XP2

Discussion in 'NZ Computing' started by julie j, Feb 17, 2007.

  1. julie j

    julie j Guest

    I noticed that Windows Update hadn't updated since December 1 and when
    I tried to update, it wouldn't. There was no error message, all I keep
    getting is something saying it needs to register and download
    something to enable updates, but it just keeps doing that over and
    again.

    Realising that the Dec 1 update had caused issues with Active X (I get
    messages saying it is disabled when I try to click the yellow
    favourites star on a post in Google Groups, but it is not disabled) I
    decided to System Restore back to before Dec 1.

    But System Restore will not work on any date, I just keep getting
    messages saying it did not restore.

    Can anybody help? Please?
     
    julie j, Feb 17, 2007
    #1
    1. Advertisements

  2. julie j

    E. Scrooge Guest

    Do you know how to check Internet Security settings?
    That's where Active X script settings are adjusted.
    Most likely why you're stuck in a loop.

    E. Scrooge
     
    E. Scrooge, Feb 17, 2007
    #2
    1. Advertisements

  3. julie j

    Enkidu Guest

    Clear out your IE cache - Tools, Internet Options and delete all content
    and cookies. It may work...

    Cheers,

    Cliff
     
    Enkidu, Feb 17, 2007
    #3
  4. julie j

    julie j Guest

    I'm certainly in some kind of loop. Whenever I try to load the
    updates, I get this message:


    And it goes through some registration process, taking me back to the
    "express download" and "custom download" page, which always takes me
    back for the "files required etc..." message.

    I reset all the Active X controls and it had no effect. I set security
    to default and it had no effect.

    This problem began with the December 1 Automatic Update, it has not
    updated since, and now System Restore will not let me restore to
    before that date.
     
    julie j, Feb 17, 2007
    #4
  5. julie j

    impossible Guest

    You have some registry corruption. If you Google the rror message you
    receive, you'll find that others have had this same problem. The most
    common solution you can try is this one.

    Go Start | Run... and then enter each of the following commands in
    succession:

    regsvr32 wuapi.dll
    regsvr32 wups.dll
    regsvr32 wuaueng.dll
    regsvr32 wucltui.dll
    regsvr32 atl.dll
    regsvr32 msxml3.dll

    These commands re-register the Windows Update files you need. After
    running each command, you should get a messgae saying the registration
    process was successful. Assuming this all works, then try running
    Windows Update again.
     
    impossible, Feb 17, 2007
    #5
  6. julie j

    Enkidu Guest

    ....and clear out your IE temporary files via Tools->Internet Options

    Cheers,

    Cliff
     
    Enkidu, Feb 17, 2007
    #6
  7. julie j

    julie j Guest

    Bless you, kind person.

    I entered the commands you gave, and now mountains of updates are
    downloading.

    Thank you very very much.
     
    julie j, Feb 17, 2007
    #7
  8. julie j

    julie j Guest

    Yes, I did that too, thanks.
     
    julie j, Feb 17, 2007
    #8
  9. That sorts out many of the M$IE problems. M$IE's cache management is poor.
     
    Dianthus Mimulus, Feb 18, 2007
    #9
  10. julie j

    Earl Grey Guest

    Wot no GUI ???
    If this was linux Biggles and Fred Dagg would be jumping all over it.
    ;-)
     
    Earl Grey, Feb 18, 2007
    #10
  11. julie j

    Biggles Guest

    I think you should take your own advice and grow up .. or at least teach
    cupa how to use linux ...






    Biggles.
     
    Biggles, Feb 18, 2007
    #11
  12. julie j

    julie j Guest

    Thank you again.

    It all worked, and has removed a variety of bugs that had come into
    being with that blasted December 1 Windows Update.

    It's also given me IE 7!!!! A new toy to play with.
     
    julie j, Feb 18, 2007
    #12
  13. julie j

    Max Burke Guest

    Earl Grey scribbled:
    Yes Earl, it IS using the GUI.
    They dont have to, because these commands are entered using the GUI when
    clicking start/run and typing the command.
    Of course they can also be entered from the command line, but they dont have
    to be....
     
    Max Burke, Feb 18, 2007
    #13
  14. julie j

    Earl Grey Guest

    Can't you just use the mouse ?
     
    Earl Grey, Feb 18, 2007
    #14
  15. Lets face it - M$ Windows does not have any means of entering text based
    commands using any type of a console that does not of itself also require
    the use of the GUI.
     
    Dianthus Mimulus, Feb 18, 2007
    #15
  16. julie j

    jasen Guest

    you can use just the mouse.

    start-acce4ssories-system_tools-command_line (or wherever it hides)
    (I usually do start-run "cmd")

    using the mouse copy the commands above and paste them to the command
    window

    :^)

    Bye.
    Jasen
     
    jasen, Feb 19, 2007
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.