Win98 - DCHP IP but no ping DHCP server

Discussion in 'Wireless Networking' started by Simon Woods, Mar 27, 2005.

  1. Simon Woods

    Simon Woods Guest

    Hi

    I've been having problems getting an XP/win98 dual boot machine joining
    my network wirelessly.

    See "Wireless connected - can't ping" on ms.public.win98.networking

    I've thought it was perhaps a problem with IRQ conflict so I've removed
    all expansion cards including the Wireless network card and now decided
    to try and configure the onboard lan. I've a spare router which I'm now
    plugging in directly to the lan connection of the machine.

    The router is acting as DHCP server.

    I'm finding now that the router is assigning an IP address to my machine
    but my machine can't ping the DHCP server. It can ping itself both by
    "ping localhost" and "ping DHCP-assigned address"

    There's nothing in the arp table (... don't know what that tells me, but
    I seem to think that when it has been working, there has been an entry)

    I've tried re-installing tcp/ip. (I've actually re-installed Win98 about
    8 times so far!!)

    Any suggestions

    Thanks

    Simon
     
    Simon Woods, Mar 27, 2005
    #1
    1. Advertisements

  2. Simon Woods

    CJT Guest

    so obviously those two are talking (which means the rudiments of
    networking are installed and functional)

    of course, if all that's connected to the wired router is this one
    some routers (optionally) won't respond to pings for security reasons,
    so that in itself isn't necessarily a problem -- if you're getting an
    address from it, you must have a connection

    but many routers have setup screens accessible via a browser; you might
    explore those

    It can ping itself both by
    no problem there
    it sounds like your wireless connection isn't being established

    but you probably knew that

    have you installed the drivers for the wireless card, etc.?

    are you sure the wireless stuff works?

    when you go into My Computer -> Control Panel -> Network, is your
    wireless card there, and bound to TCP/IP?

    are there any status lights on the wireless equipment, and what do
    they tell you?
    then it's time to try something different

    I don't think the problem is with basic TCP/IP and Win98 networking --
    that the machine will talk to the router demonstrates those are working
    sorry, I don't do wireless

    my comments have addressed the networking bits that have little/nothing
    to do with wireless, but about which you seemed to be concerned
     
    CJT, Mar 27, 2005
    #2
    1. Advertisements

  3. Simon Woods

    Simon Woods Guest

    Thanks CJT - in line
    I've tried the admin screen from IE but it can't find it - which seems
    to suggest one-way traffic --- dhcp-server => PC.
    Yes ... yes ... yes ... default gateway set DNS stuff set ... shimmering
    lights green on both the router and NIC when booting up then solid green.

    This used to work. I've had it working both with Win98 and WinXP
    wirelessly previously on this same machine --- but now it just 'won't take'!
    I was concerned because of multiple devices sharing the same IRQ, so
    I've pulled things back to a bare minimum ... taken out all expansion
    cards, disabled in BIOS all devices which are sharing the IRQ which the
    card will use --- so I've got a pretty basic setup. I've tried disabling
    IRQ steering but no good

    I've also tried wireless and wired connections. The wired connection
    gives a DHCP-originated ip address which I don't get wirelessly, but
    still can't ping the router nor open it's admin screen.

    I'm beginning to think it must be a hardware problem, but the thing is
    that I've used the on-board lan connection for wired and an expansion
    card for wireless onto 2 different routers and the results are the same
    .... it don't work (other than for wired I get a DHCP-originated ip
    address!) which makes me think it's something basic I'm missing.

    I've other win98 machines on my wireless network and they work fine!

    .... and it used to work !!

    Thanks again for your help

    Simon
     
    Simon Woods, Mar 27, 2005
    #3
  4. Simon Woods

    CJT Guest

    Although I don't profess to know anything about wireless, the one
    bit that is present with most wireless devices that isn't present
    with most wired connections is an extra layer of security -- e.g.
    password protection -- since otherwise it would be so easy to tap
    in uninvited. Could that be the source of the problem?
     
    CJT, Mar 27, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.