Win7 Homegroup Security problem

Discussion in 'Windows 64bit' started by dmh, Jun 13, 2009.

  1. dmh

    dmh Guest

    Hi,
    A question and a heads up for Win 7 users.

    Today I found I was denied access to 3 partitions I had shared. The
    security tab showed no entries at all. I was fortunate that I had not
    shared my system drive, only data and media partitions.

    To fix, I had to add back Users - Authenticated User - System -
    Administrators and ignore any error messages. I then had to take
    ownership of the partition (even though it said the Administrator had
    ownership when I selected edit I was given the option of giving
    ownership to the Administrator? or my user account, I chose
    Administrator).
    I then selected the above accounts and had the permissions propagate
    to all file and folders.
    The recycled bin for these partitions was corrupted also but after
    doing the above this issue was corrected.

    This all appeared to happed after I went to Homegroup "Joined"
    selected to "Leave the Homegroup". I also changed from a Home Network
    to a Work Network. (just trying different things).

    I'm sure this act resutled in all the security settings for my shared
    files (I did not have any problem with partitions that were not
    shared) being removed and hence requiring the above to fix.

    As stated I did not have "C" shared. I'd hate to think what mess this
    would have created.

    I will continue to test, however I thought it wise to warn fellow x64
    users to be carefull with the the Homegroup settings and to also
    enquire if anyone has had a similar experience.

    Thanks
    David
     
    dmh, Jun 13, 2009
    #1
    1. Advertisements

  2. dmh

    Carol Steele Guest

    I can confirm what you are saying as something similar happened to me when I
    was messing about with (sorry ..... testing) various Homegroup settings.
    various partitions and other disks could not be read from and showed no files
    present in Explorer. I tried a system restore from a previous restore point
    and I couldn't restore a system image as the partition the system image was
    on was not recognised.

    I even re-installed Windows 7 - but still the partitions and drives were not
    recognised - I was panicking now and then found that disk ownership had been
    changed (to nobody). Restoring disk ownership to Administrator finally
    allowed the partitions and drives affected to be recognised once more and
    from there I was able to see the system image file which I had made a couple
    of days previously. Once restored everything worked fine again.

    Last time I mess around with the Homegroup :)
     
    Carol Steele, Jun 16, 2009
    #2
    1. Advertisements

  3. dmh

    Barb Bowman Guest

    Can you duplicate this with a shared folder (less destructive) vs an
    entire partition? Can you confirm what build you are running? And is
    this the only build of W7 you have installed on this machine?

    Barb Bowman
    MS-MVP
    http://www.digitalmediaphile.com
    http://digitalmediaphile.wordpress.com
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
     
    Barb Bowman, Jun 16, 2009
    #3
  4. dmh

    Clayton Guest

    I think this problem will be fixed by RTM build, I am keeping well away from
    Homegroup, it has caused me nothing but grief
     
    Clayton, Jun 19, 2009
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.