wifi W7 & iPhone

Discussion in 'NZ Computing' started by nof, Dec 22, 2009.

  1. nof

    nof Guest

    Today I had the server's help on the phone and an hour later the
    laptop was cleared and wifi was working. Now I'll have to get really
    serious about Apple on the one hand and W7 on the other. iPhone just
    won't reach my network although it knows that the network is there.
    Just won't let me JOIN.

    W7 must have a fault in the Networking area. I am out of ideas for
    this. Channels? Encryption? Cussedness? I can't system restore to
    Vista can I? Oct 22 was the date I bought it. I would like to see its
    networking setup.

    nof, Dec 22, 2009
    1. Advertisements

  2. nof

    EMB Guest

    Windows will have *nothing* to do with your iphone failing to connect to
    the network.
    EMB, Dec 22, 2009
    1. Advertisements

  3. nof

    nof Guest

    Without doubt W7 has nothing to do with the problem. It comes down to
    the router. Given that it has a password, it is not letting me join.
    The modem is Thomson TG585v7 so I am looking for a button for change
    password. Thomson have a new partner and the page is different.

    Thanks everyone

    nof, Dec 24, 2009
  4. nof

    David Empson Guest

    Documentation for that router appears to be available here:


    Impressive level of detail, compared to most other brands I've dealt

    What encryption method are you using? If it is some form of WEP, you
    might need to enter a hex password instead of a human-readable one
    (because there is no consistent algorithm for human-readable WEP
    passwords). Not sure how you do that on an iPhone. Best solution in this
    case is to avoid WEP, as it is hopelessly insecure anyway.

    WPA or WPA2 should work without this sort of mucking around.

    From a quick glance at the router specs I can't see anything which
    stands out as an obvious issue you might run into (e.g. the router's
    WiFi is 802.11b/g, which is the same as the iPhone, so no possible
    802.11a or 802.11n confusion).

    Channels shouldn't be a problem as long as the iPhone was a NZ-sourced
    one. A US-sourced iPhone might not be able to use 802.11b/g channels 12
    and 13, since US regulations only allow channels 1-11. (Apple's Airport
    base stations follow these rules depending on the country or region in
    which they were supplied, so I'd expect similar for an iPhone.)

    A possible issue might be if you have used "strange" characters in the
    WiFi passphrase. The iPhone's keyboard appears to have all printable
    ASCII characters (except reverse quote), but you might run into code
    page compatibility problems with extended character sets (things like
    curly quotes, currency symbols other than $, etc.)
    David Empson, Dec 24, 2009
  5. nof

    nof Guest

    Thank you for the url. I've been there before and I think that is easier. The new site seems to me to be a public
    relations exercise. Today I have put the router back to default
    settings in the hope that the password would be expunged. I'll know
    more after restarting. I do have an apostrophe in my name which has
    been troublesome at times so I'll not use it for this exercise. My
    sources say to use network key WEP is favoured.

    This is exercising logic and head aches
    nof, Dec 25, 2009
  6. nof

    nof Guest

    Well folks here I am with the new episode for Boxing Day:

    Here is another episode: thomson site is

    It does have a facility to change the password - click toolbox then
    user management then change the password. Clicking on there it
    obviously asks for present password which is where the problem lies. I
    have put the modem through returning to factory defaults which may or
    may not be useful so I have gone through printed papers I have. I have
    found these settings:

    Network name
    Network key (WEP/WPA key)
    cdec481847824016b6d39409af822ed3blec97483681084c5edle001f0bdb745 -
    could this be the password?
    Key provided automatically (802.1x): 0
    Network authentication type: WPAPSK
    Data encryption Type:WPAPSK
    Data encryption Type: TKIP
    Connection Type: ESS
    Key Index:

    Do you think that the long string is the password?

    Thanks to all

    Hope you are having a great time. Be careful on the roads

    nof, Dec 25, 2009
  7. nof

    David Empson Guest

    Just to avoid further confusion with terminology: that is not the
    Thomson web site. It the address of your router. Accessing that address
    with your web browser shows you the built-in configuration web pages
    presented by your router, which allow you to configure your router. One
    of its features is that it provides access to online help.

    Nobody else can access your router configuration - it is entirely
    private to your router and local network (unless you turned on an option
    to allow remote management, which would be a bad idea; even in that
    case, nobody can access it using that IP address).

    Everyone else who has the same model of Thomson router can access the
    configuration of their own router using the same IP address (assuming
    they haven't changed its configuration to use a different address).

    Calling it the "Thomson site" is not helpful - it is not the Thomson web
    site (which is at the address I mentioned in an earlier post). Everyone
    without a Thomson router (such as me) only has access to the publically
    available documentation on the Thomson web site.
    That is probably the wrong password. The router has at least two

    1. The password required to access the configuration of the router. This
    is always set to something simple by default, but it varies between
    brands. It is often something like "admin" or "password" unless you
    changed it. It has nothing to do with accessing the WiFi network.

    2. The WiFi network created by the router optionally has a password,
    passphrase or access key (teminology varies) which must be entered on
    all computers or other devices which are allowed to access the network.
    Yes. It is the encoded form of the passphrase that would have been
    specified for the WiFi network. If you have restored factory defaults it
    may be a default one.

    When you set up a WiFi network using WPA-PSK (which is what you are
    using here), you normally get to specify a "password" or "passphrase"
    which must be a minimum of 8 characters long. This gets encoded into a
    fixed length key as a very big number. It appears your router is only
    showing you the encoded key rather than the human-readable password.

    I just tested this with my own WiFi network (created by an Apple Airport
    base station). Its management utility can show the equivalent network
    password, which displays it as the human-readable form I entered and the
    encoded form, which in my case is a string of 72 letters and numbers
    (actually a very big number in base 16, also known as hexadecimal, which
    is written out using the digits 0-9 and the letters A-F).

    I was able to join my WiFi network from my iPhone by entering the
    encoded form (very carefully).

    Now that you have posted it publically, you should change it, because
    anyone who knows where you live and finds this post will be able to get
    onto your WiFi network and borrow your Internet connection while sitting
    in a car outside.

    The procedure to change the WiFi password is described starting on page
    25 of the "TG585-v7_SetupUserGuide_en.pdf" document.

    It says you need to do the following. I've interleaved my comments in
    square brackets.

    1. Open the Thomson Gateway Web Interface (
    2. On the left menu, click Home Network.
    3. Under Wireless, click your access point.

    Your access point will be listed in the following format: "WLAN:<Network
    Name> (<Actual Speed>)". For example, WLAN: Thomson83C7C7 (54Mbps).

    4. The Wireless Access Point page appears.
    5. In the Location bar, click Configure.
    6. Under Security, you can change the Encryption.

    [You should use WPA-PSK encryption, so the steps for that are:]

    7. Select Use WPA-PSK Encryption.

    8. In the WPA-PSK Encryption Key box, type a pass phrase (also known as
    Pre-shared key) of your choice. The pass phrase must consist of 8 to 63
    alphanumeric characters or 64 hexadecimal characters (characters from 0
    to 9 and from A to F).

    [I suggest entering a human-readable pass phrase which you can remember,
    i.e. 8 to 63 alphanumeric characters. This will be easier to type in
    than the 64 hexadecimal digits encoded key.]

    9. In the WPA-PSK Version list, click the WPA-version of your choice.

    [I suggest using WPA+WPA2 for maximum compatibility, but if all your
    devices and computers are new enough you can select WPA2 only as that is
    more secure.]

    10. Click Apply.

    11. Configure your wireless client(s) with the same settings.

    [In the case of the iPhone, you will just need to type in the same
    passphrase you entered in step 8.]
    David Empson, Dec 26, 2009
  8. nof

    nof Guest

    I have no joy here. I can't get into the router's IP site because a
    window pops up asking for user name and password. I haven't got a
    password. The long string which all the world now knows doesn't work
    for me. Tomorrow a few people will be back at work so I'll see whom I
    can find to start this network again from scratch.

    Thanks everyone for the help and all the suggestions were useful in
    one way or another.

    nof, Dec 28, 2009
  9. nof

    EMB Guest

    The default username is 'Administrator' (without the quotes).
    The default password is blank, so entering just the username and hitting
    the logon button will work if nothing has been changed from default.

    If they have been changed, then reset the router in its entirety by
    following the instructions on the below link, then set it back up from
    scratch again.

    EMB, Dec 28, 2009
  10. nof

    nof Guest

    Just a quick answer. Yesterday everything went berserk however I
    looked at the router this morning and found that the wireless light on
    the router was off. I reset the router as above and I am back in
    business. The iPhone didn't recognise my network yet there was also
    progress in that a new network was recognised - coincidentally is the
    Thomson4B754E maybe there is something I can utilise?

    nof, Dec 28, 2009
  11. nof

    nof Guest

    Hello everyone

    I contacted Apple helpline and I now have a wireless connection. Maybe
    I can help others.

    nof, Dec 29, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.