WIFI connection randomly/non randomly disconnects

Discussion in 'Wireless Networking' started by King Fu, Oct 21, 2004.

  1. King Fu

    King Fu Guest

    My wifi set up is: 1 desktop with a D-Link DWL-G250+ (b/g) PCI wifi
    card and a laptop with a Intel PRO 2100 (b) wifi card.

    I connect ad-hoc no problem, getting full signal (im only 2 meters
    away on the laptop from my desktop with no walls or anything in
    between), ICS working as does file and print sharing, but then either
    with a random time interval OR when i put a high load on the link it
    disconnects on the laptop. However the on the desktop it thinks its
    still connected.

    Both machines are running xp pro with sp2. I have disabled/enabled
    antivirus and firewalls but this makes no difference. As far as i can
    tell there is no firmware updates for either of these cards.

    I've tried messing around with some of the advanced settings on the
    d-link card but to be honest im not exactly sure what most of them do.
    And in any case it hasnt changed the problem one bit. One interesting
    note is that on the laptop card (intel pro 2100) there are none of
    these advanced settings.

    Windows is controlling both connections and i am not using the
    manufactorers software.

    Someone please help, i think im losing my mind!

    Another interesting thing to note is i brought this pci wifi card as i
    was unsucesful getting a bluetooth network set up with two bluetooth
    dongles, as just as in this case, it kept randomly disconnecting!
     
    King Fu, Oct 21, 2004
    #1
    1. Advertisements

  2. King Fu

    Joe Guest

    There's your answer, I think. Have a poke around the Net with Google,
    and the consensus (denied, of course) is that the Windows driver is
    being a little too clever, and trying to find a better signal,
    presumably on another channel. This leads to frequent disconnection.

    I saw this happen on several workstations (XP SP1) and eventually gave
    up and ran cables around. The most common workaround suggested is not
    only to use the manufacturer's connection software (I was doing that
    already, with no better success than with the Windows software) but to
    actually turn off the Wireless Zero Configuration service in XP and
    leave it on manual. Alternatively, if the manufacturer's software
    doesn't do the job, leave the Windows service on auto and stop it by
    hand after boot-up. I've been running one workstation like this for over
    a week, with only one disconnection during working hours. No apparent
    change after SP2 installed.
     
    Joe, Oct 22, 2004
    #2
    1. Advertisements

  3. Carey Holzman, Nov 10, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.