why does open secure shell not connect

Discussion in 'Linux Networking' started by david nnaemeka, Aug 22, 2012.

  1. when I run this route command: "route add localhost", if get the
    following error message:

    SIOCADDRT: No such device

    but on pinging localhost I receive a positive reply, according to the
    textbook i am reading, i should get a connection to telnet; my system
    only has open secure shell. so when I run this command again: "ssh
    localhost", i get the following error response:

    ssh: connect to host localhost port 22: Connection refused

    Is there a reason why i cannot use secure shell for my loopback
    interface?
     
    david nnaemeka, Aug 22, 2012
    #1
    1. Advertisements

  2. david nnaemeka

    Jorgen Grahn Guest

    More people would understand you if you just called it "ssh".
    Most likely, no sshd daemon is listening on TCP port 22 on localhost.
    Perhaps you have installed the ssh client, but not the server.
    Check 'netstat -tap'.

    What are you *really* trying to do, by the way?

    /Jorgen
     
    Jorgen Grahn, Aug 22, 2012
    #2
    1. Advertisements

  3. I don't know why you think you need to do this.
    Most likely is that you don't have an sshd installed or running. Other
    possibilities are that you do but you've configured it with a strange
    ListenAddress, or set up a firewall that blocks access to it.
     
    Richard Kettlewell, Aug 22, 2012
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.