webservice client doesn't work properly

Discussion in 'MCSD' started by jacksu, Feb 24, 2004.

  1. jacksu

    jacksu Guest

    Sorry for posting this again. I tried some other senario,
    and found there is a fundamental issue about the
    webservice client.

    If there is "0x0d", "0x0a" at the end of the xml document,
    C# webservice client will fail.

    For example, Amazon webservice will fail with C#, but
    google works. With the same .NET framework.

    I tried to override some webservice system class, failed.
    Because the one which reports the error is not virtual
    class, so that can't override.

    That class name
    is "System.Web.Services.Protocols.SoapHttpClientProtocol.Re
    adResponse"

    Is there any fixing on that?

    Any suggestion is welcome, thanks in advance.

    Jack
     
    jacksu, Feb 24, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.