VLAN Trunk instability (not elephant)

Discussion in 'Cisco' started by Craig Tranfield, Dec 12, 2003.

  1. I have had a vlan trunk working happily for years but when
    trying a similar config on a pair of...
    IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(11)EA1

    ....the far end fails after varying amounts of time...
    1d16h: %ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on
    GigabitEthernet0/1. The port is forced to linkdown.
    1d16h: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernt0/1,
    changed state to down

    ....with the near end still showing connected.
    A simple shut/no shut of the near end brings it back up
    but I wish it would not go down in the first place.

    I have tried swapping which switch is near/far, port types, UTP and
    media converters to/from fibre :-(

    Having added what I took to be "extras" of:
    switchport nonegotiate
    udld enable

    ....the current config is...
    interface GigabitEthernet0/1
    switchport trunk allowed vlan 1,17,124,1002-1005
    switchport mode trunk
    switchport nonegotiate
    no ip address
    keepalive 2
    duplex full
    speed 1000
    udld enable

    ....which gives interface details of...
    Keepalive set (2 sec)
    Full-duplex mode, link type is force-up, unknown 0
    output flow-control is unsupported, input flow-control is unsupported, 1000Mb/s
    input flow-control is off, output flow-control is off


    Anybody got any insight as to what is wrong?

    Thanks,

    Craig
     
    Craig Tranfield, Dec 12, 2003
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.