Vista RC2 - Unable to resolve Internet Names in IE but NSlookup works!!

Discussion in 'NZ Computing' started by Martin, Oct 11, 2006.

  1. Martin

    Martin Guest

    Just installed Vista RC2 - install went without a hitch, all drivers seem to
    be detected including NIC but......(-;

    Try to browse using IE and "Internet Explorer cannot display the webpage"
    So I test the basics - can i ping the gateway by IP- Yes
    Can I ping - No - ok, so DNS issue but...
    I can do a nslookup, uses my ISP's DNS server and I put in and it
    resolves it!!! arghh...
    I go back into IE and type in and it comes back with Googles
    homepage so no connectivity issue...

    Now I'm confused - nslookup works, I can also ping by name other PC's on
    the LAN (which is using netbios name resolution i guess) but i can't ping by
    name, telnet by name or use other apps which need to do a DNS lookup..

    My only theory at the moment is that maybe its a IP6 issue - its turned on
    by default inVista RC2 but I've unticked it in net connections (can't seem
    to uninstall it) and still no go...

    Any ideas or similar Vista experiences would be welcome...

    cheers / martin
    Martin, Oct 11, 2006
    1. Advertisements

  2. Martin

    Martin Guest

    Some progress - If i use ping -4 it works!! So I'm now sure its a
    IP6 issue - the question is now how do I remove (or disable) Ip6 from Vista?
    Martin, Oct 11, 2006
    1. Advertisements

  3. Martin

    Kerry Brown Guest

    What DNS server is showing in ipconfig /all? Is it the same one that worked
    with nslookup?
    Kerry Brown, Oct 11, 2006
  4. Martin

    Martin Guest

    Yes, and I have tried several other ISP DNS servers - same result -
    interestingly I have wiped RC2 and installed Vista Beta 2 and don't have the
    same issue...

    I'm tempted to try an upgrade of beta2 to RC2 (if it lets me) and see if the
    issue comes back..

    Also, using RC2 I did untick IP6 and check the binding order and IP4 is at
    the top and it still appears to use IP6 first when I ping names!! (this is
    proven by the fact that ping doesn't work but ping -4
    does work)

    Also again (-: this issue doesn't just happen in IE so thanks for the advice
    to use firefox but if it effects ping and telnet as well then it isn't a
    browser issue.
    Martin, Oct 12, 2006
  5. Martin

    Kerry Brown Guest

    It does sound strange. If you try the upgrade let us know the results.
    Kerry Brown, Oct 12, 2006
  6. Martin

    Martin Guest


    Tried to to an upgrade from within beta2 but it said upgrade was disabled -
    only supports upgrade from Vista(!) or XP SP2 so I have a fully working
    Beta2 with Cisco Vpn, Office 2K7, NOD32, VNC, Firefox but no way of going to
    RC2 without wiping and starting again and maybe having exactly the same
    issue.....decisions...decisions (-;

    The only other thing that has come to mind since I started this process is I
    use an unusual internal subnet - Due to some historical reasons (corp vpn
    issues) I'm using 169.254.1.x as my internal IP address range - yes thats
    right I'm using the APIPA range instead of 192.168 or 172.16 or 10. - this
    has never been an issue so far..... (-;

    thanks everyone for their comments.
    Martin, Oct 12, 2006
  7. Martin

    Kerry Brown Guest

    There is another thread in the group with the subject
    "Does anyone from Microsoft read this group?" where someone has a very
    similar problem. They are also using the APIPA range. You may want to reload
    RC2 and report the bug. You could try reporting it from beta 2 but I don't
    know if it will get noticed that way.
    Kerry Brown, Oct 12, 2006
  8. Martin

    Martin Guest

    Kerry!!!! You are da man!! You put it together when you mentioned the other
    thread!! I reinstalled Visata RC2 from scratch, changed my local subnet to
    172.16.x and its all working!!! I'm amazed that the TCP/IP stack (or maybe
    DNS) treats APIPA addresses in this way - the logic must be that an APIPA IP
    is only used for emergencies if DHCP is not available from a server or
    router so you would only want local connectivity not WAN...Kinda like using
    a non-routable protocol like netBEUI.

    So the next question is do I change the subnet back to confirm the
    issue....hmmm...time is not on my side here ... would like to actually try
    this OS out a bit now its Internet connected... Anybody else want to try???

    cheers and thanks MVP's (-;
    Martin, Oct 13, 2006
  9. Martin

    Kerry Brown Guest

    You should report it as a bug. I can't see any reason you shouldn't use an
    APIPA address if you want.
    Kerry Brown, Oct 13, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.