VirtualBox Windows guest loses DHCP and DNS

Discussion in 'Linux Networking' started by Charlie Gibbs, Aug 1, 2012.

  1. Several months ago I installed Ubuntu 10.10 on my wife's new laptop,
    then used VirtualBox to duplicate the Windows XP environment that
    she had on her old laptop. It was working perfectly; I had set up
    the guest machine's networking as a bridged adapter, and her virtual
    XP machine got its own IP address and appeared on the LAN as an
    independent machine.

    A few weeks ago, though, things went south. It was probably about
    the time that we activated Telus Optik TV, although Telus had
    installed the Actiontec V1000H modem a couple of weeks before
    as a replacement for an older ADSL modem that had died. The
    Actiontec was working so well that I had gotten rid of my existing
    router and wireless access point, turning all the duties over to
    the Actiontec.

    After a couple of weeks of smooth operation with no modifications,
    the guest XP machine suddenly lost access to the LAN. The ipconfig
    command showed that it had one of those 169.254.x.x addresses that
    comes up if DHCP can't be found. Oddly enough, the Ubuntu host
    machine continued to work perfectly. I upgraded to version 4.1.18
    of VirtualBox, but that didn't help. I re-configured the network
    parameters in the XP box to set its IP address to 192.168.0.100
    instead of relying on DHCP, set the gateway IP address to 192.168.0.1
    (the Actiontec box), and inserted DNS IP addresses that I found in
    /etc/resolv.conf on the host. The guest machine then found the LAN
    and the Internet and sort of worked, but it's still so flaky as to
    be practically unusable.

    Once back from vacation, I fired up my own laptop, which I've set
    up the same way (except that my host is Mint 12 LXDE), and got
    the identical failure. On the other hand, my desktop box, which
    runs Slackware 13.37 and has a Win2000 guest under VirtualBox,
    continues to have perfect network communications for both host
    and guest. (For what it's worth, it's wired, not wireless.)

    I haven't touched the settings in VirtualBox itself. If it was
    a problem with the wireless modem/router, why would the host
    continue to function?

    Even when the guest works, it frequently loses connections.
    Accessing speedtest.net through the host reports 15Mbps downloads,
    while attempting to access it through the guest fails completely.
    (The guest can access other sites such as Google, however.)
    The host can FTP to a server on my LAN; the guest won't connect.

    Help!
     
    Charlie Gibbs, Aug 1, 2012
    #1
    1. Advertisements

  2. Charlie Gibbs

    dyrmak Guest

    En 53 lignes Charlie Gibbs a écrit
    dans le mercredi, 01 août 2012 à 22:40:03 :
    For what it's worth, have you tried a wired connection on the
    ailing laptop ? it is known to this date that bridging a guest
    machine with wireless is not possible.

    Here is a real exemple: I have bridged a kvm-qemu machine running
    Debian Squeeze, the host is again Debian Squeeze and it won't
    ping anything until I run the dam 20 yards ethernet cable. I dual
    boot with Mint 12 Gnome and running the very same guest image
    with kvm-qemu remains same as equal.

    I haven't played with VirtualBox for any lenght of time, but
    there probably is a default magical internet configuration that
    sort of keeps on working.... I'd shortcut delays with a local
    DNS running on the host machine, the guest will resolve ip address
    through the host. My setup runs this way : guest machine IP:
    192.168.0.104 host machine: 192.168.0.100 , DNS on guest machine:
    192.168.0.100

    dyrmak
     
    dyrmak, Aug 10, 2012
    #2
    1. Advertisements

  3. Before we begin, another data point: I tried installing VMware
    Player on my wife's machine. It was one of the slickest installs
    that I've ever seen - but once the Windows guest machine came up,
    it had identical networking problems to the VirtualBox guests.
    So whatever the problem is, it's not a bug in VirtualBox - which
    comes as a great relief to me, since I now know that my production
    VirtualBox guest, which is on a wired network, is in no danger of
    spontaneously going down.
    I had tried plugging a network cable into my laptop, but it made
    no difference. I then realized, however, that I had configured
    the guest machine with only a wireless interface (wlan0). When
    I added a second emulated interface, this time to a wired network
    (eth0), it came up properly. In fact, when I reconfigured the
    interfaces to use DHCP, they both worked - but only if the Ethernet
    cable was plugged in. As you say, it isn't able to bridge a
    wireless interface - although a wired interface, if present,
    seems to provide the magic needed by the wireless one.

    As an additional experiment, I disabled the wireless interface
    in the Actiontec router, dug out my old wireless access point,
    and plugged it back into my switch, restoring my original
    wireless configuration. This too failed to work on a bridged
    wireless connection.

    I've found a number of references on the net to procedures
    for getting bridging to work, but they look pretty involved
    and I've already spent more time than I can afford on this
    so I'll presuade my wife to limp along until another day.

    But I'll leave you with the following brain-teaser: why did
    wireless bridging work perfectly for several months, both on the
    old and the new hardware? What is the magic that used to be there,
    but which can now only be had by plugging in an Ethernet cable?
     
    Charlie Gibbs, Aug 11, 2012
    #3
  4. Charlie Gibbs

    dyrmak Guest

    En 59 lignes Charlie Gibbs a écrit
    dans le samedi, 11 août 2012 à 01:05:04 :
    Right to the point, your VirtualBox is on the safe side.
    It is the ethernet connection that provides the bridge, in this case
    wireless is at best irrelevant because as soon as you take away
    the ethernet cable off goes with it the internet connection.
    Nothing on your actual nor past hardware is at fault, something changed
    however on your software components, you certainly did updates
    you did not think could be harmfull to your setup system.
    I am aware of that and me neither wanted to go through hoops
    to get bridging connectivity to work, because ethernet was
    good enough for me and because I had another wireless way of doing
    things without bridging, this solution involves using iptables and it works,
    but for practical reasons I decided to stay with ethernet.

    To this date it does not work:

    brctl addif br57 wlan0 says "operation not permitted"
    and this is the same on Debian-Wheezy and Mint 12
    brctl version is 1.5

    But wait a minute, wait a minute:

    brctl addif br58 wlan0 is accepted on Mint 9
    and on Debian Squeeze ( which is no longer my
    host operating system )
    brctl version there 1.2
    so I think we have the answer, wireless is an ongoing adventure
    and as yet not a take it for granted sort of thing.

    dyrmak
     
    dyrmak, Aug 13, 2012
    #4
  5. I don't think I did, but probably Telus (our ISP) did. Things
    started going sideways about the time I signed up for Optik TV
    (their Internet digital TV package). I suspect they gave the
    Actiontec box got a firmware update at that time.
    I've since discovered that as long as the Ethernet cable is
    connected when I boot the guest machine, not only do both
    the Ethernet and wireless connections work perfectly, the
    wireless one continues to work if I unplug the Ethernet
    cable. Apparently the magic is needed only at startup.
    I still don't understand the mechanism, but my wife is
    happy now.
    So it seems. Thanks for the info.
     
    Charlie Gibbs, Aug 13, 2012
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.