Version 15.1(4)M4 outgoing byte count wrong

Discussion in 'Cisco' started by Rob, Jun 7, 2012.

  1. Rob

    Rob Guest

    In IOS Version 15.1(4)M4 running on an 1811 the output byte
    count appears to be wrong on Virtual-Access interfaces for L2TP/IPsec.

    Virtual-Access2 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Closed
    Base PPPoVPDN vaccess
    Vaccess status 0x44, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 5 seconds on reset
    Last input 00:00:00, output never, output hang never
    Last clearing of "show interface" counters 2d18h
    Input queue: 0/4096/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 4000 bits/sec, 2 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    49120 packets input, 7045240 bytes, 0 no buffer
    Received 0 broadcasts (0 IP multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    52961 packets output, 52168 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions

    Virtual-Access2.1 is up, line protocol is up
    Hardware is Virtual Access interface
    Interface is unnumbered. Using address of Loopback0 (
    MTU 1500 bytes, BW 7200 Kbit/sec, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Open
    Open: IPCP
    PPPoVPDN vaccess, cloned from Virtual-Template2
    Vaccess status 0x0
    Protocol l2tp, tunnel id 26551, session id 31061
    Keepalive set (10 sec)
    5165 packets input, 972655 bytes
    5167 packets output, 3595 bytes
    Last clearing of "show interface" counters never

    The "packets input", "packets output" and "bytes input" look like they
    could be correct, but the "bytes output" clearly is wrong.

    This worked OK on our previous router under 12.4
    Is this a bug or a functionality change?
    Could it be that it can be made working with some config change?

    interface Virtual-Template2
    description L2TP/IPsec VPN template
    ip unnumbered Loopback0
    ip access-group dialup-in in
    ip access-group dialup-out out
    ip mtu 1400
    ip tcp adjust-mss 1350
    peer default ip address pool vpnpool
    ppp authentication ms-chap-v2 ms-chap
    ppp pap refuse
    Rob, Jun 7, 2012
    1. Advertisements

  2. Rob

    Rob Guest

    I still wonder if it is a bug or if there is a new feature introduced
    between 12.4 and 15.1 that requires me to add some configuration to
    get correct bytecounts.
    Rob, Jun 15, 2012
    1. Advertisements

  3. I doubt there is anything to configure. We've been plagued with wrong
    traffic counts on various router loads over the last many years all
    the time on many different cisco platforms.
    Its something we can almost count on :(
    Until we find the magic version that fixes it with the feature set we want.
    Doug McIntyre, Jun 15, 2012
  4. Rob

    Rob Guest

    Well, it has worked OK here for quite some time (we make nice traffic
    graphs out of these via snmp), but I upgraded this router to this
    version because of an ISAKMP security issue and to see if it resolves
    other problems, and unfortunately I have now two new issues.
    (this one and the different handling of ip local pool)
    Rob, Jun 15, 2012
  5. Rob

    Rob Guest

    Unfortunately it turns out to be wrong in the RADIUS accounting as well...

    Apparently it is not a display issue but the actual counter has been
    busted and its wrong value appears everywhere (show interfaces, SNMP
    values, RADIUS accounting)
    Rob, Jun 25, 2012
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.