Using switchport mode access vlan x and switchport mode trunk on the same interface

Discussion in 'Cisco' started by lowfell1, Sep 25, 2007.

  1. lowfell1

    lowfell1

    Joined:
    Sep 25, 2007
    Messages:
    2
    Likes Received:
    0
    This has been answered before, but I need a better explanation!

    Basically looking at a switch on my network I can see the following on a 2960 switch interface

    interface FastEthernet0/1
    switchport access vlan 201 **************
    switchport trunk native vlan 888 **************
    switchport mode trunk
    speed 100
    duplex full


    WHY DO I HAVE
    switchport access vlan 201
    &
    switchport trunk native vlan 888
    ON THE SAME INTERFACE ???

    Looking at another switch somewhere on the same network i only see this

    interface GigabitEthernet0/12
    switchport trunk native vlan 888
    switchport mode trunk

    IF IT'S A TRUNK PORT, THEN DOESN'T IT JUST NEED THE
    "switchport trunk native vlan 888" ??

    & NOT THE
    "switchport access vlan 201"

    Help as I'm very confused:question: :question: :question:
     
    lowfell1, Sep 25, 2007
    #1
    1. Advertisements

  2. lowfell1

    thort

    Joined:
    Sep 26, 2007
    Messages:
    35
    Likes Received:
    0
    normally not needed

    Normally a switchport is a port that connects to a PC/server and only has (normally) one VLAN carried on it. It tags the VLAN ID associated with the port as traffic comes from the pc toward the network. It untags the VLAN ID as traffic exits towards the PC from the network.

    A trunk port normally carries multiple (or all) VLANS and is connected to another switch or mulit-vlan server. The use of native VLAN 888 tells the trunk port to keep all VLAN IDs that enter and exit except VLAN ID 888, witch is untagged.

    You should be able to take out the switchport access vlan 201 from the config with no problem. Maybe fe0/1 was an access port and then it was configured as a trunk port, without removing the access port portion of the config? Or you use the port for both pc access and switch trunking at different times ? --> Cisco can autosense if a switch trunk or access port is plugged in... one config to rule them all rather than separate configs.

    I say do a 'no switchport access vlan 201' on the interface if you are sure that it is supposed to be a trunk port to another switch. KISS concept.

    -Thor
     
    thort, Sep 26, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.