Using HSRP for fail over from Frame Relay to DSL

Discussion in 'Cisco' started by ksnight, May 31, 2005.

  1. ksnight

    ksnight Guest

    I have a router at the main office with static routes to another
    location. I am using Frame Relay to that location and I also have
    another static route to that location using DSL. The original config
    was set up using two diffrent networks and if one failed I would have
    to instruct the other location how to unplug the frame router and plug
    in the DSL router. Then would have to change jetdirect ip address for
    that network.

    Well I have now set up the two routers at the location to use HSRP. The
    837 (DSL) router and the 1600 (frame) router are working great! HSRP is
    working! The problem I am having is that the router at the main office
    is not switching to the valid route. I now have it configured using two
    static routes with administrative distance. How long should I have to
    wait for this route to become active? Why am I not allowed to ping the
    non-active router? What am I doing wrong? How should I configure the
    main office router? Should I use EIGRP, RIP, or OSPF.
    ###########################
    Frame Router at location
    ###########################
    interface Ethernet0
    ip address 192.168.30.253 255.255.255.0
    ip helper-address
    no ip redirects
    no ip directed-broadcast
    no keepalive
    standby ip 192.168.30.254
    standby track Serial1.1 20
    standby priority 110
    standby preempt
    ###########################
    DSL Router at location
    ###########################
    interface Ethernet0
    ip address 192.168.30.252 255.255.255.0
    ip helper-address
    standby ip 192.168.30.254
    standby priority 100
    standby preempt
    standby track Dialer0 20
    hold-queue 32 in
    hold-queue 100 out
    ###########################
    Main Router at main office
    ###########################
    S 192.168.30.0/24 is directly connected, Serial0/0.30
    S 192.168.30.0/24 is directly connected, Serial0/1.300


    Thank You,
    Kenny
     
    ksnight, May 31, 2005
    #1
    1. Advertisements

  2. ksnight

    anybody43 Guest

    It would appear that a dynamic routing protocol
    is what you need.

    I would choose OSPF but EIGRP is perfectly
    good choice too.

    I have never used unnumbered interfaces
    and a routing protocol and you don't say what is on
    the dialer or the Serial. I have no idea if that will
    work. I guess it must be OK.

    With the above caveat:

    remove the standby track bits
    remove the static routes.

    add

    router ospf 1
    network 192.168.30.0 mask area 0
    network other.nets.you have.connected.to.routers mask area 0

    Check the OSPF costs that you are getting by
    default and if necesary add a costs statement to
    the relevant WAN interfaces.


    router ospf 1
    log-adjacency-changes
    redistribute static ! only if you say want to
    ! propagate a static route
    ! from say the central site
    ! e.g. default route.
    network 10.23.0.0 0.0.255.255 area 0
    network 192.168.0.0 0.0.7.255 area 0


    sh ip ospf int vl 1
    Vlan1 is up, line protocol is up
    Internet Address 192.168.7.248/24, Area 0
    Process ID 1, Router ID 192.168.7.248, Network Type BROADCAST, Cost:
    1


    Well that would work with point to point
    serial and ethernet interfaces.
    The frame relay interface may need a bit
    more work since it may not handle the
    OSPF hello multicasts.

    Left as an exercise for the reader:)
    In other words I'm stuck and I can't be bothered
    to look it up.
     
    anybody43, May 31, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.