usb2 drivers ?

Discussion in 'Windows 64bit' started by Guest, May 31, 2005.

  1. Guest

    Guest Guest

    is their any usb2 drivers available ?, i cannot seem to get them installed in
    xp64 (mobo =asus k8n)
     
    Guest, May 31, 2005
    #1
    1. Advertisements

  2. Did you check Windows Update? Maybe your drivers might be detected then.
     
    Andre Da Costa, May 31, 2005
    #2
    1. Advertisements

  3. USB2 drivers for what? Your motherboard? A USB2 device? Need more info.

    Rafael Rivera
    Extended64 | http://www.extended64.com
     
    Rafael Rivera [Extended64.com], May 31, 2005
    #3
  4. Guest

    Rick Guest

    You shouldn't need any additional driver. The USB2 drivers are part of
    the x64 baseline. My USB 2.0 ports are running at full speed!
     
    Rick, May 31, 2005
    #4
  5. Thats what I was saying to myself also, best recommendation is to remove the
    USB Bus Controllers under device manager or scan for hardware changes.
     
    Andre Da Costa, May 31, 2005
    #5
  6. Guest

    Guest Guest

    my mobo is the asus k8n and it does not detect usb2 , it should also say
    something about it being the nforce3 250 chipset but does not
     
    Guest, May 31, 2005
    #6
  7. Rafael Rivera [Extended64.com], May 31, 2005
    #7
  8. Guest

    Guest Guest

     
    Guest, May 31, 2005
    #8
  9. Guest

    Guest Guest

     
    Guest, May 31, 2005
    #9
  10. Guest

    Guest Guest

     
    Guest, May 31, 2005
    #10
  11. Guest

    Guest Guest

    Guest, May 31, 2005
    #11
  12. Rafael Rivera [Extended64.com], May 31, 2005
    #12
  13. Guest

    Guest Guest

    thanks , cause if i cannot get this sorted i will go back to 32bit xp pro
     
    Guest, May 31, 2005
    #13
  14. USB2 is in there already, you shouldn't need any additional drivers.
     
    Charlie Russel - MVP, May 31, 2005
    #14
  15. Guest

    John Barnes Guest

    The AN8-SLI has the Nforce4 chip not the Nforce 3 being mentioned
     
    John Barnes, May 31, 2005
    #15
  16. Guest

    Guest Guest

    well they are not showing up when i try to upgrade to usb2 , if i remember
    correctly it was a separate install on my mobo drivers disk (32bit driver
    that is)
     
    Guest, May 31, 2005
    #16
  17. Guest

    Rick Guest

    Look in your Device Manager at the USB devices and see if one of them
    says "Enhanced Host Controller." If it does, look at the drivers and
    one of them should be "usbehci.sys" which is the USB 2.0 driver. The
    last OS that needed additional drivers for USB 2.0, supposedly, was
    Windows 98SE & Me. Microsoft has included the USB 2.0 drivers Windows
    XP (maybe starting with SP1) and they are included in the Win x64 OS.
    They are in the OEM x64 OS I purchased and were loaded during the
    installation. They were also in all four of the CPP versions I installed.

    What makes you think you need additional drivers?
     
    Rick, May 31, 2005
    #17
  18. Guest

    Rick Guest

    I don't think there were any on your mobo disk since there are none on
    the Asus download site. Asus doesn't even mention a USB 2.0 driver for
    the K8N.
     
    Rick, May 31, 2005
    #18
  19. Andre Da Costa, May 31, 2005
    #19
  20. Do this:
    Thats what I was saying to myself also, best recommendation is to remove the
    USB Bus Controllers under device manager or scan for hardware changes. Or
    Rerun the hardware Wizard from Control Panel.
     
    Andre Da Costa, May 31, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.