USB suddenly died, system started to freeze a lot

Discussion in 'Computer Support' started by Indi, May 15, 2007.

  1. Indi

    Indi Guest

    I have Acer Travelmate 4052 laptop with Centrino 1.6 Ghz processor, I
    took Hardisk from my PC to copy some data to my laptop and for that I
    bought a 3.5 inch casing which came along with an adaptor. It went
    well for a hour and copied some data but after that a message popup
    saying POWER SURGE ON USB HUB and pulled the usb connector and
    connector to the other remaing two ports alternatively but same
    message. When I restarted my computer and try to connect as usual my
    microsoft usb mouse, my system froze, nothing worked alt+crtl+del,
    nothing, so restarted but same problem on other ports as well. I
    reinstalled the USB controller but to no use, I updated the BIOS,
    enable - disable USB legacy support and USB Mass Storage suporrt from
    the BIOS but to no use. I tried to reinstall the same Winxp pro with
    integrated SP2 which was earlier on the system but it froze too,
    sometimes at intial copying of files after formating, sometimes at 34
    min remaining screen, then at 9 min, and 5 min remaining to complete
    the setup.

    I consulted one very popular laptop repair shop and the technician
    told me that it is a very common problem with computer and especially
    laptops and your Intel 82801 DBM chip has to be replaced, there is no
    alternative, and he was not sure whether it will be ok again, if not
    he said then I have to replace the motherboard. As it was a costly
    step, I tried many forum for help but to no avail. Nothing helped me
    at all.

    Finally, as I system as out of warranty and being a electronic
    hobbiest myself, I took apart my laptop and tried something really
    stupid. I placed my system in front of the airconditioner and
    restarted the 39 min installation process and walla it did completed
    successfully. Then I installed all the drivers successfully, I didnt
    tried the USB at all that time but I noticed that my CPU was
    constantly at 100% as the system was at IDLE state. I was sure about
    any virus or malware as firstly after installing windows with SP2 i
    updated the hotfixes and critical updates from AUTOPATCHER then
    installed the Internet security suite then connected to internet to
    update it, so I scanned and as expected nothing showed up. Then I
    tried the SysInternal which is now owned by Microsoft, the Process
    Explorer as no doubt the System was slow to 25% of its original speed,
    I try to figure out by searching the running thread from Process
    Explorer then I saw 4 threads which were taking all the CPU usage and
    to no surprise these were USBPORT.SYS+0x5fe6 (ALL FOUR), when I try to
    kill these threads, access was denied so I suspend them all and my cpu
    immediately comes to actual idle state 2-5%.

    I have not found any cure so far please help me. My system boots very
    very slow then I have to wait for the desktop things to appear so that
    I can open the Process Explorer to shut those USB threads and then I
    can work.

    Is it really the DBM chip fault which I read somewhere as Intel
    SouthBridge 82801 DB ICH4-M. As I explained I tried everything so far
    as I am a network engineer myself and electronic hobbiest so far
    whatever I could, I tried but nothing. I even tried the PCMCIA usb
    card, it did work once with mouse but didnt worked again. I asked the
    same technician he said how can this PCMCIA card will work as it only
    changes the Interface, controller on the motherboard still is the same
    which has to work.

    I tried to find the schematic so that I can check the voltages across
    the MOBO but only could find the service manual that too for
    Travelmate 290 which has identical motherboard.

    Please please help me, I am sure that Google group can help me out
    here.

    INDI
     
    Indi, May 15, 2007
    #1
    1. Advertisements

  2. Indi

    Pennywise Guest

    Google groups :)

    Start | Run <type in>
    devmgmt.msc
    <enter>

    Drop down to USB controllers

    Double click on each host controller, Advanced
    see what % each is using - kill anything over 10%

    Double click on each hub, power and see what type of amps each is
    using kill the obviously high one(s).

    Or something to that effect... Not sure what your going to lose.
     
    Pennywise, May 16, 2007
    #2
    1. Advertisements

  3. Indi

    Indi Guest

    I am process explorer and whenever I boot I have to go to the system
    threads and have to disable all the USBPORT.SYS threads, 4 of them, as
    they kept my CPU to 100%, I heard about the microsoft fix and try to
    use it also which says that some services or somethings keep on
    running eventhough you unplugged all the devices from USB, like it
    assumes that device is still running and even if you try to reinstall
    xp then also it will freeze during the setup according to that.
    Nothing so far
     
    Indi, May 18, 2007
    #3
  4. Indi

    Pennywise Guest

    I might be having a similar problem here.

    I get three USB dings (device being taken in and out) only once have I
    seen a tip balloon that says a device was unplug which corrected
    itself. And the system freezes mostly when Opera is playing a video.

    Bought a new mouse, it was time. It fixed the USB ding problem but the
    system is still freezing - left alone by itself it will pull out of
    it, and I can use it again and CPU never reads higher than 3% (turning
    the power off is much quicker <G>).

    The best way me to fix this problem is to run SFC /SCANNOW but that
    POS won't work!!

    Using Process Monitor and Regedit, I've been able to replace a missing
    file I've found usbui.dll to be exact. (from the i386 dir)

    Start | Run <type in>
    services.msc
    <enter>

    "Human Interface Device Access" was my problem, it starts now.

    I dual boot - the other OS works just fine.
     
    Pennywise, May 18, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.