USB - Device won't install

Discussion in 'Computer Support' started by Eos, Jan 26, 2005.

  1. Eos

    Eos Guest

    I am ready to chuck the pc through the window! I have a Sony DSC-P93 digital
    camera and I use Win XP Pro. I tried to connect the camera to the PC, but
    everytime I run the "installation program" on the CD and reboot, Windoze
    keeps asking me for the driver...'again. Well, it's there in a folder which
    the "installation program" created, but it doesn't want to know about it.
    Then I point it to the folder and tell it to 'go fetch'....'nada! I bought a
    USB card reader today to see if that would solve the problem, but it doesn't
    show up either. It also has an "installation program"! (I prefer a folder on
    the cd rom with an INF file). Well, I have 4 USB ports in total, one for
    printer, one for webcam and one for another digital camera (Canon make).
    Everything else works fine. They all work on the 'spare' port too. Is there
    any way to check if the mass storage driver is working okay, as it "might"
    be the problem...'then again, it might not be. I tried the Sony digicam and
    the card reader on another pc in the house, and they just pop up as soon as
    they are plugged into the USB ports. I've googled all over the internet till
    I'm sick of looking at it, so any assistance would be greatly appreciated.
    TIA.
    Eos.
     
    Eos, Jan 26, 2005
    #1
    1. Advertisements

  2. Eos

    PC Guest

    Eos

    The rule of thumb with USB is 'put the software in first'

    So, remove all the software to do with the Camera and Card Reader (check in
    safe mode as well) reboot and reinstall the software.
    Then plug the Camera / Reader in, not before.

    Best luck

    Paul.
     
    PC, Jan 26, 2005
    #2
    1. Advertisements

  3. Eos

    Tony Guest

    Are your ports USB1 or USB2? The DSC-P93 manual says it is only compatible
    with USB2. Have you installed XP service pack 2 to enable USB2 support?
    (that is if your motherboard supports it). XP should recognise it without
    any additional drivers. The drivers are for W98/ME only.
     
    Tony, Jan 26, 2005
    #3
  4. Eos

    Fred Guest

    The solution lies in your opening sentence.
     
    Fred, Jan 26, 2005
    #4
  5. Eos

    Eos Guest

    Thanks for the tip Paul. I just tried all that you said, but no joy.
    Eos.
     
    Eos, Jan 26, 2005
    #5
  6. Eos

    Eos Guest

    My ports are USB 1.1, but the other PC also has USB 1.1 and both camera and
    card reader work fine on that one, but not one mine. My other USB devices
    work okay on my PC. I have Win XP Pro SP2 installed.
    The camera does work on a USB 1.1. system, but just slower than on a USB 2.0
    system would run. I downloaded the USBREADY utility from Intel and it says I
    have the necessary software and harware in place. I have the 'usbstor.inf'
    file in the c:\windows\inf folder, which I take to be the USB driver for Win
    XP and USB devices. I know I shouldn't really need to install a driver from
    the CD which came with the camera as it states it's only for Win98/ME.
    Anyone know where I go from here? :-{ (It's getting "nightmarish").
    Eos.
     
    Eos, Jan 26, 2005
    #6
  7. Eos

    Tony Guest

    Try running the autoplay repair wizard from Microsoft
    http://www.microsoft.com/downloads/...b6-e8fa-45c4-a171-1b389cfacdad&DisplayLang=en
     
    Tony, Jan 27, 2005
    #7
  8. Eos

    Eos Guest

    LOL!
    Eos.
     
    Eos, Jan 27, 2005
    #8
  9. Did you go into Device Manager and manually remove it there?

    Swill
     
    Governor Swill, Jan 27, 2005
    #9
  10. Governor Swill, Jan 27, 2005
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.