UPS service won't start/no UPS tab in Power Options

Discussion in 'Computer Support' started by jdimester, Oct 24, 2007.

  1. jdimester

    jdimester Guest

    I can't start the "Uninterruptible Power Supply" service in XP Pro
    sp2; I get:
    "Could not start the Uninterruptible Power Supply service on Local
    Computer. Error 2481: The UPS service is not configured correctly."


    (I'm trying to start this service so the UPS tab will display in Power
    Options so I can get my laptop to communicate with my APC Smart-UPS v/
    s 650 on COM4 via a Keyspan USB Serial Adaptor.)
     
    jdimester, Oct 24, 2007
    #1
    1. Advertisements

  2. jdimester

    olfart Guest

    did you install the software for the UPS?
     
    olfart, Oct 24, 2007
    #2
    1. Advertisements

  3. jdimester

    Pennywise Guest

    Do you have a COM4?

    Start | Run <type in>
    devmgmt.msc
    <enter>
    Under Ports.

    If not you need to add one by using the Control panel / Add new
    hardware.
     
    Pennywise, Oct 24, 2007
    #3
  4. Google is your friend, dumbass.
     
    Paige D'Winter, Oct 24, 2007
    #4
  5. jdimester

    jdimester Guest

    did you install the software for the UPS?

    thanks, but APC and I found that their software no longer supports my
    model.
    thanks, yes I do.
    rest assured that I googled this matter extensively before looking to
    you for help, thanks.

    JS
     
    jdimester, Oct 31, 2007
    #5
  6. jdimester

    enigma_ticanomaly

    Joined:
    Nov 5, 2009
    Messages:
    1
    Likes Received:
    0
    Possible solution found

    I think I have fixed this problem.

    This problem appeared on a server that I admin.

    Previously, I had used a UPS connected to a COM port, and am sure the UPS service was functioning. After replacing the UPS and using the USB connection is most likely where the problem began.

    Because the configuration for the COM port UPS was never erased, when the HID-Battery device was installed, I'm sure the UPS tab was disabled and the service was disabled, but the configuration was still set up for the old UPS. I noticed this under the UPS Service settings in the registry. The easiest way to erase those settings and configure them for default is to simply select (None) from the "Select..." section of the UPS tab.

    Since the UPS tab somehow disappeared, we need to get that back first.
    There is a simple registry key entry to add to make this tab show again.

    HKLM\SYSTEM\CurrentControlSet\Services\UPS

    Value Name: ShowUPSTab
    Data Type : REG_DWORD
    Data Value: 1

    Once you have modified the registry with this value, re-open the power control panel, press "Select...", and choose (None)

    You may have to select a random UPS and apply those settings if (None) is already selected, then change back to (None) and apply again.

    This should default your UPS configuration.
     
    enigma_ticanomaly, Nov 5, 2009
    #6
  7. jdimester

    moc.hooha

    Joined:
    Nov 7, 2008
    Messages:
    2
    Likes Received:
    0
    Thanks, that worked! The UPS tab is back, at the minimum.
     
    moc.hooha, Jan 23, 2010
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.