UPNP Internet Gateway keeps dropping with Belkin WiFi Router

Discussion in 'Home Networking' started by Chris Smithers, Apr 21, 2006.

  1. Hi all, I have:

    WinXP Pro SP2
    Belkin Wireless G Plus router (F5D7231-4 with latest firmware)
    Internet Gateway and UPNP enabled in XP
    UPNP enabled in my Router's admin page

    However, at random intervals the Internet Gateway connection vanishes, the
    icon disappears from Network Connections, and the connection icon goes from
    the tasktray. Then many file transfers such as MSN slow down.

    The only way to get it back is to go into my router's admin page...

    UPNP Enabling:
    ADVANCED FEATURE! Allows you to turn the UPNP feature of the Router on or
    off. If you use applications that support UPnP, enabling UPnP will allow
    these applications to automatically configure the router. More Info
    - UPNP Enable / Disable

    ....and disable, then enable it. The icon then comes back and stays maybe
    for a few hours, maybe a couple of days. Nothing specific seems to cause it
    to disappear.

    Any ideas?
     
    Chris Smithers, Apr 21, 2006
    #1
    1. Advertisements

  2. Chris Smithers

    John Navas Guest

    [POSTED TO alt.internet.wireless - REPLY ON USENET PLEASE]

    In <Ak32g.56926$> on Fri, 21 Apr 2006
    Are you running peer-to-peer filesharing (e.g., Bittorrent) with lots of
    connections? That may be causing your cheap router to "fall over" and die.
    If so, sharply reduce the number of connections.
     
    John Navas, Apr 21, 2006
    #2
    1. Advertisements

  3. No. I do have Skype installed but there's nothing I can do about that. The
    router itself isn't dying, it is just losing its UPNP Internet Gateway - but
    the connection to the Internet stays alive. It seems like an XP problem, as
    the Gateway is an XP feature.

    Anyone got any other ideas? Thanks.
     
    Chris Smithers, Apr 21, 2006
    #3
  4. Chris Smithers

    alien Guest

    My my network places would stop opening. It would open once, but on
    subsequent tries, nothing would happen. Just an hour glass for about a half
    second, then nothing. I read somewhere that if you "don't show networked
    upnp devices" in the network tasks (on the left hand side of my network
    places window) , that would solve the problem of the window not opening.
    This cured my problem. Maybe try disabling if enabled or enable if disabled
    and see if it makes a difference for your problem. I've had mixed luck with
    MSN messenger file transfers over the years. They always start out
    screamin' fast but often slow to a crawl after a few seconds. That said,
    sometimes they work fine. Go figure.

    alien
     
    alien, Apr 21, 2006
    #4
  5. Thanks but I think we misunderstand each other. I'm talking about my
    Internet Gateway failing, whereas you're talking about your Network Places
    folder not opening. Thanks anyway!
     
    Chris Smithers, Apr 22, 2006
    #5
  6. Chris Smithers

    alien Guest

    It might seem at first that there's no correlation, but what is similar is
    that I too had an internet gateway device icon when I had the show upnp
    devices enabled. And it would disappear just like yours. I never worried
    about the icon not being there because my network speeds didn't seem to slow
    down, other than msn messenger maybe. My ReplayTVs both worked fine over
    the LAN, but they might not be upnp, I can't remember. Since I clicked
    don't show my upnp devices, everything has been running smoothly. Try it,
    maybe you'll like it. The icon I had only opened the config page for the
    router anyways. A browser window is all that's needed to get to the config
    page.

    alien
     
    alien, Apr 22, 2006
    #6
  7. I clicked it and a warning came up saying "This will also close the Windows
    Firewall ports so that the UPnP device software can no longer discover
    networked UPnP devices."!

    That would get me no further than losing the Internet Gateway in the first
    place. Thanks anyway but that isn't the solution.
     
    Chris Smithers, Apr 22, 2006
    #7
  8. Chris Smithers

    alien Guest

    I found this about upnp devices. Maybe it can help you.

    http://support.microsoft.com/?kbid=886257&SD=tech

    alien
     
    alien, Apr 22, 2006
    #8
  9. Chris Smithers, Apr 23, 2006
    #9
  10. It gets weirder. I noticed the UPnP Internet Gateway tasktray icon had
    disappeared again, so I opened My Network Places, and Broadband Router was
    still listed (so obviously still recognised as a UPnP device).

    I then opened Network Connections, and the Internet Gateway icon wasn't
    there any more as suspected... for a second... but then it suddenly
    appeared, as did the tasktray icon!

    By opening Network Connections I had tripped the system into reactivating
    the Gateway. Ideas?...
     
    Chris Smithers, Apr 23, 2006
    #10
  11. I found this note concerning disabling RIP listener service when
    running UPnP devices.
    http://cc.uoregon.edu/cnews/spring2003/upnp.html
    I think this may a clue as to why the Internet Gateway is
    disappearing.

    I have zero experience with UPnP but lots in dealing with broken RIP-1
    implementations on SCO Unix. What happens is that RIP is listening
    for broadcasts from other RIP enabled devices. If it hears one, it
    merrily changes the routing table depending on the payload. The
    problem is that there's no integrity check, no authentication, no
    nothing to validate the payload or the sender. In the distant past,
    Windoze NT4 v3.51 servers would not mix well with SCO OSR5 Unix boxes
    running RIP because NT4 was belching garbage that Unix was
    interpreting as valid routing updates. Loss of connectivity was the
    inevitable result. Disabling RIP-1 was the solution.

    It's also possible that your Belkin F5D7231-4 has RIP running and is
    transmitting RIP updates. It only takes one trashed packet and the
    router table on your computer will be mangled. You might want to
    compare the results of the:
    route print
    incantation before and after the gateway goes away. You should see a
    change (or garbage). As RIP updates are broadcasts, they go
    everywhere including via the wireless. I don't worry much about
    trashed packets via wired ethernet. However, it a common problem via
    wireless.

    The disappearing icon is controlled by Internet Gateway Device
    Discovery Service.
    http://support.microsoft.com/?kbid=821371
    It's purpose in life is to snoop all over your network looking for
    UPnP devices worth taking over and assimilating them into the Borg
    er... your network. The icon is apparently part of some monitoring
    scheme. No clue how it works but I suspect if it loses a few packets,
    it's going to either complain or disappear. My guess is disappear. No
    clue how well it can recover. You may be experiencing excessive
    packet loss on your wireless (an indication of interference) which is
    causing the packet loss.

    Also, you pronounce that you're using a "Belkin Wireless G Plus router
    (F5D7231-4 with latest firmware)". Please note that by being too lazy
    to disclose the exact version number, we have no way to verify that
    you really do have the latest. What's on the web pile is often NOT
    the latest firmware. Manufacturers release experimental versions for
    specific problems all the time. For Belkin, there is at least one
    product where what is on the distribution CDROM is later and better
    than what is on the web pile. Kindly disclose the version number and
    cease making assumptions.

    My turn for a question. Why do you insist on using the UPnP Internet
    Gateway feature? I'm familiar with its features and functions and
    find no reason why you are required to do so. What do you see as a
    benefit? Just curious.
     
    Jeff Liebermann, Apr 23, 2006
    #11
  12. Hi Jeff, thanks for the ideas...

    I already have RIP listener disabled so I'm guessing it's not the cause.
    Thanks. Where do I find RIP in Belkin's config page (can't see it at all so
    assume it doesn't run it), and the 'route print' (can't see that either)?
    That could be so, if I wasn't using wired to the machine in question. I
    only use the wireless part of the router for my Media Center Extenders and
    Windows Mobile device - and they all behave very nicely.
    I beg your pardon? Gosh, you don't mince words do you! :-| I thought
    "Belkin Wireless G Plus router (F5D7231-4 with latest firmware)" was pretty
    informative by post posters' standards!

    The firmware revision is 4.07.07 and I'm normally pretty good at hunting
    down the latest version hence my statement that it is the "latest firmware"
    (the 'latest' they 'pronounce' on their site is 4.05.03). I am however open
    to being proven wrong.
    "insist"? "pronounce"? I never knew I did all those things! Hehe
    seriously though, quite simply because I need what it does. I use eDonkey,
    MSN Messenger, Overnet, BitTorrent, and peer-to-peer games. They all work
    *much* better and faster with UPnP devices, without exception. Add to that
    the fact I have a UPnP capable router, and OS, and it would be stupid not to
    use all that technology and switch it off. It speeds up MSN file transfers
    by 10x for example. Brilliant.

    I would rather live with having to reactivate the UPnP every 1 or 2 days,
    than disable it altogether because some people on the web write bad things
    about it.
     
    Chris Smithers, Apr 23, 2006
    #12
  13. I guess someone else has already commented on the security aspects of
    even turning uPnP on at all?
    I was wondering that too, but assumed it had been covered earlier. The
    router will work just fine without it as far as I'm aware.
    Mark McIntyre
    --
     
    Mark McIntyre, Apr 23, 2006
    #13
  14. .... then you get what you deserve :)
    I'd be fascinated to hear a technical explanation for why enabling an
    insecure and dangerously implemented protocol can sped up file
    transfers. No kidding - all the protocol does is allow apps to open
    and close your firewall ports themselves (including, bear in mind,
    apps outside your network).
    *shrug*. You can lead a horse to water, I guess. :)
    Mark McIntyre
    --
     
    Mark McIntyre, Apr 23, 2006
    #14
  15. I don't have an F5D7231-4 handy so I can't check. It's usually on a
    page with "static routes" or something similar. If you can't find the
    setting, then Belkin probably doesn't support RIP.

    The "route print" is a Windoze command line incantation.
    Start -> Run -> cmd <enter>
    route print

    If Belkin doesn't support RIP and you have it disabled in XP, then
    it's probably not the cause of the disappearing gateway.
    Since this is a wireless internet newsgroup, I just assumed a wireless
    connection. A wired ethernet connection through a switched port does
    not produce data corruption. So much for that theory.
    Assumption is the mother of all screwups. I used to be a nice person
    until I started trying to answer questions in newsgroups. Yeah,
    you're correct. I should be thankful that you supplied the maker and
    model number which is much more than is usuallly supplied. I just
    finished dealing with a friend and competitor, who absolutly insisted
    that his firmware was the latest (it wasn't), his Windoze was updated
    to the latest patches (it wasn't), his configuration was perfect (it
    wasn't), and that his RADIUS server was configured for the correct
    port number (it wasn't). Let's just say I had a morning full of
    assumptions.
    I assume you mean the UK version. The web pile shows 4.05.03 as the
    latest.

    http://www.belkin.com/support/download.asp?download=F5D7231-4&lang=1&mode=
    4.07.07 appears to be the latest. OK, I'm impressed. Nicely done and
    I can do no better.
    Well, methinks that's part of the problem. Most cheapo routers fail
    in some manner with common file sharing programs due to the tendency
    for them to open hundreds of parallel streams. The router just can't
    handle it. If you check the release notes on various routers, many
    show firmware fixes and tweaks for BitTorrent and such.
    No way. To the best of my knowledge, the only thing that UPnP does is
    open IP ports on the router for enabling various services on the
    clients. There are no performance enchancements or tweaks involved in
    UPnP. Are you sure you're getting a performance boost? Have you run
    any tests or investigated what UPnP changed? How much better?
    Well, I suppose there's logic in that. If it's there, it should work.
    MSN Messenger uses incoming ports 6891-6900 (TCP). You could just
    configure your router to forward these ports to your desktop. Did you
    compare performance with UPnP to configure these ports versus manually
    forwarding them? If you really did get a 10x performance boost, I
    would suspect something is either broken or something odd is
    happening. I don't use MSN Mess for file transfers and haven't tried
    such benchmarking so I've never seen this effect.
    Try turning off your file sharing servers for a few days and see if it
    magically solves the problem.
     
    Jeff Liebermann, Apr 24, 2006
    #15
  16. Hi Jeff, thanks for the comments.

    Basically, I don't mean UPnP itself is a speed booster, but if you don't use
    it then programs like MSN cannot open the firewall ports themselves, and
    therefore the transfer speed dramatically drops due to the firewall in
    place. This is well documented on MS's site.

    If you configure the ports to stay open 24/7 yourself, then that is a
    security risk.

    I love UPnP as it opens ports my programs need, when they need them, lets
    through high-speed data, then closes them again when I'm done.

    I can live with it dropping every 1 or 2 days, rather than lose that.
     
    Chris Smithers, Apr 24, 2006
    #16
  17. Could I trouble you for a reference or URL? I don't believe that the
    method of opening ports has any effect of file transfer speeds.
    Perhaps you mean the time it takes to initate a file transfer.

    Incidentally, this is one recommended setup your Belkin F5D7231-4 for
    MSN Mess:
    | http://www.portforward.com/english/routers/port_forwarding/Belkin/F5D7231-4/MSN_Messenger.htm
    without UPnP. I'm not sure I like the way this was done because it
    leaves the voice and file transfer ports open when they should be
    setup with port triggering. Yech... not good.

    This is the port triggering setup for a Linksys router.
    | http://www.webhazard.com/html/linksys_port_triggering.html
    This is much better because it uses port triggering, which dooes not
    leave the ports open all the time as in the first setup.
    True. As I understand it (may be wrong), MSN Messenger leaves one or
    two ports open all the time when running.
    So does port triggering.
    Incidentally, instead of MSN Messenger, I use Gaim, Miranda IM, and
    Trillian.
    http://gaim.sourceforge.net
    http://www.miranda-im.com
    http://www.ceruleanstudios.com
     
    Jeff Liebermann, Apr 24, 2006
    #17
  18. Sorry I can't find it right now, but if you do a transfer in MSN without
    UPnP active, a little message pops up saying 'experiencing slow file
    transfers?' then takes you to a page telling you how to open ports in the
    firewall.
     
    Chris Smithers, Apr 24, 2006
    #18
  19. This isn't true. MS may say it, but they also said Windows 98 was a
    great computing platform, and that Linux wouldn't go anywhere.
    Can't find any such reference I'm afraid.
    Depends. Its only a risk if the server at the pointy end is
    vulnerable. The problem with uPnP is that it can be used to open *any*
    port, and you can't reasonably control what connects to them.
    I really think you've been sold a pup with this high speed data idea.
    Mark McIntyre
    --
     
    Mark McIntyre, Apr 24, 2006
    #19
  20. All this proves is that MSN tries to use uPNP, and can detect its not
    active. MS then pop up a meaningless dialog box. It doesn't say you
    actually *are* experiencing slow file transfers.

    IMHO you're being misled by the advertising.
    Mark McIntyre
    --
     
    Mark McIntyre, Apr 24, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.