Unable to remove Read-Only attribute from folders

Discussion in 'Computer Support' started by John Komar, Mar 20, 2005.

  1. John Komar

    John Komar Guest

    My PC is virtually useless to me because all of my folders are marked
    read only, therefore I cannot edit files in those folders. I have
    tired to change the attribute of the folders so that they are no
    longer read only, but I can't. The read only check box is checked with
    a grayed out check.. However, I am able to de select the check mark,
    but after I do that and then re open the folder the check is back
    again. It's very frustrating. I am running Windows XP SP2, however,
    before I upgraded to XP2 this same problem existed. I had hoped that
    the upgrade would fix it but it didn't.

    I researched this problem and tried the fix which is outlined at
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;256614
    however after following the instructions on that page to the letter my
    folders are still read only.

    I am desperate here. How can I fix this problem?

    I also found another web page which indicates that this is a common
    problem and there are other people like me who can't fix it. Please
    refer to this page at
    http://www.windowsitpro.com/Article/ArticleID/24940/24940.html .

    I really hope that a Microsoft MVP or someone else can help me with
    this. It's ridiculous that I can't change my folders from read only.
    If I can't fix it I am wondering is this is sufficient reason to take
    Windows XP back for a refund.

    Thanks for your help.

    John
     
    John Komar, Mar 20, 2005
    #1
    1. Advertisements

  2. John Komar

    John Guest

    I have a small correction. Actually, I can edit text files but I
    cannot edit a lot of other files because they are in read only
    folders.
     
    John, Mar 20, 2005
    #2
    1. Advertisements

  3. Normal XP behavior. You won't get a refund (even given your ignorance) but
    can install Fedora http://fedora.redhat.com/ for FREE.
     
    Sleepless in Seattle, Mar 20, 2005
    #3
  4. John Komar

    Pennywise Guest

    |> On Sat, 19 Mar 2005 18:25:06 -0800, John Komar
    |>
    |> >My PC is virtually useless to me because all of my folders are marked
    |> >read only, therefore I cannot edit files in those folders.
    |>
    |> I have a small correction. Actually, I can edit text files but I
    |> cannot edit a lot of other files because they are in read only
    |> folders.

    Sticking my neck out here, but this page is wrong
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q256614

    UseSystemForSystemFolders with a value of 1 would place the system bit
    on a folder, right?

    Attrib will not remove the read only bit from a system file so the
    example:

    attrib -r +s c:\test "needs to be" attrib -s -r c:\test

    ??
     
    Pennywise, Mar 20, 2005
    #4
  5. have you tried logging on as the administrator?

    richard
     
    Richard Benjamin, Mar 20, 2005
    #5
  6. John commented courteously...
    John, I'm hardly an MVP, so I don't understand your issue.

    My XP Pro SP1 folders are also read-only as yours are, but
    there's no check mark. And, I can not only edit *every*
    file in *every* folder on my PC (that includes files I've
    transferred from CD-R since XP automatically turned off
    the read-only bit), I can also rename or delete *any*
    folder.

    Not disputin' ya, just don't understand...
     
    All Things Mopar, Mar 20, 2005
    #6
  7. John Komar

    John Guest

    Given my ignorance? LOL. And I suppose you're a genius.
     
    John, Mar 20, 2005
    #7
  8. John Komar

    John Guest

    Yes. It didn't matter.
     
    John, Mar 20, 2005
    #8
  9. John Komar

    David Candy Guest

    They are NOT marked read only.
     
    David Candy, Mar 20, 2005
    #9
  10. John Komar

    John Guest

    Join the club, Jerry. I don't understand either, but then according to
    another poster in this thread I'm ignorant.

    I didn't mean to suggest that every XP user has the same problem that
    I do. But if you read the link that I posted you will see that many
    people do even though you do not.

    I just wish I knew what's going on. When I use CoolEdit to edit a WAV
    file I cannot save the edited file with the same file name because I
    get an message that says "error - directory write protected." It's the
    same thing in a lot of other cases such as when I try to edit Open
    Office files, although as I said I can edit text files with Notepad.
     
    John, Mar 20, 2005
    #10
  11. John Komar

    John Guest

    Did you come over to my house and look at my computer? Or are you
    calling me a liar? I am telling you that they are marked read only.
    Didn't you read the link that I posted in my OM?
     
    John, Mar 20, 2005
    #11
  12. John commented courteously...
    I read some more of this thread, and still don't
    understand, again, same as you. And, I ran a spat more
    "tests" on my system, including the "customize this
    folder" stuff from the MS KB article and can't create your
    problem. I guess I should stop looking a gift horse in the
    mouth!

    Sorry I can't help. Hope you find a reasonable solution
    soon!
     
    All Things Mopar, Mar 20, 2005
    #12
  13. John Komar

    Jim Guest

    You may not be able to edit the files, but the readonly attribute is not the
    reason. Every folder on my computer shows the readonly attribute checked,
    but I can do whatever I wish with any file in any folder.
    Jim
     
    Jim, Mar 20, 2005
    #13
  14. John Komar

    David Candy Guest

    It shows indeterminate not checked or unchecked.
     
    David Candy, Mar 20, 2005
    #14
  15. John Komar

    Pennywise Guest

    |> I just wish I knew what's going on. When I use CoolEdit to edit a WAV
    |> file I cannot save the edited file with the same file name because I
    |> get an message that says "error - directory write protected."

    Try this:

    Open a command window (WinKey+R) <type in> cmd <enter>
    type in:
    CD \
    attrib -R *.* /S

    This will remove the read only bit on all files, and not hurt anything.

    You will receive a lot of errors don't worry about them.

    I also can't see why your having this problem but Microsoft actually
    addresses it...
     
    Pennywise, Mar 20, 2005
    #15
  16. John Komar

    John Guest

    Thanks, but I already tried that. That was already outlined in the
    Microsoft Page that I posted a link to in my OM. However, it didn't
    work.
     
    John, Mar 20, 2005
    #16
  17. John Komar

    Pennywise Guest

    |> On Sun, 20 Mar 2005 03:57:21 GMT, wrote:
    |>
    |> >Try this:
    |> >
    |> >Open a command window (WinKey+R) <type in> cmd <enter>
    |> >type in:
    |> >CD \
    |> >attrib -R *.* /S
    |>
    |> Thanks, but I already tried that. That was already outlined in the
    |> Microsoft Page that I posted a link to in my OM. However, it didn't
    |> work.

    No those links were Folders that was for all your files. (just in case
    your file was protected).

    Follow MS's page, but use my suggestion. (it's harmless)

    You might be fighting the UseSystemForSystemFolders, just hope the
    attrib command is faster :)
     
    Pennywise, Mar 20, 2005
    #17
  18. John Komar

    Jerry G. Guest

    Before applying the solution, did you log on as the Administrator?

    So, if you never used the folder customization feature, this bug would never
    have shown up.

    --

    Jerry G.
    =====

    My PC is virtually useless to me because all of my folders are marked
    read only, therefore I cannot edit files in those folders. I have
    tired to change the attribute of the folders so that they are no
    longer read only, but I can't. The read only check box is checked with
    a grayed out check.. However, I am able to de select the check mark,
    but after I do that and then re open the folder the check is back
    again. It's very frustrating. I am running Windows XP SP2, however,
    before I upgraded to XP2 this same problem existed. I had hoped that
    the upgrade would fix it but it didn't.

    I researched this problem and tried the fix which is outlined at
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;256614
    however after following the instructions on that page to the letter my
    folders are still read only.

    I am desperate here. How can I fix this problem?

    I also found another web page which indicates that this is a common
    problem and there are other people like me who can't fix it. Please
    refer to this page at
    http://www.windowsitpro.com/Article/ArticleID/24940/24940.html .

    I really hope that a Microsoft MVP or someone else can help me with
    this. It's ridiculous that I can't change my folders from read only.
    If I can't fix it I am wondering is this is sufficient reason to take
    Windows XP back for a refund.

    Thanks for your help.

    John
     
    Jerry G., Mar 20, 2005
    #18
  19. John Komar

    B0B Guest

    The posted link was to an article about how to fix the problem in Windows
    2000, Windows NT 4.0, Windows Millennium Edition, Windows 98, and Windows
    95, Not XP.
     
    B0B, Mar 20, 2005
    #19
  20. John Komar

    John Guest

    Thanks for trying to help but I tried attrib -s -r c:\test and that
    didn't work either.

    It's a God damned Microsoft bug and I'm hopping mad about it. Where do
    they get off charging me $199.99 for an operating system that doesn't
    work?
     
    John, Mar 20, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.