Unable to get an IP Address from Router.

Discussion in 'Broadband Hardware' started by Tmuldoon, Jul 3, 2007.

  1. Tmuldoon

    Tmuldoon Guest

    Help!

    Hello,

    I have a Linksys Wireless G router and 2 XP computers that were
    working fine.

    I am using it wired - no wireless being used.

    Now one get an error that is there is low network connectivity and
    cannot connect to anything.

    The other computer - fine. So X - no connection, Y - connected

    I tried swapping cables - same situation (different ends, new cable,
    the one from Y) - X no network, Y is fine. Switched router ports -
    same situation X-no, Y - yes

    Plugged in modem directly into X - works FINE.

    I did check the security center in the control panels - in both cases
    the fire wall is on, but the windows firewall is off. I cannot
    disable the firewall from X - it must be the router firewall (I tried
    removing any filtering from the router - same issue). Again, Y works
    fine.


    Only when going through the router does this cause a problem.

    Direct connection is fine.

    To top it off, when computer X is booted up in safe mode and going
    through the router - it is fine. An IP address is taken. In regular
    mode the computer boots up and shows an IP address of 169.254.x.x. I
    tried power cycling the mode, router, both, reboots - same issue
    169.254.x.x. I tried hard coding the IP address to the one found on
    the router and in the range of the router - no dice.

    Why can't I get an IP address from DHCP?

    Computer X does not Norton Antivirus on it - I disabled it in regular
    mode - same problem. I do not want to uninstall it.

    I read about a Service Pack 2 problem with XP - but the problem does
    not appear in Safe Mode with Networking and I did try the fixes my MS
    about it - to no avail. The underlying issue is that computer X
    cannot get an IP address from the router.

    Computer X work when:
    - there is a direct connection from the modem (DSL) to the computer
    in regular mode
    - booted up in Safe Mode and attached to the router - can ping it,
    surf the net

    Computer Y is fine with the Router.

    Suggestions on how to proceed?

    Help!

    Thanks!

    Tmuld
     
    Tmuldoon, Jul 3, 2007
    #1
    1. Advertisements

  2. Tmuldoon

    measoldier Guest

    Tmuldoon,
    Have you made sure that your "Windows" Firewall is turned "OFF". The
    routher has its own firewall. You can not have Windows firewall on at the
    same time.
     
    measoldier, Jul 28, 2007
    #2
    1. Advertisements

  3. Tmuldoon

    Tmuldoon Guest

    Hello,

    Yes, I made sure it was off.

    However the OS says a firewall is one. Norton is installed - but
    there is no firewall option.

    I killed all tasks associated with Norton - and still the same
    problem.

    Yet it works in Safe Mode. I can renew and release and IP in that
    mode. Not in regular mode.

    Very curious.

    Tmuld
     
    Tmuldoon, Aug 1, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.