Unable to connect to wireless network from laptop on Windows XP

Discussion in 'Wireless Networking' started by Edward Diener, Dec 18, 2009.

  1. I am trying to connect my laptop via a wireless connection to my D-Link
    DIR-655 router.
    The laptop is a Toshiba Satellite Pro L300D which as an Integrated
    Atheros 802.11b/g wireless LAN.
    I am running Windows XP on my laptop.

    Under Windows XP on my laptop it finds my wireless network by its name
    of 'MyWirelessNet' and I click on the entry and then on the Connect
    button. It prompts me for my network key and I type in 'Y2YT5689OPEE'. I
    then type this in again in the Confirm area also. It then attempts to
    connect, taking a very long time to do so with a message box and a
    message "Please wait while Windows connects to the 'MyWirelessNet'
    network" and another message below it which says "Waiting for the
    network...". Finally the Wireless Network Connection message box closes
    but the connection has not been made. No error message shows anything.

    Ideas, thoughts, solutions, experiences, or things I might try to get my
    laptop to connect wirelessly to the DIR-655 are most welcome.

    If I run a wired network cable from my laptop to the DIR-655 everything
    is successful. But naturally I want to connect wirelessly so I can move
    my laptop around. Isn't that what laptops are all about ?

    I am also successful connecting my laptop wirelessly to other wireless
    networks. But not to my DIR-655 router.
     
    Edward Diener, Dec 18, 2009
    #1
    1. Advertisements

  2. Hi
    It is probably authentication (PW) problem.
    Log to the Wireless Router with a cable, and disable the security. Make sure
    that you can connect to it when it is open.
    When it works OK, switch On the security enter a new pass phrase copy the
    pass phrase to the Copy buffer and then paste to the computer's password
    box.
    Make sure that the level of the security that you use is compatible with Win
    XP.
    In General.
    From the weakest to the strongest, Wireless security capacity is.
    No Security
    Switching Off SSID (same has No Security. SSID can be easily sniffed even if
    it is Off)
    MAC Filtering______(Band Aid if nothing else is available, MAC number can be
    easily Spoofed).
    WEP64____(Easy, to "Break" by knowledgeable people).
    WEP128___(A little Harder, but "Hackable" too).
    -------------------
    The three above are Not considered safe.
    Safe Starts here at WPA.
    -------------------
    WPA-PSK__(Very Hard to Break).
    WPA-AES__(Not functionally Breakable)
    WPA2____ (Not functionally Breakable).
    Note 1: WPA-AES the the current entry level rendition of WPA2.
    Note 2: If you use WinXP bellow SP3 and did not updated it, you would have
    to download the WPA2 patch from Microsoft.
    <http://support.microsoft.com/kb/893357>
    The documentation of your Wireless devices (Wireless Router, and Wireless
    Computer's Card) should state the type of security that is available with
    your Wireless hardware.
    All devices MUST be set to the same security level using the same pass
    phrase.
    Therefore the security must be set according what ever is the best possible
    of one of the Wireless devices.
    I.e. even if most of your system might be capable to be configured to the
    max. with WPA2, but one device is only capable to be configured to max . of
    WEP, to whole system must be configured to WEP.
    If you need more good security and one device (like a Wireless card that can
    do WEP only) is holding better security for the whole Network, replace the
    device with a better one.
    Setting Wireless Security - http://www.ezlan.net/Wireless_Security.html
    The Core differences between WEP, WPA, and WPA2 -
    http://www.ezlan.net/wpa_wep.html
    Jack (MVP-Networking).
     
    Jack [MVP-Networking], Dec 18, 2009
    #2
    1. Advertisements

  3. This was the first thing I tried and I still could not connect to the
    router wirelessly. What gets me is that Winodws XP gives absolutely no
    indication of why the connection failed. I'm a programmer and I think it
    is very poor giving no end-user feedback in that situation.
    I do not know how it can be determined what level of security is
    compatible with Windows XP. How can I determine that ? I keep up to date
    with the latest updates through Windows Update so I should always be up
    to date on my laptop.
    On the router I am using WPA-Personal, with a WPA mode set to Auto (WPA
    or WPA2) and Cipher type of TKIP and AES.
    Right now the only wireless device is the laptop, although I bought
    wireless USB for both my desktops which are currently wired to the
    router. Since my laptop has connected to other routers wirelessly, I
    wanted to solve my laptops connection to the router before I start
    playing around with connecting either of my desktops to the router
    wirelessly.
    I understand this principle. I am not sure how to determine what the
    laptop supports other than specifying what I did in my OP which is that
    the laptop supports 802.11b and 802.11g.
    Of course.
    Thanks for the info and links. Since I tried connecting with all
    security turned off and could not do so, I don't think it can be a
    security problem. I wish I knew what it was, though, as my router has
    many settings I can try manipulating but I don't know what the magic
    combo is to get it working. Of course I can eventually try talking to
    the D-Link support people but that is always a major trial nowadays.
     
    Edward Diener, Dec 18, 2009
    #3
  4. Edward Diener

    Guest Guest

    Try this, Log on to your Router and set up the built-in Wireless
    function. So with your laptop wired to the router try the following. Using
    your web browser, input 192.168.1.1 as the routers address. Then use admin
    as User Name and for Password, try password1. Hopefully this will give you
    access
    to your Router's software and the set-up for the wireless functions.
    Otherwise
    contact your Internet Service provider for instructions accessing your
    Router setup .
     
    Guest, Dec 18, 2009
    #4
  5. I can get into my router's configuration simply by using a wired
    connection from my laptop or from either of my two desktops so that is
    no problem. My router's wireless functionality is fully setup and I have
    tried to connect to it wirelessly from my laptop where there is no
    security and where the security is WPA-personal and both times have failed.

    My problem is not getting into my router's configuration and setting it
    up for a wireless connection.

    Thanks for your help, nonetheless.
     
    Edward Diener, Dec 18, 2009
    #5
  6. Edward Diener

    Lem Guest

    Responding inline is tempting, but with long posts it gets really
    difficult to follow.

    If you are certain that you have disabled wireless security in the
    router (and this includes not only encryption but anything else you
    might have set in an effort to increase security, such as MAC filtering)
    and still cannot connect, there are only a limited number of
    possibilities. You have eliminated most of them by saying that your
    laptop successfully connects to other wireless networks.

    First, clear out remnants of prior attempts to connect to your network.
    Go to Network Connections and right click on the icon for your
    wireless adapter and choose Properties. Select the Wireless Networks tab
    and Remove all entries that have your SSID. OK your way out. Now click
    the View Wireless Networks tab, locate your SSID in the list of
    available networks, and click Connect. I'll assume that you can't connect.

    Go back to your router's configuration utility (from a wired computer)
    and determine what wireless mode it is set to. The DIR-655 is a
    wireless-N router, but it can be set to operate as G-only, G&B, B-only,
    N-only, or mixed N,B,G. Make sure that the mode is compatible with your
    wireless adapter. If you don't know what your wireless adapter is,
    either set the router to Mixed N,B,G or (better) look up your adapter's
    model number in Device Manager and Google it.

    With respect to the level of security, Win XP sp3 supports (is
    "compatible with") WPA2-Personal if (and this is a big if) the wireless
    hardware in your laptop supports that. If your adapter is somewhat
    elderly, you may need to update a driver. See the website of your
    laptop's manufacturer for the appropriate driver. You should be able to
    determine what level of encryption is supported by your laptop's
    wireless adapter by going back to the Wireless Networks tab of the
    wireless adapter's Properties dialog, selecting a Preferred network from
    the list and clicking the Properties button. On the Association tab,
    you'll see a drop down box for "Encryption." Click the arrow and you
    should see the possibilities.
     
    Lem, Dec 19, 2009
    #6
  7. I tried that. Subsequently the Wireless Network Connection finds it
    again as a network within range. I clikc on my network, click
    Connect..., enter the netwrok key, the long connecting dialog comes up
    again, and it fails to connect again with no message.
    Unfortunately it still does not work.
    Boo ! <g>.

    Thanks for your suggestions.
     
    Edward Diener, Dec 19, 2009
    #7
  8. This finally solved the problem. The laptop supports 802.11b/g and when
    I changed the router to mixed mode 802.11b / 802.11g from its previous
    setting of mixed mode 802.11b / 802.11g / 802.11n, presto !!! Everything
    works now. I am now a happy camper.
     
    Edward Diener, Dec 19, 2009
    #8
  9. To everyone who replied helping me out with this problem, I want to say
    thanks. By changing my router's setting from mixed mode 802.11b /
    802.11g / 802.11n to mixed mode 802.11b / 802.11g the connection was
    finally made. My laptop supports only 802.11b / 802.11g so I guess
    setting my router to support all three caused the problem ( although as
    a programmer I don't think it should ).
     
    Edward Diener, Dec 19, 2009
    #9
  10. Edward Diener

    Lem Guest

    Thanks for letting us know. I'm glad you got it working. You're correct
    that "Mixed N,B,G" *should* have worked, but it's not worth spending
    more effort at this point to find out why it didn't.
     
    Lem, Dec 19, 2009
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.