Unable to access HDD / Windows unable to complete format

Discussion in 'Hardware' started by rmundy, May 27, 2010.

  1. rmundy

    rmundy

    Joined:
    May 27, 2010
    Messages:
    10
    Likes Received:
    0
    I just thought I'd share a problem that I came across recently as it might save someone else from losing data or thinking their hard drive is dead.

    The laptop that I was having the problem with is a Dell D620 running Windows XP SP2.


    Whenever I tried to access two of my three USB hard drives I received the error saying that the disk needs to be formatted although all three worked fine on other XP machines.

    I backed up the contents of one of the drives then tried to format using my laptop, but received an error saying that Windows was unable to complete the format (very informative as always).

    Eventually I noticed that the two drives I couldn't access/format were using FAT32, while the third drive that I could access and my internal laptop hard drive were both using NTFS.


    I started digging around inside Windows and found that NTFS and FAT partitions use different drivers. Default locations;

    C:\WINDOWS\system32\drivers\fastfat.sys
    C:\WINDOWS\system32\drivers\ntfs.sys


    To force Windows to re-load the driver, I changed the file name to "fastfat_BACKUP.sys" then rebooted the laptop.

    Once it had booted back up Windows had re-created fastfat.sys and I was able to access all of my hard drives again and more importantly my data :D

    I can only assume that the original driver had become corrupt somehow (Windows update maybe?!).

    NOTE: IF YOUR WINDOWS PARTITION IS FAT/FAT32, OR YOU'RE ABLE TO ACCESS A FAT/FAT32 DRIVE THEN THIS WILL NOT APPLY.



    Hope this helps someone else out!
     
    Last edited: Jun 7, 2010
    rmundy, May 27, 2010
    #1
    1. Advertisements

  2. rmundy

    greentech07

    Joined:
    Aug 2, 2010
    Messages:
    2
    Likes Received:
    0
    Using the Group Policy Editor in Windows XP Professional

    1. Click Start, Run, type gpedit.msc and click OK.
    2. Under User Configuration, Click on the plus (+) next to Administrative Templates
    3. Click on the plus (+) next System, then click on Ctrl+Alt+Delete Options
    4. Find Remove Task Manager in the right-hand pane and double click on it
    5. Choose the option "Not Configured" and click Ok.
    6. Close the Group Policy Window
    try some registry cleaner to make use of it (reginout)
     
    greentech07, Aug 13, 2010
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.