Trying to disable ethernet bonding

Discussion in 'Linux Networking' started by mark.bergman, Nov 2, 2012.

  1. mark.bergman

    mark.bergman Guest

    I have a RHEL system that has 2 Ethernet interfaces combined into an IP bond, usual thing with ifcfg's for bond0, eth0, eth1.
    I now want to disable the bond, and use the two Ethernet interfaces for separate networks, with different IP addresses.

    So, I delete the ifcfg-bond0 in /etc/sysconfig/network-scripts (and in /etc/sysconfig/network/profiles/default and /etc/sysconfig/network/devices), edit the ifcfg-eth0 and eth1 to remove the MASTER and SLAVE entries and restore the IPADDR & NETMASK.
    If I just do ifconfig bond0 down, ifconfig eth0 down then up, ifconfig eth1 down then up,
    and try to ping, I get a repeated error that Operation Not Possible (or something like that).
    If I reboot, the ifcfg-bond0 files are recreated, and the ifcfg-eth0/1 files are edited to append MASTER/SLAVE entries!!

    So, how do I do this?! (and what is recreating the bond0 file etc)?

    mark.bergman, Nov 2, 2012
    1. Advertisements

  2. mark.bergman

    the Guest

    Is this RHEL 6? Is the interface controlled by the Network Manager? If they are you'll wanted to delete the interface using the Manager. I think it is under preferences then network connections in the gnome gui.
    the, Nov 2, 2012
    1. Advertisements

  3. If NM is involved the only way that I know of to prevent NM from
    handling the interfaces is if they are set as static. Otherwise you have
    to remove/disable Network Manager. At least that is how it works in
    Jonathan N. Little, Nov 2, 2012
  4. mark.bergman

    mark.bergman Guest

    No, RHEL 4.5
    mark.bergman, Nov 5, 2012
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.